Passenger window switch inoperative - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 11 (permalink) Old 12-28-2009 Thread Starter
SHELBY GT 350 Member
5.0L Member
 
YLDPONY's Avatar
 
Joined: Nov 2009
Location: Thornville
Posts: 8,798
 
Passenger window switch inoperative

My passenger window switch does not want to work at all. It is like I have the "window lock" on the driver's side on all the time (yes, I have tried cycling it many times). The window works fine when operated from the drivers side. I was just curious if this was a known problem, and which door should I start with? The "window lock" on the drivers side, the switch on the passenger side, or somewhere else?
Just another reason I wish I had waited for a GTS...

Thanks guys!

'94 Laser red 'vert. Still a 5-oh... for now
YLDPONY is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 12-28-2009
Made Member
V6 Member
4.6L Member
 
Black_35th's Avatar
 
Joined: Nov 2009
Location: Inland Sea urban
Posts: 722
 
Quote:
Originally Posted by YLDPONY View Post
My passenger window switch does not want to work at all. It is like I have the "window lock" on the driver's side on all the time (yes, I have tried cycling it many times). The window works fine when operated from the drivers side. I was just curious if this was a known problem, and which door should I start with? The "window lock" on the drivers side, the switch on the passenger side, or somewhere else?
Just another reason I wish I had waited for a GTS...

Thanks guys!
It could just be that the passenger side switch needs replacing.

10+ Year Mustang owner.
99 Mustang GT - mint condition
-
04 Terminator - Pullied, diablo predator tuner with dyno tune, airbags, MM subs/cc plates, Wilwood brakes, 4 point roll bar, FR500 steering wheel, staggered bullitts, JLT cai, Magnaflow exhaust, mgw shifter

00 V6 - Kenny Brown V6 stuff, Dr Gas x pipe
Black_35th is offline  
post #3 of 11 (permalink) Old 12-29-2009
SHELBY GT 350 Member
 
302Feen's Avatar
 
Joined: Jan 2008
Location: Norman
Posts: 6,939
 
Quote:
Originally Posted by Black_35th View Post
It could just be that the passenger side switch needs replacing.
I agree.
If the switch on the drivers side door will move the passenger window, but the switch on the passenger side won't work, then it's more than likely just the switch.

-1994 Mustang GT "The Red Baron": 3.73 gears,K&N filter,GT40 tubular intake,BBK Full Length Headers,modified midpipe & Flowmaster muffs, timing at 12*. Best time- 14.74 @ 93.16
-Check profile for pics of our car collection!
- AmericanMuscle ROCKS!!
- "True Hot-Rods don't have valve covers!"
302Feen is offline  
post #4 of 11 (permalink) Old 12-29-2009
Apprentice
5.0L Member
 
D-stang95's Avatar
 
Joined: Aug 2009
Location: Bridgewater
Posts: 56
 
i have the same problem, it's the switch.
D-stang95 is offline  
post #5 of 11 (permalink) Old 12-29-2009 Thread Starter
SHELBY GT 350 Member
5.0L Member
 
YLDPONY's Avatar
 
Joined: Nov 2009
Location: Thornville
Posts: 8,798
 
Sounds good. Surgery I will start there. The only other thing I was thinking it could be is the "window lock" stuck engaged.

'94 Laser red 'vert. Still a 5-oh... for now
YLDPONY is offline  
post #6 of 11 (permalink) Old 12-30-2009
SHELBY GT 350 Member
 
302Feen's Avatar
 
Joined: Jan 2008
Location: Norman
Posts: 6,939
 
Quote:
Originally Posted by YLDPONY View Post
Sounds good. Surgery I will start there. The only other thing I was thinking it could be is the "window lock" stuck engaged.
I've never seen a "window lock" on any SN95 Mustang.......?

-1994 Mustang GT "The Red Baron": 3.73 gears,K&N filter,GT40 tubular intake,BBK Full Length Headers,modified midpipe & Flowmaster muffs, timing at 12*. Best time- 14.74 @ 93.16
-Check profile for pics of our car collection!
- AmericanMuscle ROCKS!!
- "True Hot-Rods don't have valve covers!"
302Feen is offline  
post #7 of 11 (permalink) Old 12-30-2009
PONY Member
5.0L Member
 
Dick's Avatar
 
Joined: Dec 2008
Location: Colonial Heights
Posts: 477
 
I had the same problem on my 95 stang I took the switch out and cleaned the contacts and put dielectric grease on them and its been working like new. For some reason the right door window and door lock switch would work great and then they would start to fade I cleaned them more than once and they would work ok for awhile and then stop. My son told me to clean them again and this time put some dielectric grease on the contact points to keep them from corroding, this fixed the problem. I used 400 grit sandpaper folded it over and pulled it back and forth through the contact points untill they were clean and then greased them, (this should fix the switch).
Dick is offline  
post #8 of 11 (permalink) Old 12-30-2009 Thread Starter
SHELBY GT 350 Member
5.0L Member
 
YLDPONY's Avatar
 
Joined: Nov 2009
Location: Thornville
Posts: 8,798
 
Thanks much man! I was wondering if cleaning it was possible. Hopefully this will save me some $

'94 Laser red 'vert. Still a 5-oh... for now
YLDPONY is offline  
post #9 of 11 (permalink) Old 12-31-2009 Thread Starter
SHELBY GT 350 Member
5.0L Member
 
YLDPONY's Avatar
 
Joined: Nov 2009
Location: Thornville
Posts: 8,798
 
Quote:
Originally Posted by 302Feen View Post
I've never seen a "window lock" on any SN95 Mustang.......?
Maybe this a 'vert only thing? Mine has a 5th button below the 4 window controls on the driver's side called "lock." It prevents the annoying passenger from playing with the window.

'94 Laser red 'vert. Still a 5-oh... for now
YLDPONY is offline  
post #10 of 11 (permalink) Old 12-31-2009 Thread Starter
SHELBY GT 350 Member
5.0L Member
 
YLDPONY's Avatar
 
Joined: Nov 2009
Location: Thornville
Posts: 8,798
 
Today at actually got above freezing, so a brushed off the car and examined the window switch. Bingo! Cleaning didn't work, dielectric grease and all, but a slight tweaking of the frail copper bars did. Thanks very much all!

'94 Laser red 'vert. Still a 5-oh... for now
YLDPONY is offline  
Rookie
 
scullydavidson's Avatar
 
Joined: May 2010
Location: Brighton
Posts: 1
 
I have to resurrect this one folks.
Jury rigging the switch is like blowing on the old Nintendo cartridges. Their has to be another solution to this one because my mustang has the same problem and the switch rig did not work.
Heres the deal.
The passenger switch will not operate the passenger window, but the driver side will. The lock button is not the problem. This is an even wierder problem, because if I hold the driver side switch down the window will start down, then if some hits the passenger side switch, it will stop the window from moving. I replaced the passenger side switch so that is not the issue here. I am thinking that their may be a problem with some sort of relay.
Anyone have any ideas on this one?
scullydavidson is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183