1994 Mustang GT, Dash wont light up, cant see gauges. - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 10 (permalink) Old 12-30-2009 Thread Starter
Rookie
5.0L Member
 
915.0lxnotch's Avatar
 
Joined: Sep 2009
Location: Auburn
Posts: 30
 
1994 Mustang GT, Dash wont light up, cant see gauges.

I have a 1994 GT .ok so my dash lights wont come on when i turn my headlights on. so i checked the switch and harness. the harness was burnt(common problem i hear). so i pulled one off another mustang, twisted the correct wires together after splicing, pluged the harness back into the headlight switch and turned on the headlights. headlights, corner llights, and fog lights all work.. but the dash still wont light up. i've still yet to check the bulbs in the dash.. could that be it or what. i've check fuse #13 which is the ilumination fuse for the dash. idk what else could be wrong. i want to be able to se my gauges at night!!.. im startin to go a little crazy lol.... can someone please tell me whats wrong. any ideas, thoughts, or knowledge helps. thank you.
915.0lxnotch is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 12-30-2009
Made Member
 
MUSTANGPAT93's Avatar
 
Joined: Jul 2009
Location: Sac
Posts: 843
 
Could also be the dimmer switch not working, Not the headlight switch. I would start checking other fuses just to be on the safe side and pull the cluster. I find it hard to believe every light is blown.

1993 COBRA, 115k miles on car 2k miles on everything else. Stroked and supercharged.

Snakes are still around some with more bite than others!
MUSTANGPAT93 is offline  
post #3 of 10 (permalink) Old 12-30-2009 Thread Starter
Rookie
5.0L Member
 
915.0lxnotch's Avatar
 
Joined: Sep 2009
Location: Auburn
Posts: 30
 
pull the cluster? yeah no dash lights come on at all
915.0lxnotch is offline  
post #4 of 10 (permalink) Old 12-31-2009
PONY Member
V6 Member
S197 Member
 
mercfocus's Avatar
 
Joined: Apr 2007
Location: San Diego
Posts: 380
 
I had that same problem since I got mine 2 years ago. Then somebody I know with a '97 GT who also had the same problem played with his switch a little bit and found the problem. I did the same to mine and found the same problem too. Both of us also didn't have working rear running lights. Check your tail lights to see if they don't light up.
I still have this issue. When I turn on my lights, I pull the switch all the way out and push it back in just a little bit. I mean very little bit. My dash then lights up and headlights go out. I have to keep pushing it in & out, a little bit, until both are working at the same time.
It's a hassle. If you don't find any other possibilities, you might want to try jerking the switch around like we had to.
mercfocus is offline  
post #5 of 10 (permalink) Old 12-31-2009
PONY Member
V6 Member
S197 Member
 
mercfocus's Avatar
 
Joined: Apr 2007
Location: San Diego
Posts: 380
 
I was talking about my '94GT, not the car in the pic to the left.
mercfocus is offline  
post #6 of 10 (permalink) Old 01-01-2010 Thread Starter
Rookie
5.0L Member
 
915.0lxnotch's Avatar
 
Joined: Sep 2009
Location: Auburn
Posts: 30
 
i've tried it all bro. nothin works. could be a short in a wire or fuse. taillights, headlight, corner and fog lights all work. i think i might just have to get a new dimmer switch
915.0lxnotch is offline  
post #7 of 10 (permalink) Old 01-03-2010
Made Member
5.0L Member
 
Yankeesfan239's Avatar
 
Joined: Jan 2009
Location: Cape Coral
Posts: 290
 
Send a message via AIM to Yankeesfan239 Send a message via MSN to Yankeesfan239 Send a message via Yahoo to Yankeesfan239
what happen when you turn the know left and right?

Car:1995 Mustang GT Convertible 5 Speed
Daily Driver color:Yellow ,Miles:105,000
MODS: Trickflow trackheat upper/ lower intake, edelbrock performer aluminum heads, e303 cam, 30lb injectors, 65mm throttle body, 75 mm MAF, bbk cold air intake, trw forged pistons, mac longtubes, shorty h pipe (no cats), flowmaster 40's,smog delete,egr delete,3.73 gears. 1.6 roller rockers, Walbro 255LPH High pressure fuel pump, Kirban performance Adjustable fuel Pressure Regulator, a9l ECU/MSD 6AL Ignition Box.
Yankeesfan239 is offline  
post #8 of 10 (permalink) Old 01-03-2010 Thread Starter
Rookie
5.0L Member
 
915.0lxnotch's Avatar
 
Joined: Sep 2009
Location: Auburn
Posts: 30
 
nothin happened. think not one dash bulb came on. still yet to get a voltmeter and check the fues power outlet and power to the wires.
915.0lxnotch is offline  
post #9 of 10 (permalink) Old 01-03-2010
Apprentice
 
1995Beast's Avatar
 
Joined: Feb 2009
Location: Saucier
Posts: 216
 
Quote:
Originally Posted by mercfocus View Post
I had that same problem since I got mine 2 years ago. Then somebody I know with a '97 GT who also had the same problem played with his switch a little bit and found the problem. I did the same to mine and found the same problem too. Both of us also didn't have working rear running lights. Check your tail lights to see if they don't light up.
I still have this issue. When I turn on my lights, I pull the switch all the way out and push it back in just a little bit. I mean very little bit. My dash then lights up and headlights go out. I have to keep pushing it in & out, a little bit, until both are working at the same time.
It's a hassle. If you don't find any other possibilities, you might want to try jerking the switch around like we had to.
I had this exact problem a good while back and it was a simple fix for me... I tried everything to get my lights to work properly but nothing seemed to work, not even a new switch. So I brought it to an auto electrical place and all it was was a da## fuze "the one thing i forgot to check". I paid them 40 dollars for them to tell me that. It was one of the fuzes by the pedals not under the hood if that helps.

5.0-Clean Machine
BBk under-drive pullies, BBk LT headers, BBk CAI, SCT chip, Edlebrock Performer Intake
1995Beast is online now  
PONY Member
V6 Member
S197 Member
 
mercfocus's Avatar
 
Joined: Apr 2007
Location: San Diego
Posts: 380
 
All my fuses are new. I put new fuses in it when I replaced the fuse box. The one by the pedals - it was fried when I bought the car. I mean totally burnt. I should probably put a pic of it in my profile somewhere because it really is that unbelievable until you see it. I had to get it out of a '97 V6 auto from the junkyard and crimp 31 connections.
I tried a new switch too before wiggling it around. I still havn't had time to get into it more. I've just been putting up with it, but then again, I don't have to drive this car a lot.
mercfocus is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182