Cooling fan relay location? - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 10 (permalink) Old 03-31-2011 Thread Starter
Apprentice
5.0L Member
 
garroxs's Avatar
 
Joined: Feb 2011
Location: San Luis Obispo
Posts: 131
 
Cooling fan relay location?

Looking for the location of the relay that controls the fans, a/c and fuel pump, on my 1994 gt, got the correct part #...has an "R" on it.
garroxs is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 03-31-2011
Rookie
 
jestrada1981's Avatar
 
Joined: May 2010
Location: Port St. Lucie
Posts: 2
 
I have a '95 and the relay that controls the fuel pump, A/C and fan is located on the bracket that holds the coolant overflow bottle. Try checking there, you should see the black box.
jestrada1981 is offline  
post #3 of 10 (permalink) Old 03-31-2011
GT Member
 
toyman's Avatar
 
Joined: Sep 2007
Location: Vernon
Posts: 2,406
 
It's called the CCRM (Constant Control Relay Module).

Richard
KB 2.1L, FRPP M5400-A Suspension System, FRPP Aluminum D/S, Shift Kit, Built TC, FRPP 3.73 Gears, Balanced Roller Cammed Engine, Edelbrock Performer Heads, Comp 270AH cam, AEM EMS, 3.5 Bar MAP, Zeitronix ZT-2 WB, FRPP 70mm TB, hardened AODE, modified UPR CAI, Be Cool Aluminum Rad
toyman is offline  
post #4 of 10 (permalink) Old 03-31-2011
Apprentice
V6 Member
5.0L Member
S197 Member
 
NickC's Avatar
 
Joined: May 2008
Location: Northwest corner
Posts: 111
 
Check out this link with a overview and location of relays.
94-95 Mustangs Electrical CCRM - Mustang-Tech
NickC is offline  
post #5 of 10 (permalink) Old 04-02-2011 Thread Starter
Apprentice
5.0L Member
 
garroxs's Avatar
 
Joined: Feb 2011
Location: San Luis Obispo
Posts: 131
 
wow...thats the stuff....I will check mine out with this info, and get back to this post...great information...thank you. My fan isn't working, that way ever since I bought it a month ago, Have a switch hooked up but want it right.
garroxs is offline  
post #6 of 10 (permalink) Old 04-02-2011
SHELBY GT 350 Member
5.0L Member
 
YLDPONY's Avatar
 
Joined: Nov 2009
Location: Thornville
Posts: 8,798
 
I'd try replacing the temperature sender (the one for the ECM, there are two of them) before you assume it's the CCRM. I'd at least test the CCRM and make sure it's the culprit.

'94 Laser red 'vert. Still a 5-oh... for now
YLDPONY is offline  
post #7 of 10 (permalink) Old 04-02-2011 Thread Starter
Apprentice
5.0L Member
 
garroxs's Avatar
 
Joined: Feb 2011
Location: San Luis Obispo
Posts: 131
 
Did the check on that first, no suprize it fell apart at first touch, replaced it hoping it was the issue, no luck....gotta get a volt meter.
garroxs is offline  
post #8 of 10 (permalink) Old 04-22-2012 Thread Starter
Apprentice
5.0L Member
 
garroxs's Avatar
 
Joined: Feb 2011
Location: San Luis Obispo
Posts: 131
 
Replaced the CCRM , found it on e-bay...25 bucks delivered, works perfectly, no more switch, kept it in place for emergency.

1994 gt 5.0 / 5 speed / 10th anniversay rims / 275/40/17 nexxen, Orical 651-8 inch stripes-self installed/ K&N filter / flowmaster/ 6 speakers w/JBL sub/ White Gauges w/ blue leds, blue led map light, White shift nob, 96' white tailligts w/ sequentials...
garroxs is offline  
post #9 of 10 (permalink) Old 04-23-2012
Made Member
5.0L Member
 
guitar_stitch's Avatar
 
Joined: Jan 2012
Location: Jacksonville
Posts: 363
 
It took you a year to complete this? Kudos on your persistence.

"Oh Good, my Dog found the Chainsaw"

'95 Mustang GT, 5 speed, O/R H-Pipe
Current Needs to Polish this Turd:
-AC Compressor
guitar_stitch is offline  
post #10 of 10 (permalink) Old 05-03-2012 Thread Starter
Apprentice
5.0L Member
 
garroxs's Avatar
 
Joined: Feb 2011
Location: San Luis Obispo
Posts: 131
 
With the switch in place and workin, the priorities list was the key.

1994 gt 5.0 / 5 speed / 10th anniversay rims / 275/40/17 nexxen, Orical 651-8 inch stripes-self installed/ K&N filter / flowmaster/ 6 speakers w/JBL sub/ White Gauges w/ blue leds, blue led map light, White shift nob, 96' white tailligts w/ sequentials...
garroxs is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in









Random Question

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183