Go Back   Ford Mustang Forums > Mustang > 2.3 and SVO Mustang > 2.3L Tech

Welcome to our Mustang forums where Mustangers come together to hang out, discuss and enjoy their favorite Mustang hobby with fellow Mustang enthusiasts. We invite everyone to read, post, and enjoy our Mustang forum as well as the many other sections of our site.

You are currently viewing our forums as a guest. By joining our community you gain access to post topics, communicate with members, upload your photos and access many other special features. Registration is fast, simple and free so why wait, join our Mustang community today! If you have any problems with registration or your account login, please contact support.

Introductions| Mustang Lounge | 2.3L Talk | 2.3L Tech | Mustang Tech | Tech | Racing | Regional

Reply   Post New Thread
Unread 08-07-2013   #1 (permalink)
KingDave is offline Rookie


Joined: Aug 2012
Posts: 36 Threads: 10
 KingDave's Country Flag  View KingDave's 1 photo
Courtenay   British Columbia
KingDave is on a distinguished road
Default Crank Position Sensor Bad ?

So my cars been acting up recently, it has never started when warm but the other day it stalled for the first time ever, and then started up right after while it was warm.. I cleaned the idle air controler and it seemed to idle smoother ( had really low idle before ) later that day i started up the car, it took a few cranks as usual but it fired, then almost immediately died, so i started it up again but this time i gave it some gas so it wouldnt die. I put the car in drive and i was on my way, the whole way home (6km) i was afraid to stop at a stop light and let it idle because i knew it was going to die. So i made it almost home without stopping when the car stopped sparking the fuel, i hit the gas but nothing happened, i put the car in Neutral and it instantly died and coasted to a stop. I walked home & let it cool down, i went back a couple hours later but the car just cranked, the fuel pump primes it but theres no spark. I don't think it would be the ignition coil because the car still runs with only one, and i swapped the ICM earlier to a different one i had and that didnt change anything. Im thinking its the Crank Position Sensor.. Sound right? Any other suggestions ? Thanks.
KingDave is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Sponsored Links
Advertisement
 
Unread 08-07-2013   #2 (permalink)
TOM RENZO is offline BOSS Member

2.3L Member


Joined: Jul 2009
Posts: 3,855 Threads: 164
 TOM RENZO's Country Flag  View TOM RENZO's 3 photos
Danbury   Connecticut
TOM RENZO is on a distinguished road
Default

Crank sensor or a broken TIMING BELT!!! Peace Tom
__________________
HAVE YOU DRIVEN A FORD LATELY!!!

"As I lay rubber down the street, I pray for traction I can keep, but if I spin and begin to slide, please dear God protect my ride"

I SPEND MONEY I DON'T HAVE, TO BUILD CARS I DON'T NEED,TO IMPRESS PEOPLE I DON'T KNOW.
TOM RENZO is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 08-07-2013   #3 (permalink)
PhoenixSheriden is offline PONY Member

2.3L Member


Joined: Sep 2009
Posts: 766 Threads: 56
 PhoenixSheriden's Country Flag  View PhoenixSheriden's 25 photos
Wheeler   Indiana
PhoenixSheriden is on a distinguished road
Default

+1 to crank sensor. sounds exactly what i went thru when mine died a while back.

-using that just because its awesome
__________________
Choose the letter that best describes your outlook on life:
A. the glass is half full :shiny:
B. the glass is half empty
C. i dont know ok!! its just got some freaking water in it!!!
PhoenixSheriden is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 08-07-2013   #4 (permalink)
Gavs 2.3 is offline Rookie


Joined: Aug 2013
Posts: 3 Threads: 1
 Gavs 2.3's Country Flag
Gloucester   Virginia
Gavs 2.3 is on a distinguished road
Default

Hello, I don't mean to hijack this thread but this is the most recent one that covers a topic similar to my problems. I have a 93 2.3 with the 8 plugs. My car begins to misfire badly around 3-4th gear. It also has an intermittent problem when it will have very long cranks before firing up. While cranking, the check engine light stays brightly lit. Does this mean it's automatically the crank sensor? or could it be related to an intermittent problem with the ICM? Thanks in advance guys.
Gavs 2.3 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 08-08-2013   #5 (permalink)
TOM RENZO is offline BOSS Member

2.3L Member


Joined: Jul 2009
Posts: 3,855 Threads: 164
 TOM RENZO's Country Flag  View TOM RENZO's 3 photos
Danbury   Connecticut
TOM RENZO is on a distinguished road
Default

OK lets analyze this !!! The crank sensors do go bad and should be replaced at timing belt changes. Ford says this shoulde dun at 60K. Also remember the sensor has to be adjusted correctly. GAPPED according to ford specks. If the air gap is to big it wont work correctly and cause issues. So change the belt and sensor every 60K and or you will have issues. If possible use a Factory Ford part not an aftermarket one. Trust me on this!!! Peace Tom


HERE WE GO THIS IS NEEDED AND SOME SOME SENSORS COME WITH THE TOOL RIGHT IN THE BOX. FORD DOES NOT INCLUDE THE TOOL AS FAR AS I KNOW. But for 17 bucks it is a no BRAINIER!!!

http://www.amazon.com/Rotunda-Cranks.../dp/B009ZGO4HU
__________________
HAVE YOU DRIVEN A FORD LATELY!!!

"As I lay rubber down the street, I pray for traction I can keep, but if I spin and begin to slide, please dear God protect my ride"

I SPEND MONEY I DON'T HAVE, TO BUILD CARS I DON'T NEED,TO IMPRESS PEOPLE I DON'T KNOW.
TOM RENZO is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 08-09-2013   #6 (permalink)
KingDave is offline Rookie


Joined: Aug 2012
Posts: 36 Threads: 10
 KingDave's Country Flag  View KingDave's 1 photo
Courtenay   British Columbia
KingDave is on a distinguished road
Default

How much $$ does the crank position k
sensor cost ? And how long should this job take with all the right tools ?
Thanks.
KingDave is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 08-10-2013   #7 (permalink)
mg man 75 is offline MODERATOR

2.3L Member


Joined: Jan 2008
Posts: 3,662 Threads: 59
 mg man 75's Country Flag  View mg man 75's 18 photos
Elkhorn   Kentucky
mg man 75 is a name known to allmg man 75 is a name known to allmg man 75 is a name known to allmg man 75 is a name known to allmg man 75 is a name known to allmg man 75 is a name known to all
Default

List: Search for 'crankshaft position/angle sensor' | O'Reilly Auto Parts
If Tom Renzo say get Ford part, get Ford part he knows. Maurice
__________________
1989 Mustang 2.3 turbo, rebuilt SVO motor, 88 computer,vam upgrade, adjustable boost control, intercooler, c-4 trans, 7.5 345 turbocoupe rearend, motorsport driveshaft, Black interior.


AFM FORUM MODERATOR
mg man 75 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 08-10-2013   #8 (permalink)
TOM RENZO is offline BOSS Member

2.3L Member


Joined: Jul 2009
Posts: 3,855 Threads: 164
 TOM RENZO's Country Flag  View TOM RENZO's 3 photos
Danbury   Connecticut
TOM RENZO is on a distinguished road
Default

Thank you Maurice. Catch this example of a factory part issue. I had a customer with a PT cruiser that set a cam sensor code. I scanned the car and told him he needed a new one. He said he replaced it a month ago and the light came on again. So i told him to buy a new one from the dealer. So with that he went to advanced auto and bought another sensor. Installed it and brought the car to me to clear the code. I asked him if he bought a factory part. HE SAID NO!!! With that the check engine light came on again. With that he came back and asked me for advice. So i told him to buy a factory sensor. With that he brought the car to the dealer to have them program the new sensor to the ECM. They did!!! 3 blocks after leaving the dealer the check engine light came on again. With that he asked me to fix the car. I went to the dealer and bought a dealer sensor. Installed it cleared the codes and that was 6 months ago. If possible and i strongly suggest using factory sensors. They normally are made better and specific to the car. Some will argue but not JIMMY with the PT CRUISER. Peace Tom
__________________
HAVE YOU DRIVEN A FORD LATELY!!!

"As I lay rubber down the street, I pray for traction I can keep, but if I spin and begin to slide, please dear God protect my ride"

I SPEND MONEY I DON'T HAVE, TO BUILD CARS I DON'T NEED,TO IMPRESS PEOPLE I DON'T KNOW.
TOM RENZO is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 08-11-2013   #9 (permalink)
mg man 75 is offline MODERATOR

2.3L Member


Joined: Jan 2008
Posts: 3,662 Threads: 59
 mg man 75's Country Flag  View mg man 75's 18 photos
Elkhorn   Kentucky
mg man 75 is a name known to allmg man 75 is a name known to allmg man 75 is a name known to allmg man 75 is a name known to allmg man 75 is a name known to allmg man 75 is a name known to all
Default

Tom The supplier you mention I will never buy from. I installed 4 of the "rebuilt" alternators all 4 failed with in 2 years of the first install. Now I have a used 3 G. Installed a "lifetime " radiator in Jeep. Replaced twice and present leaks and warranty is gone [Said they no long do lifetime on radiators, What]. 2 water pumps on Jeep. 3 starters on Mustang. Never, Never again. Maurice
__________________
1989 Mustang 2.3 turbo, rebuilt SVO motor, 88 computer,vam upgrade, adjustable boost control, intercooler, c-4 trans, 7.5 345 turbocoupe rearend, motorsport driveshaft, Black interior.


AFM FORUM MODERATOR
mg man 75 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Sponsored Links
Advertisement
 
Reply   Post New Thread

Tags
2.3, cps, dis, icm, stalled



Thread Tools



Mustang Photos
Mustang Links    Top Sites    RSS    Link To Us    Add to Favorites    Archive    Terms of Use    Site Rules    Privacy    Contact    Sponsors    Advertise   
AllFordMustangs is not affiliated with or endorsed by Ford Motor Company. ©Copyright 2002-2011 All Auto Enthusiasts Network

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162