1993 Mustang LX 2.3L 5spd Help with high idle - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 10-12-2013 Thread Starter
Rookie
 
XxSaltLifexX's Avatar
 
Joined: Oct 2013
Location: Florida
Posts: 16
 
1993 Mustang LX 2.3L 5spd Help with high idle

The idle on the car moves up and down and it is also high. about 1600 rps. If I turn the A/C on it goes down to about 1200 rpms. Also the check engine light is on. I tried to do the codes test and I got a 126 code which says online that it is a BP or MAP sensor is too high or too low. Any help is appreciated, thank you.
XxSaltLifexX is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-13-2013
PONY Member
2.3L Member
5.0L Member
 
Lazypig's Avatar
 
Joined: Feb 2008
Location: Nelson
Posts: 283
 
clean the idle air control valve and check for vacuum leaks if nothing found replace the map

1989 Mustang Hatch 2.3 Turbo Swap, 17 PSI, Holset HY35, Stinger Center Mount Header, 3 Inch Straight Pipe Exhaust, Tial External Wastegate, Greddy BPV, Spec Stage 3 Clutch, FMIC, Ported Intake.
Lazypig is offline  
post #3 of 4 (permalink) Old 10-14-2013
PONY Member
2.3L Member
S197 Member
 
bl817's Avatar
 
Joined: Jul 2010
Location: Fort Worth
Posts: 468
 
welcome to the forum. first off, do a tune up on the car(plugs, wires, air filter, oil change etc) clean your mass air flow sensor with specific mass air flow cleaner. as mentioned above clean/relplace idle air control valve, check for vacuum leaks. check tps (throttle position sensor) remove and clean throttle body. I read your other post and your clutch may be just fine but need adjusted. short term, you can lift up the clutch pedal and the quadrant will take up the slack in the cable. if that doesn't help then search the stickys at the top of the forum for the dogbone cable upgrade and try that. sounds like the clutch isn't fully releasing enabling you to shift without grinding the gears. small and easy steps to get your pony up and running. good luck and ask away, there are plenty of very knowledgeable ppl on here to help.
bl817 is offline  
post #4 of 4 (permalink) Old 10-19-2013
PONY Member
2.3L Member
 
PhoenixSheriden's Avatar
 
Joined: Sep 2009
Location: Wheeler
Posts: 781
 
after you try all the abopve advice, take your car out for a nice long drive. when you get back do engine off and engine running tests to check for codes to make sure you fixed the problem. make sure to wait for the 2nd batch of codes in both tests. sometimes it seems to take almost a minute for that 2nd batch to start so be patient. ideally what you want to get is a code 111 that is a system pass. if you get 111 first off on both tests then you should be good.

Choose the letter that best describes your outlook on life:
A. the glass is half full :shiny:
B. the glass is half empty
C. i dont know ok!! its just got some freaking water in it!!!
PhoenixSheriden is offline  
Sponsored Links
Advertisement
 
Reply

Tags
1993 , 2.3 , high idle , idle up and down , mustang

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182