Go Back   Ford Mustang Forums > Mustang > 2005+ Mustang > 2005-2010 Mustang GT Tech

Welcome to our Mustang forums where Mustangers come together to hang out, discuss and enjoy their favorite Mustang hobby with fellow Mustang enthusiasts. We invite everyone to read, post, and enjoy our Mustang forum as well as the many other sections of our site.

You are currently viewing our forums as a guest. By joining our community you gain access to post topics, communicate with members, upload your photos and access many other special features. Registration is fast, simple and free so why wait, join our Mustang community today! If you have any problems with registration or your account login, please contact support.

 

2005-2010 Mustang GT Tech Forum

2011+ Talk | 2011+ GT | 2011+ V6 | 2005-2010 Talk | 2005-2010 GT | 2005-2010 V6 | Shelby GT500 | Mustang Tech 
 

Reply   Post New Thread
Unread 11-24-2008   #1 (permalink)
CrashedStang06 is offline Apprentice


Joined: Aug 2008
Posts: 151 Threads: 18
 CrashedStang06's Country Flag
Honolulu   Hawaii
CrashedStang06 is on a distinguished road
Default What does it mean when the O/D light flashes?

I never had this happen until now. It was raining heavily and I was driving around with the O/D and TCS on. Well after about 15 minutes of driving slowly, I noticed the O/D light pop on and flash constantly. The tranny sounded like it had a whining noise also. I pulled the car over and restarted it and the flashing O/D went away. Would anyone know what would cause this? I never had problems with the tranny until now. However, after I crashed it a few months ago, I replaced the cooler with an aftermarket one which has 3/8" hoses going to the stock 1/2" hose. Didnt know if this might be a problem. I'm getting really sick of this car since it only has 18,000 miles on it and has been to Ford over 30 times for repairs from the radio to the tailights. Now htis is happening I'm wondering if I got stuck with the last car that was built on a Friday afternoon!! As always, everyones help is greatly appreciated!!!
CrashedStang06 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Sponsored Links
Advertisement
 
Unread 11-24-2008   #2 (permalink)
texmedley2003 is offline Rookie


Joined: Jul 2008
Posts: 33 Threads: 11
 texmedley2003's Country Flag  View texmedley2003's 3 photos
Lancaster, TX   Texas
texmedley2003 is on a distinguished road
Default

My 2004 did that and it was the speed Sensor.
__________________
Karen


No matter where your at, there you are.
texmedley2003 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 11-24-2008   #3 (permalink)
Ricesmoker is offline Made Member


Joined: Apr 2006
Posts: 520 Threads: 4
 Ricesmoker's Country Flag  View Ricesmoker's 12 photos
Lake County   Illinois
Ricesmoker is on a distinguished road
Default

My 2006 did that and it meant imminent failure for my 5R55S tranny. The flasshing light indicates a problem for sure. It can be something as as simple as a stuck solenoid or as serious as a failed drum. If it resets itself - no worry. If not get it serviced.
__________________
KB 2.4 IC, KB Stage 2, Level 10 tranny, Kooks 1.75" LT, Powerhouse, FRRP, Moroso, M/T, AFCO, Autometer, Hot Rod Chassis, ST Motorsports, Moroso, Granatelli Motor Sports, Simpson

11.42@ 118.98 MPH 1.63 60'
Ricesmoker is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 11-24-2008   #4 (permalink)
stlwagon is online now MODERATOR

Classic Member
S197 Member


Joined: Oct 2005
Posts: 74,668 Threads: 730
 stlwagon's Country Flag  View stlwagon's 60 photos  View stlwagon's 2 classified ads
Southern   Maryland
stlwagon has much to be proud ofstlwagon has much to be proud ofstlwagon has much to be proud ofstlwagon has much to be proud ofstlwagon has much to be proud ofstlwagon has much to be proud ofstlwagon has much to be proud ofstlwagon has much to be proud ofstlwagon has much to be proud of
Send a message via Yahoo to stlwagon
Default

Quote:
Originally Posted by Ricesmoker View Post
My 2006 did that and it meant imminent failure for my 5R55S tranny. The flasshing light indicates a problem for sure. It can be something as as simple as a stuck solenoid or as serious as a failed drum. If it resets itself - no worry. If not get it serviced.
+1... Get it serviced now..
__________________
1965 Mustang 289 Coupe
2007 Corvette
2003 Ram 3500 4x4 diesel dually
stlwagon is online now  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 11-24-2008   #5 (permalink)
Mojave Dave is offline Apprentice

S197 Member


Joined: Apr 2008
Posts: 85 Threads: 8
 Mojave Dave's Country Flag
Houston   Texas
Mojave Dave is on a distinguished road
Default

I had a flashing OD light once or twice a week that would go out if I shut off the car and then restarted it. Sort of like yours, but I had no noise. I had a tune in it for the CAI. It was resolved by my finding out that the MAF was wrong in the CAI and getting another tune. The light has not been on since in several months. These computers are apparently very sensitive. Good luck.
__________________
2006 Black Mustang B302 & CNC heads, Comp Stage 2 cams, FB 4R70W, Circle D TC, Moser 8.8 with 9" ends, 4.11 spool, MadMan Roll Cage & kirkey Seat, BMR-K & Extreme ARB, GT500 dual fuel pump, 60lb injectors, Saleen S/C, 10%OD, KooKs, QA1 dbl front & rears, Scott-Drake dbl adj lca, Wilwood brakes, Bogarts, 325x15 ET Streets & skinnies. Triangle Speed Tuning. !st test run 10.22 @132 on foot brake.
Mojave Dave is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 11-24-2008   #6 (permalink)
MickMach is offline Top Dog

Classic Member
S197 Member


Joined: Sep 2005
Posts: 4,391 Threads: 65
 MickMach's Country Flag  View MickMach's 14 photos
Front Royal   Virginia
MickMach is on a distinguished road
Default

I heard the light will flash if the tranny is low in fluid. since you had the cooler changed did you loose some fluid? if not.....however the bigger cooler and lines will "take up" extra tranny fluid and you will/may need to add fluid. that would be nice if thats the fix
__________________
Saleen S/C 3.2 pulley. Chris Rose tune.

Hot Rod cams, GT500 pumps, CHE goodies on the rear, 4.10's, KOOKS/ O/R X pipe with PYPES Violators, Spydershaft, TCI 3500 stall, PA deep tranny pan. Meziere w/p,M&H 325/45/17 DRs.
S/C---7.201@97.75/11.61@118.62
MickMach is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 11-25-2008   #7 (permalink)
CrashedStang06 is offline Apprentice


Joined: Aug 2008
Posts: 151 Threads: 18
 CrashedStang06's Country Flag
Honolulu   Hawaii
CrashedStang06 is on a distinguished road
Default

Thanks for the advice everyone. Ford did fill it up so I dont think its a fluid problem. I hope its not the tune, but I thought having a smaller tranny cooler line going to the stock 1/2" might be a problem. I asked before about it but everyone said it would be fine. I hope this is not a serious problem, I'm about to jump this car off a cliff if I have another major problem. Don't worry, I'll make sure to get some vid's of it!!!!
CrashedStang06 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 02-01-2009   #8 (permalink)
kj217 is offline Made Member

4.6L Member
S197 Member


Joined: Jan 2008
Posts: 367 Threads: 60
 kj217's Country Flag
Jeddah
kj217 is on a distinguished road
Default

Quote:
Originally Posted by Mojave Dave View Post
I had a flashing OD light once or twice a week that would go out if I shut off the car and then restarted it. Sort of like yours, but I had no noise. I had a tune in it for the CAI. It was resolved by my finding out that the MAF was wrong in the CAI and getting another tune. The light has not been on since in several months. These computers are apparently very sensitive. Good luck.
how can a MAF be wrong in the CAI?
please, explain.

first time i have ever seen this was once i installed the C&L racer
__________________
2006 GT drophead|Auto|X3|Comp NSR Stage II Cams|Steeda UDP|Steeda CMDP|C&L Racer|MMR Windage Tray|4.10|X PYPES|Eibach ProKit|D SPECS|SLP Loudmouth|GT500 LCA|Steeda UCA|PA Deep Oil Pan|20"s Foose Nitrous Grey
kj217 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 02-01-2009   #9 (permalink)
MSgt46270 is offline Made Member

S197 Member


Joined: Feb 2005
Posts: 590 Threads: 24
 MSgt46270's Country Flag  View MSgt46270's HomePage
San Diego   California
MSgt46270 is on a distinguished road
Default

When my O/D light would flash it was a real bad thing, had to have the trans rebuilt. But I was also drag racing my car.

Give Tony (owner) a call at Larry's Transmissions and he can pretty much tell you whats going on. He hasn't been wrong with me yet.
Attached Thumbnails
What does it mean when the O/D light flashes?-scan0150-custom-.jpg  
__________________
Saleen S/C, 4R70W Trans, 3:73 gears, 3200 stall PI, GT500 fuel pump, JBA Shorty headers.
MSgt46270 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 02-01-2009   #10 (permalink)
kj217 is offline Made Member

4.6L Member
S197 Member


Joined: Jan 2008
Posts: 367 Threads: 60
 kj217's Country Flag
Jeddah
kj217 is on a distinguished road
Default

Quote:
Originally Posted by MSgt46270 View Post
When my O/D light would flash it was a real bad thing, had to have the trans rebuilt. But I was also drag racing my car.

Give Tony (owner) a call at Larry's Transmissions and he can pretty much tell you whats going on. He hasn't been wrong with me yet.
i will contact him..
does he have an email add?
__________________
2006 GT drophead|Auto|X3|Comp NSR Stage II Cams|Steeda UDP|Steeda CMDP|C&L Racer|MMR Windage Tray|4.10|X PYPES|Eibach ProKit|D SPECS|SLP Loudmouth|GT500 LCA|Steeda UCA|PA Deep Oil Pan|20"s Foose Nitrous Grey
kj217 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 02-01-2009   #11 (permalink)
Mojave Dave is offline Apprentice

S197 Member


Joined: Apr 2008
Posts: 85 Threads: 8
 Mojave Dave's Country Flag
Houston   Texas
Mojave Dave is on a distinguished road
Default

Ki217, the MAF was the wrong size in diameter. It was a real bargain unit sold by a dealer. Was told it was an early 2005 that should have been recalled but was not. When replaced by a new one that was correct size the problem was over. What I am referring to is the pipe that the sensor goes into right behind the filter. Not sure of the actual numbers, but instead of being like 90mm the pipe was 85mm and this is a problem for the flow measurements in the sensor. Anyway that was what I was told and the results speak for themselves. Good luck.
__________________
2006 Black Mustang B302 & CNC heads, Comp Stage 2 cams, FB 4R70W, Circle D TC, Moser 8.8 with 9" ends, 4.11 spool, MadMan Roll Cage & kirkey Seat, BMR-K & Extreme ARB, GT500 dual fuel pump, 60lb injectors, Saleen S/C, 10%OD, KooKs, QA1 dbl front & rears, Scott-Drake dbl adj lca, Wilwood brakes, Bogarts, 325x15 ET Streets & skinnies. Triangle Speed Tuning. !st test run 10.22 @132 on foot brake.
Mojave Dave is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 02-01-2009   #12 (permalink)
kj217 is offline Made Member

4.6L Member
S197 Member


Joined: Jan 2008
Posts: 367 Threads: 60
 kj217's Country Flag
Jeddah
kj217 is on a distinguished road
Default

Quote:
Originally Posted by Mojave Dave View Post
Ki217, the MAF was the wrong size in diameter. It was a real bargain unit sold by a dealer. Was told it was an early 2005 that should have been recalled but was not. When replaced by a new one that was correct size the problem was over. What I am referring to is the pipe that the sensor goes into right behind the filter. Not sure of the actual numbers, but instead of being like 90mm the pipe was 85mm and this is a problem for the flow measurements in the sensor. Anyway that was what I was told and the results speak for themselves. Good luck.
can the C&L racer the cause for OD light flashing????????????
the racer CAI surely has larger MAF housing than stock but, this should be considered in the tune..
__________________
2006 GT drophead|Auto|X3|Comp NSR Stage II Cams|Steeda UDP|Steeda CMDP|C&L Racer|MMR Windage Tray|4.10|X PYPES|Eibach ProKit|D SPECS|SLP Loudmouth|GT500 LCA|Steeda UCA|PA Deep Oil Pan|20"s Foose Nitrous Grey
kj217 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 02-02-2009   #13 (permalink)
Dags44890 is offline Rookie


Joined: Nov 2007
Posts: 41 Threads: 6
 Dags44890's Country Flag
San Antonio   Texas
Dags44890 is on a distinguished road
Default

when the o/d light flashes, its the check engine light for the trans. if you read the dtc with a diagnostic reader, itll throw p00=0 or p00<0 or other weird stuff. only the dealer or a trans shop has the tool to read the tcm, well that is unless youre willing to buy one for a k to 2k.
Dags44890 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 02-02-2009   #14 (permalink)
Smokey88 is offline Made Member

V6 Member
4.6L Member
S197 Member


Joined: Dec 2008
Posts: 561 Threads: 29
 Smokey88's Country Flag  View Smokey88's 9 photos
Tucson   Arizona
Smokey88 is on a distinguished road
Send a message via Yahoo to Smokey88
Default

WHEN THE OD light flashes it means that your 2nd shift selenoid is malfunctioning, or that the fth gear and 6th overdrive gears are slipping
__________________
08 GT Hurst Shifter, Fidanza clutch, JLT CAI, Kooks Longtubes and O/R X, BBR tune, SSS Terminator mufflers, M80 mufflers, Eibach pro kit, Eibach struts and shocks, Asanti AF 135 rims, 295/35/20 rear tires More to come!
Smokey88 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 02-06-2009   #15 (permalink)
CrashedStang06 is offline Apprentice


Joined: Aug 2008
Posts: 151 Threads: 18
 CrashedStang06's Country Flag
Honolulu   Hawaii
CrashedStang06 is on a distinguished road
Default

Had this rear its ugly head again! The car drove fine for a few months after the first instance of this. Now its popping up again! The car shifts fine, anyone have a clue why it's doing this? I reloaded the tune again and it went away, I'm hoping this is just the computer acting up and not the tranny going!!
CrashedStang06 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Sponsored Links
Advertisement
 
Reply   Post New Thread



Thread Tools



Mustang Photos
Mustang Links    Top Sites    RSS    Link To Us    Add to Favorites    Archive    Terms of Use    Site Rules    Privacy    Contact    Sponsors    Advertise   
AllFordMustangs is not affiliated with or endorsed by Ford Motor Company. ©Copyright 2002-2011 All Auto Enthusiasts Network

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162