Go Back   Ford Mustang Forums > Mustang > 2005-2014 Mustangs > 2005-2010 Mustang GT Tech

Welcome to our Mustang forums where Mustangers come together to hang out, discuss and enjoy their favorite Mustang hobby with fellow Mustang enthusiasts. We invite everyone to read, post, and enjoy our Mustang forum as well as the many other sections of our site.

You are currently viewing our forums as a guest. By joining our community you gain access to post topics, communicate with members, upload your photos and access many other special features. Registration is fast, simple and free so why wait, join our Mustang community today! If you have any problems with registration or your account login, please contact support.

 

2005-2010 Mustang GT Tech Forum

2011-2014 Talk | 2011-2014 GT | 2011-2014 V6 | 2005-2010 Talk | 2005-2010 GT | 2005-2010 V6 | Shelby GT500 | Mustang Tech 
 

Reply   Post New Thread
Unread 04-24-2009   #1 (permalink)
Y-Man is offline Rookie


Joined: May 2007
Posts: 2 Threads: 1
 Y-Man's Country Flag
Albuquerque   New Mexico
Y-Man is on a distinguished road
Default 2007 Mustang GT Loud clicking from dash

This problem recently started within the last two months or so. I live in the Albuquerque area, so it was cold temperatures when the problem started. The problem is when I start my car, I get a loud clicking from under the dash that lasts for about 5 seconds or so, then stops and doesn't come back until I restart the car. It sounds like it's coming from the air selector underneath the dash. The noise will happen no matter what position I have the selector in, even in off. Now, if it's hot out and my car is hot inside, the noise doesn't happen. As the temperatures move to warmer, it doesn't happen as often during the day, but early morning when it's cool, is guaranteed to happen. All the positions of the air selector work, so I know that function is ok. Does the air selector do a cycle check during engine start and is causing the noise? Anyway, I'd appreciate any help that I can get at this point. I'm beyond my warranty already with nearly 45k miles, so the fix will have to come from my wallet

Thanks in advance for any replies

Y-Man
Y-Man is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Sponsored Links
Advertisement
 
Unread 04-24-2009   #2 (permalink)
stlwagon is offline MODERATOR

Classic Member
S197 Member


Joined: Oct 2005
Posts: 74,584 Threads: 733
 stlwagon's Country Flag  View stlwagon's 60 photos  View stlwagon's 2 classified ads
Southern   Maryland
stlwagon has much to be proud ofstlwagon has much to be proud ofstlwagon has much to be proud ofstlwagon has much to be proud ofstlwagon has much to be proud ofstlwagon has much to be proud ofstlwagon has much to be proud ofstlwagon has much to be proud ofstlwagon has much to be proud of
Send a message via Yahoo to stlwagon
Default

That's a new one on me. Are you certain it's not coming from the CD player?
__________________
1965 Mustang Coupe
stlwagon is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 04-24-2009   #3 (permalink)
Y-Man is offline Rookie


Joined: May 2007
Posts: 2 Threads: 1
 Y-Man's Country Flag
Albuquerque   New Mexico
Y-Man is on a distinguished road
Default

I can't say that I'm 100% certain it's not the cd player, but I've had discs make some clicking when they were rejected, and the clicking the cd player made wasn't near the volume of what this is. The sound seems to be coming from near the passengers feet, just near the center console, although, I can't be certain.
Y-Man is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 07-08-2010   #4 (permalink)
Wilder6891 is offline Rookie


Joined: Feb 2010
Posts: 1 Threads: 0
 Wilder6891's Country Flag
Savannah   Georgia
Wilder6891 is on a distinguished road
Default

Just had the same thing happen to my 07 GT i'm pretty sure its the Blend door and actuator assembly i trouble shot it a little and it doesn't seem to be working 100%. If you dont know what this assembly is, its the one behind the dash that directs the air to the vents as controled by the selector knob. Just check to see if when you select the different directions it works as advertised. i will keep you posted as i fix mine let me know what happens with yours Thanks
Wilder6891 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 09-01-2011   #5 (permalink)
TexasPenguin is offline Rookie


Joined: Nov 2010
Posts: 23 Threads: 2
 TexasPenguin's Country Flag  View TexasPenguin's 3 photos
Flint.   Texas
TexasPenguin is on a distinguished road
Default

Quote:
Originally Posted by Wilder6891 View Post
Just had the same thing happen to my 07 GT i'm pretty sure its the Blend door and actuator assembly i trouble shot it a little and it doesn't seem to be working 100%. If you dont know what this assembly is, its the one behind the dash that directs the air to the vents as controled by the selector knob. Just check to see if when you select the different directions it works as advertised. i will keep you posted as i fix mine let me know what happens with yours Thanks
Old post but did you ever get to the bottom of this? Mine's just started doing the exact same thing and, before I dismantle the dash (great job in Texas in 100+ degrees!) it would be great if someone else had already identified the potential culprit.

Thanks.
TexasPenguin is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 09-01-2011   #6 (permalink)
metalheadwillie is offline Apprentice


Joined: Dec 2010
Posts: 98 Threads: 12
 metalheadwillie's Country Flag
Concord   California
metalheadwillie is on a distinguished road
Default

I had the same thing... I couldn't figure it out where it was coming from...

Well, one day I pulled my sunglasses out of the glovebox. The clicking stopped. Now if I ever hear it, I just move my sunglasses around and the clicking stops.

Haha. I freaked out until I figured it out. :kooky:
metalheadwillie is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Sponsored Links
Advertisement
 
Reply   Post New Thread



Thread Tools



Mustang Photos
Mustang Links    Top Sites    RSS    Link To Us    Add to Favorites    Archive    Terms of Use    Site Rules    Privacy    Contact    Sponsors    Advertise   
AllFordMustangs is not affiliated with or endorsed by Ford Motor Company. ©Copyright 2002-2011 All Auto Enthusiasts Network

Search Engine Friendly URLs by vBSEO 3.5.2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164