Smart Junction Box Blues - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 15 (permalink) Old 02-03-2010 Thread Starter
Rookie
S197 Member
 
aihler's Avatar
 
Joined: Jun 2009
Location: West Jordan
Posts: 19
 
Smart Junction Box Blues

Hey everyone,
It's been awhile since I've been on this. I had and still do have a problem with my smart junction box. It all started with one right rear tail light wouldn't work, then the other right tail light went out. Both wires coming back to the lights from the junction box are dead. The right front turn light works fine. Anyway I want and need to get this problem fixed. I called Ford and they said if I replace the box myself they would code it for around $100.00. I just want it fixed because I got a sequential light system for Christmas. What do you think? Does this sound like this should fix the problem?

2006 GT. Bought new in Sept.2005. Lt Blue, Shaker 1000. Automatic. Added rear louvers and 1/4 window louvers. Painted the rear spoiler flat black. Added a 1969 Mach 1 hood scoop with working turn lights. GT500 chrome wheels. Saleen supercharger with a Brenspeed tune. 3.75 gears out back. borla SS mufflers. Roush front bumper. Custom rear bumper.
aihler is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 02-03-2010
MODERATOR
Classic Member
S197 Member
 
stlwagon's Avatar
 
Joined: Oct 2005
Location: Southern
Posts: 74,636
                 
Send a message via Yahoo to stlwagon
Not sure that replacing the SJB is a typical DIY job.

1965 Mustang Coupe
stlwagon is offline  
post #3 of 15 (permalink) Old 02-03-2010
Top Dog
 
pcfrisch's Avatar
 
Joined: Feb 2005
Location: Southeastern
Posts: 14,558
 
How much would it cost if the dealer did it?

AFM Site Administrator
2006 Tungsten Grey Mustang GT Manual.
Alpine H/U with Infinity speakers.
Powerhouse CAI and Tune.
Previous Mustangs:
1978 2.8 L, 1979 5.0, 1982 5.0 "HO", 1986 5.0 GT

Don't wait for tomorrow to look back and wish for today
pcfrisch is offline  
post #4 of 15 (permalink) Old 02-03-2010
MODERATOR
Classic Member
S197 Member
 
stlwagon's Avatar
 
Joined: Oct 2005
Location: Southern
Posts: 74,636
                 
Send a message via Yahoo to stlwagon
I thought there was a recent post by someone that put it close to $1000.

1965 Mustang Coupe
stlwagon is offline  
post #5 of 15 (permalink) Old 02-03-2010 Thread Starter
Rookie
S197 Member
 
aihler's Avatar
 
Joined: Jun 2009
Location: West Jordan
Posts: 19
 
I can get the box for 250.00 (I have taken it out before, trying to fix this problem) the dealer said they would charge 100.00 to program it. I just want to make sure they know what they are doing and that it would fix the problem.. I got concerned when the guy at the dealer asked where it was followed by to the left of the steering wheel :?:

2006 GT. Bought new in Sept.2005. Lt Blue, Shaker 1000. Automatic. Added rear louvers and 1/4 window louvers. Painted the rear spoiler flat black. Added a 1969 Mach 1 hood scoop with working turn lights. GT500 chrome wheels. Saleen supercharger with a Brenspeed tune. 3.75 gears out back. borla SS mufflers. Roush front bumper. Custom rear bumper.
aihler is offline  
post #6 of 15 (permalink) Old 02-03-2010
SHELBY GT 500 Member
S197 Member
 
travelers's Avatar
 
Joined: Sep 2006
Location: Eastern
Posts: 10,879
 
I would check a few different dealers.


2011 GT Candy Red
07 REDFIRE GT Gone
travelers is offline  
post #7 of 15 (permalink) Old 02-03-2010
Made Member
 
10/05gt's Avatar
 
Joined: Jun 2006
Location: Grove City
Posts: 769
 
Quote:
Originally Posted by aihler View Post
Hey everyone,
It's been awhile since I've been on this. I had and still do have a problem with my smart junction box. It all started with one right rear tail light wouldn't work, then the other right tail light went out. Both wires coming back to the lights from the junction box are dead. The right front turn light works fine. Anyway I want and need to get this problem fixed. I called Ford and they said if I replace the box myself they would code it for around $100.00. I just want it fixed because I got a sequential light system for Christmas. What do you think? Does this sound like this should fix the problem?
The dealer tech can actually connect up their VCM (vehicle communication module) and get specific DTC's from the SJB that should identify if the SJB has failed.

Just out of curiosity did you check connector C411 and ground G402? This connector and ground is under the rear plastic trim panel in the back of the trunk to the right of the trunk latch. You say the right rear tail light it dead? Are none of the lights in it working? Turn, flasher or running? How about the right rear side lamp?

Just trying to help you cover all the bases before you got to lay out out for a new SJB.

If it needs replaced the dealer tech needs to upload the data from your old SJB, it holds the anti theft, keyless entry data and communicates with the PCM. Once the new SJB is installed then the data needs to be downloaded to it.

This is only an educated guess but I bet if you install an SJB from a salvage yard the car won't start because of the anit-theft. I might be wrong on that one though.

One other thing. If you have to have yours replaced I would be willing to buy your failed one. PM me if your interested

"You can't fix stupid"

Tuned by PowerHouse411
10/05gt is offline  
post #8 of 15 (permalink) Old 02-04-2010 Thread Starter
Rookie
S197 Member
 
aihler's Avatar
 
Joined: Jun 2009
Location: West Jordan
Posts: 19
 
Thanks for the responses. I did check the ground under the panel. It seems to be fine.. I do have marker lights. All three light up and the side marker lights up. I do not have turn or brake lights on the right side. But I did jump one bulb from the third brake light so I have brake lights and then I jumped the wire for the front right light back to the other light so I have a turn light on the right side. I think I will drive over to Ford and talk to them. I agree the have to do something about down loading my box and up loading the new box.. I will let you know what I find out. If I get it working with the new box I will let you have the old box to play with.... thanks everyone for your help and if any of you find out something else please let me know....

2006 GT. Bought new in Sept.2005. Lt Blue, Shaker 1000. Automatic. Added rear louvers and 1/4 window louvers. Painted the rear spoiler flat black. Added a 1969 Mach 1 hood scoop with working turn lights. GT500 chrome wheels. Saleen supercharger with a Brenspeed tune. 3.75 gears out back. borla SS mufflers. Roush front bumper. Custom rear bumper.
aihler is offline  
post #9 of 15 (permalink) Old 02-09-2010 Thread Starter
Rookie
S197 Member
 
aihler's Avatar
 
Joined: Jun 2009
Location: West Jordan
Posts: 19
 
Just a update. I ordered a smart box and it's on back order. I will let you all know what happens when I get it.

2006 GT. Bought new in Sept.2005. Lt Blue, Shaker 1000. Automatic. Added rear louvers and 1/4 window louvers. Painted the rear spoiler flat black. Added a 1969 Mach 1 hood scoop with working turn lights. GT500 chrome wheels. Saleen supercharger with a Brenspeed tune. 3.75 gears out back. borla SS mufflers. Roush front bumper. Custom rear bumper.
aihler is offline  
post #10 of 15 (permalink) Old 03-06-2010 Thread Starter
Rookie
S197 Member
 
aihler's Avatar
 
Joined: Jun 2009
Location: West Jordan
Posts: 19
 
Update on Smart Junction Box Blues... I got the smart junction box (it's been on back order). I took off both battery cables. Took out the old sjb and installed the new one, hooked up the battery cables and tested out everything. The turn signals work. The keyless remote would not operate the doors, I put the key in the igntion and turned it on and off until the doors locked and then pushed both the lock and unlock buttons on the remote and it programed the remote. But the alarm will not set. I haven't found out how to reset that yet... One other thing the headlight come on when I turn on the key.

2006 GT. Bought new in Sept.2005. Lt Blue, Shaker 1000. Automatic. Added rear louvers and 1/4 window louvers. Painted the rear spoiler flat black. Added a 1969 Mach 1 hood scoop with working turn lights. GT500 chrome wheels. Saleen supercharger with a Brenspeed tune. 3.75 gears out back. borla SS mufflers. Roush front bumper. Custom rear bumper.
aihler is offline  
Rookie
 
Stevie D's Avatar
 
Joined: Mar 2009
Location: North Huron
Posts: 22
 
The SJB you installed prob. has base programming, but the options need to be entered. The only way I know now that the swap is done is for the dealer to enter VIN spec. as built data. $100 may seem outrageous but it is specialized equipment with very high monthly update costs so you are paying for that. If headlights are coming on with no park lights we call that daytime running lights way up north here in Canada

06 Black GT, vortech H.O with DaSilva tune, 464 @ rears. Cervini B2 chin, CDC shaker, side window scoops and rear slats, Eibach pro. Pioneer avic d3 with back-up and hurst shifter
Stevie D is offline  
Rookie
 
Mustang Pete's Avatar
 
Joined: May 2010
Location: Charlottesville
Posts: 1
 
Exclamation Smart Junction Box

Hi everyone,

I'm not driving a GT, but my headlights were stuck on high beam even when off. I took it to the dealer and they said there was water intrusion? Anyway, they quoted me like $550 to replace it!
Unfortunatly I can't do it myself so I'm stuck having to use the dealer because of the re-code issue.
Mustang Pete is offline  
Rookie
4.6L Member
S197 Member
 
raydondaughters's Avatar
 
Joined: Jun 2009
Location: Hamilton
Posts: 2
 
I have a 2008 GT/CS and my smart junction box is being replaced under warranty. I had a rear right light that stayed on even when the car was off.
raydondaughters is offline  
Apprentice
 
Collins '07Pony's Avatar
 
Joined: Apr 2011
Location: Myrtle Beach
Posts: 173
 
i had the same issue, but now another issue..

hey guys im starting up this thread again bc i had a guy at my local shop tell me that i need to replace my smart junction box and since i know nothing about it, i figured i would do a little bit of research! Seeing as you Aihler replaced your s i really need som feedback from you guys.

So i had the same issue with the tail ights not working on the passenger side in my 07 gt. so i checked all the fuses and one was out that was labeled SJB #4 and replaced it and they went to working. so now my ac isnt working and all my fuses are good and the guy at my local shop says the compressor isnt getting power, and checked all grounds and everything is fine, so then he called ford an they said it sounds like the SJB needs to be replaced and it could be around $300??? But reading what yall have said, someone evidentally paid $1000 for it, so im happy with the number 300 haha But guys i need help!!!

2007 Mustang Gt-Vista Blue
Collins '07Pony is offline  
Rookie
 
jbd55's Avatar
 
Joined: Jul 2014
Location: Scottsville
Posts: 1
 
I had SJB replaced and recoded by dealer on my 2005 in May. Cost $530.
I have the old one if anyone wants it to tinker on.
jbd55 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in









Random Question

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183