2005 Mustang GT Check Engine Light on after Error P0340 - Ford Mustang Forum
LinkBack Thread Tools
post #1 of 4 (permalink) Old 02-21-2012 Thread Starter
kkaylynne89's Avatar
Joined: Feb 2012
Location: Tempe
Posts: 4
Any Suggestions? 2005 Mustang GT Check Engine Light on after Error P0340

OK guys, I just purchased the car about 3 weeks ago now. On Friday the check engine light came on, I stopped by AutoZone and there was an error P0340 which I found to be Cam Position Sensor malfunction. I replaced the passenger side CPS, immediately after replacing it I began having problems with the car staying running when at an idle/under 1000rpm, if the car started to stall and I 'recovered' at the last chance the car would kinda 'put' along until I let off the gas and then began to accelerate again, which was confusing. While sitting at a stop light or slowing to make a turn the car would just stall, it is an Automatic. I returned to AutoZone and found out that the alternator was now bad, replaced that. I then replaced the driver side CPS as well.. The light is still on again, after driving about 100 miles. The battery charging indicator light intermittently pops up at start up and stays on for about 5-10 minutes and then shows back up every so often during the trip. The car also seems to be possibly misfiring. Any ideas as to what may still be wrong? Again, the car is 2005 Mustang GT Auto, stock.
kkaylynne89 is offline  
Sponsored Links
post #2 of 4 (permalink) Old 02-21-2012
4.6L Member
2Manystangs's Avatar
Joined: Mar 2009
Location: Tampa
Posts: 12,440
I would check the coils and plugs to start, also the battery may be weak and contributing to charging issues...most used cars are poorly maintained, so you may be in for a ride before you get it straight...good luck
2Manystangs is offline  
post #3 of 4 (permalink) Old 02-22-2012
rasmukri's Avatar
Joined: Oct 2011
Location: Fort Irwin
Posts: 47
Hey man it is the alternator. I had the EXACT same problem in my 06. there is some diode in the alternator that goes out and throws a code for the cps i dono why but that is what your problem is. Just go to autozone and get a remanufactured one. If you dont replace it soon the alternator will fail completly and you're car will die and have to get towed. Mine died as i pulled into the parking lot where i live, so the sooner the better.
rasmukri is offline  
post #4 of 4 (permalink) Old 02-22-2012 Thread Starter
kkaylynne89's Avatar
Joined: Feb 2012
Location: Tempe
Posts: 4
I replaced the alternator with a refab one from AutoZone but it is still throwing the same code PLUS there have been a few more added. I am now getting P0344(x2), P2106, P2110, P0122, P0223 and P0340(x2) Still!! The battery light is still staying on for about the first 10 minutes of driving and the check engine light is still remaining on. I have a feeling that the car is still misfiring, but I am not for sure. I had the batttery checked and it was good. I just don't get why it's one thing after another at this point...

Last edited by kkaylynne89; 02-22-2012 at 11:33 AM. Reason: left out some info
kkaylynne89 is offline  
Sponsored Links

alternator , battery light stays on , camshaft position sensor , misfiring , p0340

Quick Reply

Register Now

In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

For the best viewing experience please update your browser to Google Chrome