Go Back   Ford Mustang Forums > Mustang > 2005-2014 Mustangs > 2005-2010 Mustang GT Tech

Welcome to our Mustang forums where Mustangers come together to hang out, discuss and enjoy their favorite Mustang hobby with fellow Mustang enthusiasts. We invite everyone to read, post, and enjoy our Mustang forum as well as the many other sections of our site.

You are currently viewing our forums as a guest. By joining our community you gain access to post topics, communicate with members, upload your photos and access many other special features. Registration is fast, simple and free so why wait, join our Mustang community today! If you have any problems with registration or your account login, please contact support.

 

2005-2010 Mustang GT Tech Forum

2011-2014 Talk | 2011-2014 GT | 2011-2014 V6 | 2005-2010 Talk | 2005-2010 GT | 2005-2010 V6 | Shelby GT500 | Mustang Tech 
 

Reply   Post New Thread
Unread 05-01-2006   #1 (permalink)
jplaytym is offline Apprentice

S197 Member


Joined: Jan 2005
Posts: 70 Threads: 17
 jplaytym's Country Flag  View jplaytym's 9 photos
LOXAHATCHEE   Florida
jplaytym is on a distinguished road
Default Need help! New radio subs won't work!!

Hey guys I need help. I just installed a new radio in the Mustang that shaker 500 could only go so far and it sounded like crap, So I put in the New ddx 6019 Kenwood touchsreen radio. I hooked up everything and all works good my front and rear speakers work great but my Subs that are in the doors are not working. Now the questions is why? I have heard some on this forum talk about the Factory amp. But if that is all i have to hook up to then what wires? thanks all in advance for the help.
Attached Thumbnails
Need help! New radio subs won't work!!-hpim0415.jpg  Need help! New radio subs won't work!!-hpim0416.jpg  
__________________
2005 BLACK MUSTANG GT PREMIUM , LAMBORGHINI DOORS,4.10 GEARS, HOOKER HEADERS,GBA EXHAUST, STEEDA SHORT THROW SHIFTER,STEEDA UNDERDRIVE PULLIES,C&L CAI,STEEDA LOWER CONTROL ARMS,AlUMINUM FLY WHEEL, STEEDA CLUTCH AND PRESSURE PLATE ,HT2 HOTTER PLUGS, CUSTOMS FORCED AIR INDUCTION,BMR CROSSBRACE,18" RUFF RACING WHEELS, PUSHBUTTON START, BUILT IN BACK UP CAMERA, RED RACING STRIPES, 305 HP 313 Lbs TRQ. 13.1 1/4 mile at 109mph. AND THE LIST GOES ON!! :eyepoppin
jplaytym is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Sponsored Links
Advertisement
 
Unread 05-02-2006   #2 (permalink)
JoeJP is offline Apprentice


Joined: Nov 2005
Posts: 54 Threads: 1
 JoeJP's Country Flag
Long Island NY   New York
JoeJP is on a distinguished road
Default Re: Need help! New radio subs won't work!!

Not sure exactly what you are asking? But if all you did was hook the Kenwood to the factory harness with an adapter, there is no power going to the door subs. You cannot use the factory amps with an aftermarket radio, so you need to run cables from the Kenwood to a new amp and from the amp to the door speakers. If you changed out the pos factory 8", to a svc sub or dvc 4ohm, then you only need a two channel amp, with the factory dvc 2ohm's, you will need a 4 channel amp. You can tap into the factory speaker harnesses located at the factory amps which are above the kick panel in the driver's footwell. Did you change all of the other speakers? Otherwise the sound will not be any better than the Shaker 500, which I think sounds real good with the right upgrades.
__________________
2006 GT Premium, Legend Lime w/Charcoal; Manual, Opts: IUP, 18" Fanblades, Air Bags, Active Anti-Theft, Spoiler Delete. Perf. Mods: C&L CAI, Predator Tuner, Steeda UDP, FRPP Shortys, FRPP Stingers, Steeda Tri-Ax, Steeda Billet Brace.
JoeJP is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 05-02-2006   #3 (permalink)
hawgman is offline Made Member

S197 Member


Joined: Jun 2005
Posts: 767 Threads: 3
 hawgman's Country Flag  View hawgman's HomePage
North Central   Texas
hawgman is on a distinguished road
Send a message via MSN to hawgman Send a message via Yahoo to hawgman
Default Re: Need help! New radio subs won't work!!

Quote:
Originally Posted by JoeJP
You cannot use the factory amps with an aftermarket radio, so you need to run cables from the Kenwood to a new amp and from the amp to the door speakers.
Sorry, but this info is completely wrong. If you bought the Metra 70-5521 harness it comes with two plugs. The larger one for power, delay, dimming, front and rear speakers, etc., and the smaller one isn for the subs. You use RCA cables from the sub out of the head unit to the harness. Use a "Y" connector to go from the single sub out of the head unit to both inputs on the harness. Then connect the amp on ( and remember to use a voltage regulator on that line ) signal wire to BOTH power wires on the harness. The factory amps and subs will work fine.... sound like crap because that is what they are. But they will work fine.
__________________
2005 GT Premium,torch red, all available factory options.
Performance mods: Lets just say it's not stock.

Some people are like Slinkies. They're really good for nothing. But they still bring a smile to your face when you push them down a flight of stairs.

This IntelliTXT stuff sucks.
hawgman is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 05-02-2006   #4 (permalink)
jplaytym is offline Apprentice

S197 Member


Joined: Jan 2005
Posts: 70 Threads: 17
 jplaytym's Country Flag  View jplaytym's 9 photos
LOXAHATCHEE   Florida
jplaytym is on a distinguished road
Default Re: Need help! New radio subs won't work!!

Quote:
Originally Posted by hawgman
Sorry, but this info is completely wrong. If you bought the Metra 70-5521 harness it comes with two plugs. The larger one for power, delay, dimming, front and rear speakers, etc., and the smaller one isn for the subs. You use RCA cables from the sub out of the head unit to the harness. Use a "Y" connector to go from the single sub out of the head unit to both inputs on the harness. Then connect the amp on ( and remember to use a voltage regulator on that line ) signal wire to BOTH power wires on the harness. The factory amps and subs will work fine.... sound like crap because that is what they are. But they will work fine.

I did use the metra but not that model number you gave,it only came with the large plug. I did look on crutchfield and noticed the one you are talking about I think that is what I need is the smaller plug. Oh and yes I did replace the speakers for 3 way Infinity's/ does anyone know where I can get just that little plug? or can someone give me a close up pics of there plug . I can probably tap into the wires without the plug!!
__________________
2005 BLACK MUSTANG GT PREMIUM , LAMBORGHINI DOORS,4.10 GEARS, HOOKER HEADERS,GBA EXHAUST, STEEDA SHORT THROW SHIFTER,STEEDA UNDERDRIVE PULLIES,C&L CAI,STEEDA LOWER CONTROL ARMS,AlUMINUM FLY WHEEL, STEEDA CLUTCH AND PRESSURE PLATE ,HT2 HOTTER PLUGS, CUSTOMS FORCED AIR INDUCTION,BMR CROSSBRACE,18" RUFF RACING WHEELS, PUSHBUTTON START, BUILT IN BACK UP CAMERA, RED RACING STRIPES, 305 HP 313 Lbs TRQ. 13.1 1/4 mile at 109mph. AND THE LIST GOES ON!! :eyepoppin
jplaytym is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 05-02-2006   #5 (permalink)
hawgman is offline Made Member

S197 Member


Joined: Jun 2005
Posts: 767 Threads: 3
 hawgman's Country Flag  View hawgman's HomePage
North Central   Texas
hawgman is on a distinguished road
Send a message via MSN to hawgman Send a message via Yahoo to hawgman
Default Re: Need help! New radio subs won't work!!

Google search the model and part number and you will find a bazillion places on line selling it. One of them is bound to have a picture.

<update>
Here, I even did the search for ya... You owe me 10 seconds
http://www.audiooutfitter.com/images...mtr70-5521.jpg
__________________
2005 GT Premium,torch red, all available factory options.
Performance mods: Lets just say it's not stock.

Some people are like Slinkies. They're really good for nothing. But they still bring a smile to your face when you push them down a flight of stairs.

This IntelliTXT stuff sucks.
hawgman is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 05-08-2006   #6 (permalink)
R3troGT is offline Rookie


Joined: Apr 2006
Posts: 3 Threads: 0
 R3troGT's Country Flag
Toronto   Ontario
R3troGT is on a distinguished road
Default

I have the same deck as you. I put a box in the Trunk with two 10" subwoofers and a JBL mono amp.
__________________
2006 Mustang GT - Tungsten Grey
C&L Intake & Custom Tune - MAC Performance Exhaust - Eibach Pro Kit - Stedda Strut Tower Brace - Billet Grill Side Scopes - Interior Billet Pieces Polished Fan Shroud Cover
R3troGT is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Sponsored Links
Advertisement
 
Reply   Post New Thread



Thread Tools



Mustang Photos
Mustang Links    Top Sites    RSS    Link To Us    Add to Favorites    Archive    Terms of Use    Site Rules    Privacy    Contact    Sponsors    Advertise   
AllFordMustangs is not affiliated with or endorsed by Ford Motor Company. ©Copyright 2002-2011 All Auto Enthusiasts Network

Search Engine Friendly URLs by vBSEO 3.5.2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172