2007 mustang headlights turning on by themselves - Ford Mustang Forums
Reply
 
LinkBack Thread Tools
post #1 of 19 (permalink) Old 01-25-2009 Thread Starter
ray
Rookie
 
ray's Avatar
 
Joined: Sep 2006
Location: Vancouver
Posts: 4
 
Question 2007 mustang headlights turning on by themselves

Hey,

First I would like to say I've been reading this forum for a few years and have gained lots of info from all of you, Thank you. But i have a question, I recently bought a used 2007 gt500 and I have not seen this problem but both of my parents have. They say that at random times of the day the headlight on my car come on by themselves and after a few minutes turn off. Weird. Anyways just wondering if anyone else has experienced this? The car was originally from the states and when it was brought up to canada the dealer flashed the vehicle for daytime runners, not sure if thats relevant to the problem or not. Ive got a JLT intake and diablo tune and it was having this problem both before and after the tune. I did a quick search and could find anyone else with the same problem. Anyways any help would be greatly appreciated.

Thanks,

Ray
ray is offline  
Sponsored Links
Advertisement
 
post #2 of 19 (permalink) Old 01-25-2009
Made Member
 
topnycdog's Avatar
 
Joined: Nov 2007
Location: Poughkeepsie
Posts: 249
 
Send a message via AIM to topnycdog Send a message via MSN to topnycdog Send a message via Yahoo to topnycdog
no one is pressing the buttons on the remote. because 2007+, has the function of the lights turning on, when you press the unlock button on the remote.

Stock for now. Two GT take off muffler, connected to a GT H-pipe.Upgrade instrument cluster. Shorty antenna. GT rear bumper. GT side skirts. GT front and rear sway bars. So many GT parts, and still a V6 engine. Damn. 18 inch Deep Dish Black rims, with polish lip. 255 front, 275 rear, soon changed to 285.
topnycdog is offline  
post #3 of 19 (permalink) Old 01-25-2009 Thread Starter
ray
Rookie
 
ray's Avatar
 
Joined: Sep 2006
Location: Vancouver
Posts: 4
 
naw, its real weird the keys are in a drawer and a couple of times my dad has got up at like 3 am and he thinks im just getting home cause he sees the lights but im fast a sleep.
ray is offline  
post #4 of 19 (permalink) Old 01-25-2009
Made Member
 
sixers007h's Avatar
 
Joined: Oct 2007
Location: East
Posts: 1,659
 
Maybe there is a ghost in the home that turns the lights on... Ive never heard of this. Maybe your switch is loose or you have a short.
sixers007h is offline  
post #5 of 19 (permalink) Old 01-25-2009
MACH I Member
S197 Member
 
Bocephus357's Avatar
 
Joined: Apr 2008
Location: Central
Posts: 2,544
 
Quote:
Originally Posted by ray View Post
the dealer flashed the vehicle for daytime runners, not sure if thats relevant to the problem or not.
Too keep the running lights on all the time? Is that a requirement in Canada? I would suspect either that or a wiring issue.

2008 Grabber Orange GT premium, 5 speed manual, 3.31s
C&L Racer CAI, Kooks LT headers and catted H pipe, MAC Boom Tubes, Diablosport Predator Tuner with AM/Bama Tunes

Heroes Live Forever
Bocephus357 is offline  
post #6 of 19 (permalink) Old 01-26-2009
Apprentice
4.6L Member
S197 Member
 
07blackgt's Avatar
 
Joined: Dec 2008
Location: Hawthorne
Posts: 121
 
it has to be some sort of wiring issue...if you bought it from a dealer, take it back to them and have them check it out

'07 Mustang GT Manual,Black..
Performance- BBK Long Tube Headers, BBK Catted X Pipe, Corsa Touring Axle Back, JLT Cold Air Intake, 4.10 Ford Racing Gears, MGW Short Throw Shifter, 93 Oct Race Tune by Valley Performance, Ford Racing Lowering Springs, Roush P51 Clutch.
07blackgt is offline  
post #7 of 19 (permalink) Old 01-26-2009 Thread Starter
ray
Rookie
 
ray's Avatar
 
Joined: Sep 2006
Location: Vancouver
Posts: 4
 
yeah i figure its probably best to take it to the dealer, i just wondering if anyone else had a similar issue or if it was a known problem. Guess not. I wonder if when the lights come on do the doors also unlock. Anyways Thanks for your thoughts.
ray is offline  
post #8 of 19 (permalink) Old 01-26-2009
S197 Mustang Owner
4.6L Member
S197 Member
 
hotshot's Avatar
 
Joined: Sep 2006
Location: West Caldwell
Posts: 13,060
 
Send a message via AIM to hotshot
Since you live in Canada and have to have DRL's, i am assuming some wires got crossed. Either that or Big Willy's gremlin finally moved north

2007 Mustang GT Convertible Stage 0 E-Force #402 Supercharger, Brenspeed Tune (435/400), GT500 Fuel pump, Clutch Delete Option, Roush Front Fascia, Brembos, California Dream Hood, Qwitch latch flush mount hood pins, MRT Light Bar, J&M LCA's, BMR UCA, UPR catch can, 6000k, Pypes Bombs, Pypes X-pipe, Airbrushed Flame pieces under the hood, Clear corners, GT500 shocks , FRPP P-springs (rear), BMR Adj Panhard, E-Force engine covers
2012 Ford Focus SEL 5Dr with MyFordTouch, Auto-Park, 303A Package,


hotshot is offline  
post #9 of 19 (permalink) Old 01-26-2009
Apprentice
 
chad05gt's Avatar
 
Joined: Feb 2008
Location: Lake Charles
Posts: 193
 
side marker

i had a side marker light out, I thought no big deal... few days later, get back from dinner and one headlight on... had to disconnect battery.

replaced burnt side marker ,no more problem... closed loop is a *****!

NO N2O, NO boost, ALL N/Asty! (for now...)

12.05 @ 117.05
320hp/291tq Mustang Dyno
FRPP intake, Livernois stage II heads, Comp stage II VSR, 39lbinj., TR6060, 4.56, GT500tb...
Pics/Mods list/Vids: search Chad05gt on youtube & cardomain
302 shortblock on its way; 67mm PH turbo, 80lb inj., GT500 pumps, eBoost2, ...
chad05gt is offline  
MODERATOR
Classic Member
S197 Member
 
stlwagon's Avatar
 
Joined: Oct 2005
Location: Southern
Posts: 74,615
                 
Send a message via Yahoo to stlwagon
Either a short or a problem with the active theft control system.

1965 Mustang Coupe
stlwagon is offline  
Rookie
 
Blk07ShelbyGT's Avatar
 
Joined: Mar 2011
Location: Batavia
Posts: 1
 
I have a 2007 Shelby GT with that active security system and my car does the same thing from time to time. Ford says there is no explanation for it. But you aren't alone.
Blk07ShelbyGT is offline  
Rookie
 
Codeman_82's Avatar
 
Joined: May 2012
Location: Spokane
Posts: 1
 
We just bought a 2007 GT and we are having the same exact problem you are having. Not sure if we should take it into the Ford dealer and rack up an expensive bill. You mentioned that Ford wasn't able to find anything with your GT. I'm thinking it must be a wiring issue. Are you still having this issue? If you're not, what did you do to solve it?
Frustrated,
Codeman_82
Codeman_82 is offline  
GT Member
 
stars's Avatar
 
Joined: Jan 2003
Location: ...
Posts: 1,275
 
Quote:
Originally Posted by Codeman_82 View Post
We just bought a 2007 GT and we are having the same exact problem you are having. Not sure if we should take it into the Ford dealer and rack up an expensive bill. You mentioned that Ford wasn't able to find anything with your GT. I'm thinking it must be a wiring issue. Are you still having this issue? If you're not, what did you do to solve it?
Frustrated,
Codeman_82
Other than hotshot Iím not sure if any of those guys are still around. At any rate, the lights in the S197 are controlled by the smart junction box (SJB, located in the passenger side kick panel). The light switch simply tells it what you want to do. Stupid thing is if the switch is disconnected instead of the lights staying out they come on. If an intermittent in the light switch assembly develops (or the wire harness that connects to it) that behavior could cause the lights to come on. If thereís ever been water incursion into the SJB it could be flaky too. If you have an active alarm system that might also cause some issues if itís developed a problem.
stars is offline  
Made Member
 
jasonthefox's Avatar
 
Joined: Aug 2011
Location: Cape Breton
Posts: 381
 
I have an 07 GT and have had the exact same issue- although it seems to have resolved itself, oddly though. They would randomly turn on, as if I had hit the unlock button. But only the lights. The wasn't car actually unlocking itself. Could happen at anytime of the day or night and they'd stay on for about 30 seconds. Lasted from about November to March. I wasn't able to figure it out so I took it to the service dept at my Ford dealership. They said they'd seen this problem before, and were pretty sure it was cause by corrosion on the circuit that controls the headlight coming on with the unlock button, in the smart junction box. Likely caused by moisture getting in there.

So I let them "clean" it off or whatever they did. Problem seemed fixed for about 2 or 3 days and came back. But it seems to have fixed itself - I haven't seen (or been told) it happening in about 2 months. For what it's worth, I'm thinking it may have been related to the colder and wetter winter weather. I'm literally like 10 mins from the Atlantic ocean.

2007 GT - vista blue/black leather/auto/3.73 gears/CnL Racer CAI, SLP Powerflo axelbacks, tuned by Bama!
jasonthefox is offline  
Apprentice
 
LS1GodOfPain's Avatar
 
Joined: Jan 2008
Location: Amarillo
Posts: 163
 
I'm with SJB also, I'm having trouble with mine right now and I did notice if it looses power of is having a problem the headlights turn on. Hell you can take it out of the car completely and the lights turn on.
LS1GodOfPain is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Mustang Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182