2003 Mustang Service engine soon light - Ford Mustang Forum

 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 06-11-2009 Thread Starter
Rookie
4.6L Member
 
benny1450's Avatar
 
Joined: Mar 2009
Location: Chico
Posts: 6
 
Question 2003 Mustang Service engine soon light

So the SES light keeps coming on. The code is Cylinder 2 misfire! I replaced the spark with original sparks. It will run for a while b4 the light comes on. I also changed the Spark Coil and switch it with another Cylinder to see if it was that, but had no luck. light came back on, same cylinder. Any ideas what the problem could be?

benny1450 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 06-11-2009
PONY Member
4.6L Member
 
AJCaron12's Avatar
 
Joined: May 2009
Location: Manchester
Posts: 613
 
Quote:
Originally Posted by benny1450 View Post
So the SES light keeps coming on. The code is Cylinder 2 misfire! I replaced the spark with original sparks. It will run for a while b4 the light comes on. I also changed the Spark Coil and switch it with another Cylinder to see if it was that, but had no luck. light came back on, same cylinder. Any ideas what the problem could be?
Could be a bad injector


2000 GT 14.5 sec @ 98 mph
SCT tuner...SLP powerflo catback...JLT short ram intake...Typhoon intake manifold...Professional products throttle body...C&L intake plenum...Steeda underdrive pulleys...Steeda tri-ax short throw shifter...05-09 Mustang GT shift knob...Steeda adjustable clutch cable, firewall adjuster, and quadrant kit...Eibach front sway bar...Steel strut bar...Tokico shocks...Polyurethane spring isolators...J&M rear lower control arms...Powerslot rotors...Nitto tires
AJCaron12 is offline  
post #3 of 4 (permalink) Old 06-11-2009
Apprentice
4.6L Member
 
02BlkGt's Avatar
 
Joined: Feb 2009
Location: St. Joseph
Posts: 199
 
thats odd... i had the same exact problem cylinder 2 misfire in first 1000 rpm upon startup. changed all the plugs out and its been runnin better since.

2005 Pontiac G6 GT.. Also gone :-(
2002 Mustang GT So long... :-(
2010 Mitsubishi Lancer Sloooowwwww
Dreamin about when i will get my 20?? Shelby 500
02BlkGt is offline  
post #4 of 4 (permalink) Old 08-19-2012
Rookie
 
llcccc's Avatar
 
Joined: Aug 2012
Location: pflugerville
Posts: 3
 
Service enginge soon

I have the same problem and when accelerate to rpm 4000 then engine sacking look like not enougt gass what would be thw problem
llcccc is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome