ABS Light is on.. 2004 Mustang GT - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 9 (permalink) Old 04-27-2010 Thread Starter
Rookie
4.6L Member
 
Schimy 844's Avatar
 
Joined: Apr 2010
Location: Columbia City
Posts: 4
 
ABS Light is on.. 2004 Mustang GT

I had the back of my car up on jackstands and the front was still touching. well I started the car and accidentally left the parking brake on while i let the tires spin to check out a rear end problem. Well to cut to the chase when I started the car my abs light stays on now. Anybody know why! or how to get it off.
Schimy 844 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 04-27-2010
SHELBY GT 350 Member
 
2oo5GT's Avatar
 
Joined: Nov 2007
Location: Pope AFB
Posts: 5,151
 
Maybe a wheel sensor was damaged or something while it was up. If nothing seems out of the ordinary, reset the computer and see if it comes back.

-2003 Mustang Cobra
1 of 451 Oxford White #1415
-Violent Work Of Art-
-2003 Ford Lightning
1 of 723 Sonic Blue #113
--13' GT500 TVS powered--
-2005 Expedition XLT--DD
-2013 Ford Escape 1.6T
2oo5GT is offline  
post #3 of 9 (permalink) Old 05-08-2010
Apprentice
4.6L Member
 
Rami35thAnnGT's Avatar
 
Joined: Feb 2008
Location: Yonkers
Posts: 77
 
I have the same problem. I reset the computer but it still comes back... After I am done with my suspension work, I am gonna see if it is a ABS Sensor (which is likely.) I will let you know if the work is easy. Hopefully it is.
Rami35thAnnGT is offline  
post #4 of 9 (permalink) Old 05-08-2010
Made Member
4.6L Member
 
JoeLee's Avatar
 
Joined: Jan 2007
Location: San Juan
Posts: 258
 
I had that happen to me twice. Both times the light dissapeared after having to jam on the brakes to do a hard stop.
I know it sounds silly, but find and empty road and try a hard stop from at least 30 or 40 mph. It may be that when the ABS gets activated, it resets the light.
( I dont know sh!t about brakes, sensors, ABS or any mechanical thing for that matter; I'm just telling you what happened to me. Maybe someone that knows better will chime in).

2002 GT Zinc Yellow Premium Edition, Borla Stinger Catback, MRT Catted H, KB 2.1L 9#, Accufab 70mm TB, FRPP 3.73 gears, SCT custom tune, street/strip valve body, Mach 1 Grille Delete/Chin Spoiler/Brake Upgrade, Bullit suspension kit, Steeda UCA/LCA
JoeLee is offline  
post #5 of 9 (permalink) Old 05-08-2010
Apprentice
4.6L Member
 
Rami35thAnnGT's Avatar
 
Joined: Feb 2008
Location: Yonkers
Posts: 77
 
Anybody with a do-it-yourself instruction guide for this?! *Changing a ABS Sensor*
Rami35thAnnGT is offline  
post #6 of 9 (permalink) Old 05-08-2010
Apprentice
4.6L Member
 
Rami35thAnnGT's Avatar
 
Joined: Feb 2008
Location: Yonkers
Posts: 77
 
Actually, I just went and played with the car a little bit. It is very easy to do, I just removed my fender well cover and the line is right there. If you have a ABS Diagnostic Tool, it would be very simple to diagnose which sensor is bad or what is bad and then you can access the sensors easily.
Rami35thAnnGT is offline  
post #7 of 9 (permalink) Old 05-08-2010
Rookie
 
ModMustang281's Avatar
 
Joined: Mar 2010
Location: Decatur - the crap hole
Posts: 31
 
i had abs light problem in my 96 gt during the winter, i took the car up to high speed (100-120) and the light turned off
(it only came on as soon as i started to move, as soon as the car moved it came on)
^what about you
ModMustang281 is offline  
post #8 of 9 (permalink) Old 05-24-2010
Rookie
 
djbronco's Avatar
 
Joined: May 2010
Location: Caldwell
Posts: 4
 
Mine comes on at 50MPH

Mine comes on every time I reach 50 MPH and stays on until I turn the car off! Anybody have any ideas why this is happening?
djbronco is offline  
post #9 of 9 (permalink) Old 05-24-2010
Rookie
 
LoudStang00's Avatar
 
Joined: Jan 2010
Location: Spartanburg
Posts: 1
 
I have a 2000 Mustang GT and this same thing happened to me...my abs light came on and stayed on..I still havnt gotten it fixed..It only comes on very other day though. I think I might have damaged a wheel senser after hiting a pot hole at 60.
LoudStang00 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Tags
abs , abs light , brakes

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in









Random Question

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183