Go Back   Ford Mustang Forums > Mustang > 4.6 Mustang > 4.6L Tech

Welcome to our Mustang forums where Mustangers come together to hang out, discuss and enjoy their favorite Mustang hobby with fellow Mustang enthusiasts. We invite everyone to read, post, and enjoy our Mustang forum as well as the many other sections of our site.

You are currently viewing our forums as a guest. By joining our community you gain access to post topics, communicate with members, upload your photos and access many other special features. Registration is fast, simple and free so why wait, join our Mustang community today! If you have any problems with registration or your account login, please contact support.


Reply   Post New Thread
Unread 02-23-2006   #1 (permalink)
Mikes90 is offline Apprentice


Joined: Sep 2002
Posts: 83 Threads: 14
 Mikes90's Country Flag  View Mikes90's 4 photos
Madison Tn   Tennessee
Mikes90 is on a distinguished road
Default P0320 Fault Code

Hey guys,I haven't been here for a while. After the rebuild my 5.0 is running better than ever and is gettin tired of eatin rice. My buddy has a 98 4.6 GT. It has been running eratic. missing, stalling and even dieing completely. Sometimes it runs great and then it starts acting up. Pulled the code P0320 but it is a very broad range....anyone seen this or have any ideas?????
__________________
1990 5.0 LX
Flowmaster American Thunder Cat-Back, MAC C.A.I., Cervini Hood ,Cobra R Rims 16", Underdrive Pullies,TFS 302 Engine Kit, Twisted Wedge Heads, TFS Valve Covers, TFS Forged Pistons, TFS Track Heat Intake, Stage One Cam, BBK Shorty Headers,TFS Roller Rockers, 70MM Throttle Body, NOS 150
Mikes90 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Sponsored Links
Advertisement
 
Unread 02-23-2006   #2 (permalink)
BlueStreak03 is offline SHELBY GT 500 Member


Joined: Nov 2002
Posts: 5,947 Threads: 463
 BlueStreak03's Country Flag  View BlueStreak03's 78 photos
Trinity   North Carolina
BlueStreak03 is on a distinguished road
Send a message via AIM to BlueStreak03 Send a message via Yahoo to BlueStreak03
Default

What is the description given with the code?? It sounds a lot like a bad IAC.
__________________
"Posterity! You will never know how much it cost the present Generation to preserve your Freedom! I hope you will make good use of it. If you do not, I shall repent in Heaven, that I ever took half the Pains to preserve it."

John Adams
BlueStreak03 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 02-23-2006   #3 (permalink)
engineer76 is offline Made Member

4.6L Member
S197 Member


Joined: Feb 2005
Posts: 701 Threads: 23
 engineer76's Country Flag
Zurich
engineer76 is on a distinguished road
Default

That sounds like a crankshaft positioning sensor problem.
The ECU (PCM) doesn't know where it's pistons are and therefore fires at the wrong time or not at all.
You might want to clean/inspect the gears and sensor and wiring of the crankshaft positioning sensor.
After that, reset the ECU. (battery off for 20 minutes, headlight on)

Autozone has a good article on that:

http://www.autozone.com/servlet/UiBr...3d801da853.jsp

Hope this helps!
__________________
2006 Ford Mustang GT (daily driver)
other cars
engineer76 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 02-25-2006   #4 (permalink)
green 01 is offline Apprentice

4.6L Member


Joined: Apr 2005
Posts: 98 Threads: 27
 green 01's Country Flag
Lockport   Illinois
green 01 is on a distinguished road
Default

take a look ca this link. i hope it helps.



http://www.dr-mustang.com/index.php?...ontent&tid=747
green 01 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 02-05-2010   #5 (permalink)
ales.s_18 is offline Rookie


Joined: Feb 2010
Posts: 3 Threads: 1
 ales.s_18's Country Flag
miami   Florida
ales.s_18 is on a distinguished road
Default

hi people.

my mustang v6 when the engine warned up started to misfires and eventually goes off..... its turn on again ease.. also loses power, i'm installing the diagnostic computer and got these two failure code P0320 , P0618

anybody can help me??
ales.s_18 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Sponsored Links
Advertisement
 
Reply   Post New Thread



Thread Tools



Mustang Photos
Mustang Links    Top Sites    RSS    Link To Us    Add to Favorites    Archive    Terms of Use    Site Rules    Privacy    Contact    Sponsors    Advertise   
AllFordMustangs is not affiliated with or endorsed by Ford Motor Company. ©Copyright 2002-2011 All Auto Enthusiasts Network

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162