1989 Mustang LX 5.0 heater not working - Ford Mustang Forum
LinkBack Thread Tools
post #1 of 2 (permalink) Old 01-13-2010 Thread Starter
4.6L Member
5.0L Member
S197 Member
dean donnell's Avatar
Joined: Dec 2009
Location: Franklin
Posts: 33
1989 Mustang LX 5.0 heater not working

any one have an idea why the heater in my 1989 lx 5.0 wouldnt work after ive replaced the heater coil?

please advise
dean donnell is offline  
Sponsored Links
post #2 of 2 (permalink) Old 01-14-2010
Made Member
5.0L Member
76Ford90LX's Avatar
Joined: Oct 2007
Location: Riverside
Posts: 1,202
Whats not working?

Is it not blowing air? Or is it Blowing air but its not hot air?

1990 LX, Vortech Sc-Trim, UPR Power Pipe, C&L 76mm MAF, DIY ported upper, MAC 70mm T/B, BBK Equal length shorties, BBK O/R H-pipe, Flowmasters with Dumps, FRPP 4.10 gears, Strange 10 Way Shocks, BBK Springs, Electric Fan, 130 Amp Alt, FRPP Plug Wires, MSD Cap, MSD Coil.
76Ford90LX is offline  
Sponsored Links
Closed Thread

Quick Reply

Register Now

In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

For the best viewing experience please update your browser to Google Chrome