I was just wondering why my coolant level in my radiator always extremely low?? - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 12 (permalink) Old 01-29-2003 Thread Starter
Apprentice
 
1fast90gt's Avatar
 
Joined: Oct 2002
Location: Corpus Christi
Posts: 112
 
Angry coolant loss question

I was just wondering why my coolant level in my radiator always extremely low?? I never see coolant on the ground and I checked all my hoses, and they are fine. Somebody told me if your thermostat is bad it will cause the car to heat up and cause evaporation???????!!!!! any truth to this???

1fast90gt is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 01-29-2003
PONY Member
 
Sniper's Avatar
 
Joined: Sep 2002
Location: El Paso
Posts: 589
 
I'm having the same problem right now! I checked my oil pan to see if there was any coolant in there but there was nothing. I'm guessing that I have a leak somewhere near the water pump. It's just not enough to make puddles under the car. Have you changed your intake manifold? Maybe it's leaking from around the lower intake. Hopefully we figure this out soon!

Sniper is offline  
post #3 of 12 (permalink) Old 01-29-2003
Apprentice
5.0L Member
 
swurvinervin's Avatar
 
Joined: Dec 2002
Location: Midwest
Posts: 196
 
Does anyone know how long a Ford thermostat will last?

1992 Mustang GT AOD 3:73 BBK headers and X Pipe w/ cats 144,000 miles
swurvinervin is offline  
post #4 of 12 (permalink) Old 01-29-2003 Thread Starter
Apprentice
 
1fast90gt's Avatar
 
Joined: Oct 2002
Location: Corpus Christi
Posts: 112
 
No sniper I haven't changed my intake lately. I guess I will keep looking and update you.
1fast90gt is offline  
post #5 of 12 (permalink) Old 01-29-2003
C J
PONY Member
5.0L Member
 
C J's Avatar
 
Joined: Jul 2002
Location: Avondale
Posts: 519
 
have/can you do a coolant pressure test??

94 GT Vert - MM coil overs, SFC, Panhard bar, C/C Plates, bumpsteer kit, alum. rack bushings, Rear LCAs, Ft ctl arms, 6pt Roll Bar; MAC equal length headers, catted hpipe, cat back, CAI; Baer Ft Tk+ brake kit; 3.73 FRPP Gears; 245s ft, 275s rear on Cobra 17 x 9; Cobra Daytona seats(powered).
00 Excursion - 7.3L 4x4 LTD, 8" lift, 38x15.5x18 Toyo M/T tires, chipped, Banks i/c, AFE CAI, APRacing brakes, Dynatrac c/o steer, Warn hubs, HD bumper & 15k winch
http://www.cardomain.com/id/cjones101812
C J is offline  
post #6 of 12 (permalink) Old 01-29-2003
Apprentice
5.0L Member
 
tamu93gt's Avatar
 
Joined: Oct 2002
Location: san antonio
Posts: 164
 
Send a message via AIM to tamu93gt
My low coolant light comes on quite often however I know there is plenty of fluid in the radiator. Just for grins make sure the coolant sensor isn't to dirty and if it is clean it.

93 Gt, trickflow upper and lower intake with CAI.
tamu93gt is offline  
post #7 of 12 (permalink) Old 01-29-2003
Banned
 
Twister's Avatar
 
Joined: Jul 2002
Location: Phoenix
Posts: 4,479
 
usually, it is a cracked overflow bottle, for some reson, they dont last too long
Twister is offline  
post #8 of 12 (permalink) Old 01-29-2003
Rookie
 
Tha Pony's Avatar
 
Joined: Dec 2002
Location: Mississippi
Posts: 46
 
Send a message via AIM to Tha Pony
I have noticed that my low coolant light is always on. I have a 91' lx

vroom! vroom! Boom! Boom! vroom! vroom! boom! (Ah, the sound of my beast and my bump.)
Tha Pony is offline  
post #9 of 12 (permalink) Old 01-30-2003 Thread Starter
Apprentice
 
1fast90gt's Avatar
 
Joined: Oct 2002
Location: Corpus Christi
Posts: 112
 
my coolant light never comes on, but my overflow bottle is crap it is cracked and it is missing the cap. Could that be it??
1fast90gt is offline  
Rookie
 
zman95GTS's Avatar
 
Joined: Oct 2002
Location: Fort Worth TX
Posts: 15
 
I had the same problem and found that it was a bad radiator cap, coolant was evaporating out of the top of the radiator, if you can get ahold of a pressure tester, test the cap, or fork over the few bucks it takes to get a new one. Good Luck!!

Zman
95 GTS
K&N
Ford Racing Springs
Mac Off-Road H-Pipe
Mac Shorties
Flowmaster Cat Back
MSD 8mm
Steeda Tri-Ax
NEED MORE!!!!
zman95GTS is offline  
post #11 of 12 (permalink) Old 01-30-2003 Thread Starter
Apprentice
 
1fast90gt's Avatar
 
Joined: Oct 2002
Location: Corpus Christi
Posts: 112
 
i replaced it with a universal one , for like $5.95, and it really is cheap. Is there a better one to use ???
1fast90gt is offline  
post #12 of 12 (permalink) Old 01-30-2003 Thread Starter
Apprentice
 
1fast90gt's Avatar
 
Joined: Oct 2002
Location: Corpus Christi
Posts: 112
 
Also, is there a certain pressure cap that is needed?? I have seen diff. pressure caps.
1fast90gt is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome