Go Back   Ford Mustang Forums > Mustang > 5.0 Mustang > 5.0L Tech

Welcome to our Mustang forums where Mustangers come together to hang out, discuss and enjoy their favorite Mustang hobby with fellow Mustang enthusiasts. We invite everyone to read, post, and enjoy our Mustang forum as well as the many other sections of our site.

You are currently viewing our forums as a guest. By joining our community you gain access to post topics, communicate with members, upload your photos and access many other special features. Registration is fast, simple and free so why wait, join our Mustang community today! If you have any problems with registration or your account login, please contact support.

5.0 Mustangs Tech Forum

5.0L Talk | 5.0L Tech | 94-95 Tech | 1979-1993   1994   1995   Upload Pictures | Timeslips | Power Adders | Mustang Tech 


Reply   Post New Thread
Unread 02-25-2010   #1 (permalink)
mustangracr92 is offline Apprentice

5.0L Member


Joined: Jan 2008
Posts: 81 Threads: 21
 mustangracr92's Country Flag
Shelby   Alabama
mustangracr92 is on a distinguished road
Send a message via AIM to mustangracr92
Default what are symptoms of a bad maf sensor?

does anyone know the symptoms of a bad maf sensor? any input would be nice! thanks
mustangracr92 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Sponsored Links
Advertisement
 
Unread 02-25-2010   #2 (permalink)
cwc1979 is offline Apprentice

4.6L Member


Joined: Jan 2010
Posts: 93 Threads: 11
 cwc1979's Country Flag
Paducah   Kentucky
cwc1979 is on a distinguished road
Default

Hmm, I would think it would feel underpowered, and maybe hesitate a little during acceleration. Possibly not idling correctly either. Try and just clean it real good before you go and replace it.
__________________
2004 Expedition
2004 Mustang Cobra
1998 F150

Yes, I like Fords.
cwc1979 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 02-25-2010   #3 (permalink)
need4spd90 is offline SHELBY GT 350 Member

5.0L Member


Joined: Apr 2009
Posts: 6,366 Threads: 45
 need4spd90's Country Flag
Mountain Top   Pennsylvania
need4spd90 is on a distinguished road
Default

check for codes..if the sensor isnt working correctly,you'll know for sure..not just guessing,wasting money and time on un-needed parts that may not be broken in the first place

DIY KOEO/KOER/Cylinder Balance Self-Test Procedure
__________________
1987 Notchback - N/A stock 302, TFS heads, Holley Systemax, FTI cam, Astro A5
Best so far: 10.92 @ 123mph with a 1.49 60ft
need4spd90 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 02-25-2010   #4 (permalink)
mustangracr92 is offline Apprentice

5.0L Member


Joined: Jan 2008
Posts: 81 Threads: 21
 mustangracr92's Country Flag
Shelby   Alabama
mustangracr92 is on a distinguished road
Send a message via AIM to mustangracr92
Default

yes! it surges at idol bad and most of the time will not stay running. and it does feel underpowered bad. if i give it full throttle its worse power than 3/4 it just kinda quits pullin like its not getting enough fuel or something
mustangracr92 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 02-26-2010   #5 (permalink)
need4spd90 is offline SHELBY GT 350 Member

5.0L Member


Joined: Apr 2009
Posts: 6,366 Threads: 45
 need4spd90's Country Flag
Mountain Top   Pennsylvania
need4spd90 is on a distinguished road
Default

Quote:
Originally Posted by mustangracr92 View Post
yes! it surges at idol bad and most of the time will not stay running. and it does feel underpowered bad. if i give it full throttle its worse power than 3/4 it just kinda quits pullin like its not getting enough fuel or something
and checking for trouble codes is the FIRST place to start to diagnose any of those symptoms..

what dont you guys understand about that?

sounds more like a TPS or timing condition than a bad maf to me..but checking the codes will verify whats wrong..i gave you a step by step link on how to do it..

..or you could just waste money replacing parts that arent broken in the first place..
__________________
1987 Notchback - N/A stock 302, TFS heads, Holley Systemax, FTI cam, Astro A5
Best so far: 10.92 @ 123mph with a 1.49 60ft
need4spd90 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 02-26-2010   #6 (permalink)
Blt2Lst is offline PONY Member

5.0L Member


Joined: Mar 2009
Posts: 684 Threads: 32
 Blt2Lst's Country Flag
Redondo Beach   California
Blt2Lst is on a distinguished road
Default

Quote:
Originally Posted by need4spd90 View Post
checking for trouble codes is the FIRST place to start to diagnose any of those symptoms..
Good advice..
__________________
89 LX Vert 5.0 Mostly Stock
5 speed,
2.73, TracLok still blown, but, new Spec Stg 1 Clutch
Dynomax Super Turbo
s[i]

I'm a victim of circumstance..


Blt2Lst is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 02-26-2010   #7 (permalink)
YLDPONY is offline SHELBY GT 350 Member

5.0L Member


Joined: Nov 2009
Posts: 8,798 Threads: 46
 YLDPONY's Country Flag  View YLDPONY's 29 photos
Thornville   Michigan
YLDPONY is on a distinguished road
Default

When I first got my car, it was doing the same thing with the "more power at 3/4 throttle than on the floor" thing. Mine turned out to have a really dirty MAF.

One of my SHO friends had the same problem. To make sure the MAF was the culprit one of the other guys had us unplug it. We test drove it and it worked on that car, the power was back and it revved right out. We drove it back, cleaned the MAF and problem solved.

I have heard some say the unplugging the MAF thing as a test doesn't work, but it is worth a try, imho. 0$ and 1.5 minutes.
__________________
'94 Laser red 'vert. Still a 5-oh... for now
YLDPONY is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 02-26-2010   #8 (permalink)
spdjnky_42 is offline Top Dog

5.0L Member


Joined: Nov 2007
Posts: 13,639 Threads: 204
 spdjnky_42's Country Flag  View spdjnky_42's 21 photos
St.Louis   Missouri
spdjnky_42 is on a distinguished road
Send a message via Yahoo to spdjnky_42
Default

A bad MAF would definetly cause surging and no idle. Especially if the air filter is removed or in the wrong location depending on the maf. RUN THE CODES.
spdjnky_42 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Sponsored Links
Advertisement
 
Reply   Post New Thread



Thread Tools



Mustang Photos
Mustang Links    Top Sites    RSS    Link To Us    Add to Favorites    Archive    Terms of Use    Site Rules    Privacy    Contact    Sponsors    Advertise   
AllFordMustangs is not affiliated with or endorsed by Ford Motor Company. ©Copyright 2002-2011 All Auto Enthusiasts Network

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162