Go Back   Ford Mustang Forums > Mustang > 5.0 Mustang > 5.0L Tech

Welcome to our Mustang forums where Mustangers come together to hang out, discuss and enjoy their favorite Mustang hobby with fellow Mustang enthusiasts. We invite everyone to read, post, and enjoy our Mustang forum as well as the many other sections of our site.

You are currently viewing our forums as a guest. By joining our community you gain access to post topics, communicate with members, upload your photos and access many other special features. Registration is fast, simple and free so why wait, join our Mustang community today! If you have any problems with registration or your account login, please contact support.

5.0 Mustangs Tech Forum

5.0L Talk | 5.0L Tech | 94-95 Tech | 1979-1993   1994   1995   Upload Pictures | Timeslips | Power Adders | Mustang Tech 


Reply   Post New Thread
Unread 10-18-2010   #1 (permalink)
Saleen302 is offline Apprentice

5.0L Member


Joined: Oct 2010
Posts: 161 Threads: 18
 Saleen302's Country Flag  View Saleen302's 7 photos
Regina   Saskatchewan
Saleen302 is on a distinguished road
Default KOEO Test gave me code 31,41,91

I did the self test because my check engine light would come on the odd time and would piss me off. My gas mileage sucks recently and i had the slight idle problems as well. Car runs fine but i know there is something wrong. I took all the Spark plugs off and they had some white color to them, also they are gapped at 55 i got 8mm wires and msd cap and rotor and stock coil, I then took off the O2 sensors and they were white colorish as well so i know i got a lean air/fuel mixture. I had a hole in my charcoal canister and had replaced that 2 days ago. i checked for apparant vacuum leaks and none could be found. Today i cleaned and made sure i had good connection with the 10hole salt n pepper shakers to possibly fix my code 31 which is low voltage to egr solenoid. Im waiting to buy 2 new O2 sensors to hopefully fix code 41 and 91. HAS ANYONE HAD THESE CODE PROBLEMS AND HOW DID YOU FIX THEM? when i get the new 02 sensors when i put them on i will disconnect the battery for 30 mins to erase memory...Help anyone?
__________________
93 5 speed 306/GT40p Heads,GT40 Tubular Intake,Stock Cam/Electric fan/3g 130amp/MAC underdrives/Blue Thunder Short Throw/MAC offroad Xpipe/Flows super 44/Eibach prokit/MMS lower control arms & Bumpsteer kit/Retrofit Projectors 6000k HID/Saleen spoiler
Saleen302 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Sponsored Links
Advertisement
 
Unread 10-18-2010   #2 (permalink)
spdjnky_42 is offline Top Dog

5.0L Member


Joined: Nov 2007
Posts: 13,639 Threads: 204
 spdjnky_42's Country Flag  View spdjnky_42's 21 photos
St.Louis   Missouri
spdjnky_42 is on a distinguished road
Send a message via Yahoo to spdjnky_42
Default

those are 02 codes but sometimes they can be from a bad fuel regulator. As for 31 replace the EGR solenoid or if you can (emmisions allowing) remove it. May want to wait on the EGR and see if it goes away after you fix the lean cond.
spdjnky_42 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 10-18-2010   #3 (permalink)
Saleen302 is offline Apprentice

5.0L Member


Joined: Oct 2010
Posts: 161 Threads: 18
 Saleen302's Country Flag  View Saleen302's 7 photos
Regina   Saskatchewan
Saleen302 is on a distinguished road
Default

how can i tell if the fuel pressure regulator is bad or not giving good pressure? the one i got is factory, and what should the pressure be at?
__________________
93 5 speed 306/GT40p Heads,GT40 Tubular Intake,Stock Cam/Electric fan/3g 130amp/MAC underdrives/Blue Thunder Short Throw/MAC offroad Xpipe/Flows super 44/Eibach prokit/MMS lower control arms & Bumpsteer kit/Retrofit Projectors 6000k HID/Saleen spoiler
Saleen302 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 10-18-2010   #4 (permalink)
spdjnky_42 is offline Top Dog

5.0L Member


Joined: Nov 2007
Posts: 13,639 Threads: 204
 spdjnky_42's Country Flag  View spdjnky_42's 21 photos
St.Louis   Missouri
spdjnky_42 is on a distinguished road
Send a message via Yahoo to spdjnky_42
Default

with both 02 codes and a factory reg i say change it sometimes you can smell gas in the vaccum hose.
spdjnky_42 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 10-18-2010   #5 (permalink)
Saleen302 is offline Apprentice

5.0L Member


Joined: Oct 2010
Posts: 161 Threads: 18
 Saleen302's Country Flag  View Saleen302's 7 photos
Regina   Saskatchewan
Saleen302 is on a distinguished road
Default

which vacuum hose you talking about? how much are fuel pressure regulators?? can i test it somehow without knowing it good or bad? i guess this is where an adjustable fuel pressure regulator is good to have
__________________
93 5 speed 306/GT40p Heads,GT40 Tubular Intake,Stock Cam/Electric fan/3g 130amp/MAC underdrives/Blue Thunder Short Throw/MAC offroad Xpipe/Flows super 44/Eibach prokit/MMS lower control arms & Bumpsteer kit/Retrofit Projectors 6000k HID/Saleen spoiler
Saleen302 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 10-18-2010   #6 (permalink)
spdjnky_42 is offline Top Dog

5.0L Member


Joined: Nov 2007
Posts: 13,639 Threads: 204
 spdjnky_42's Country Flag  View spdjnky_42's 21 photos
St.Louis   Missouri
spdjnky_42 is on a distinguished road
Send a message via Yahoo to spdjnky_42
Default

Yeah I would get a BBK or holley. The vacuum line running from the factory reg. You are lean on both banks, either both your 02 are bad or your reg is causing the problem (i.e. a chunk of the diaphram has lodged in the fuel line opening.
spdjnky_42 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 10-18-2010   #7 (permalink)
Saleen302 is offline Apprentice

5.0L Member


Joined: Oct 2010
Posts: 161 Threads: 18
 Saleen302's Country Flag  View Saleen302's 7 photos
Regina   Saskatchewan
Saleen302 is on a distinguished road
Default

have you had that experience in the past? well first i will buy the o2 sensors and test them and run the codes again and see if anything comes up. thanks for your help
__________________
93 5 speed 306/GT40p Heads,GT40 Tubular Intake,Stock Cam/Electric fan/3g 130amp/MAC underdrives/Blue Thunder Short Throw/MAC offroad Xpipe/Flows super 44/Eibach prokit/MMS lower control arms & Bumpsteer kit/Retrofit Projectors 6000k HID/Saleen spoiler
Saleen302 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 10-18-2010   #8 (permalink)
spdjnky_42 is offline Top Dog

5.0L Member


Joined: Nov 2007
Posts: 13,639 Threads: 204
 spdjnky_42's Country Flag  View spdjnky_42's 21 photos
St.Louis   Missouri
spdjnky_42 is on a distinguished road
Send a message via Yahoo to spdjnky_42
Default

Run the 02's and check plugs again LOL This is not my first rodeo
spdjnky_42 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 10-20-2010   #9 (permalink)
Saleen302 is offline Apprentice

5.0L Member


Joined: Oct 2010
Posts: 161 Threads: 18
 Saleen302's Country Flag  View Saleen302's 7 photos
Regina   Saskatchewan
Saleen302 is on a distinguished road
Default

Ok well my g/f bought me NTK O2 sensors because Canadian Tire only sells those and they said they dont sell the bosch ones anymore. So the new O2 sensors cleared codes 41 and 91. But i only got code 31 left that wont go away. So i plan on getting a different sensor for the EGR and see if that will go away. Since i got the new O2 Sensors, my car has its power back, it pulls alot better in 2nd gear! and the exhaust sounds more snappy..
__________________
93 5 speed 306/GT40p Heads,GT40 Tubular Intake,Stock Cam/Electric fan/3g 130amp/MAC underdrives/Blue Thunder Short Throw/MAC offroad Xpipe/Flows super 44/Eibach prokit/MMS lower control arms & Bumpsteer kit/Retrofit Projectors 6000k HID/Saleen spoiler
Saleen302 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 11-08-2010   #10 (permalink)
Saleen302 is offline Apprentice

5.0L Member


Joined: Oct 2010
Posts: 161 Threads: 18
 Saleen302's Country Flag  View Saleen302's 7 photos
Regina   Saskatchewan
Saleen302 is on a distinguished road
Default

so i finally fixed code 31. i took the EGR solenoid off and took it apart and cleaned the filter and put a bit of dielectric grease on some electrical contacts and adjusted the long bolt screw that goes in the middle of the solenoid and erased the computer codes, drove my car for about 30 minutes at different speeds and did the KOEO test 2 times and all im getting is code 11 system pass. what i did knotice when i did clean and adjust the EGR solenoid is that when i first start my car my idle sits very still at 750/800rpm's, before there was a little jump maybe like a 50rpm jump in revs when the code 31 was around at first start up and now i realize that the EGR solenoid was doing that problem and also causing a lean condition from what i read and experienced. One last thing tho. my car tends to run a bit warmer? im not sure why? bad thermostat i was thinking? or can the EGR system cause that? i just dont know. what i do know is that its running like a dream.
__________________
93 5 speed 306/GT40p Heads,GT40 Tubular Intake,Stock Cam/Electric fan/3g 130amp/MAC underdrives/Blue Thunder Short Throw/MAC offroad Xpipe/Flows super 44/Eibach prokit/MMS lower control arms & Bumpsteer kit/Retrofit Projectors 6000k HID/Saleen spoiler
Saleen302 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 11-08-2010   #11 (permalink)
spdjnky_42 is offline Top Dog

5.0L Member


Joined: Nov 2007
Posts: 13,639 Threads: 204
 spdjnky_42's Country Flag  View spdjnky_42's 21 photos
St.Louis   Missouri
spdjnky_42 is on a distinguished road
Send a message via Yahoo to spdjnky_42
Default

Factory gauge is useless. Only way to tell is to use a mechanical gauge or a laser temp reader to see if you are operating in the range of the t-stat being used.
__________________
When the green light drops...
The Bullsh!t stops. :shiny:
spdjnky_42 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 11-08-2010   #12 (permalink)
Saleen302 is offline Apprentice

5.0L Member


Joined: Oct 2010
Posts: 161 Threads: 18
 Saleen302's Country Flag  View Saleen302's 7 photos
Regina   Saskatchewan
Saleen302 is on a distinguished road
Default

ok thank you, ill do that. i actually want to go buy the aftermarket high flow thermostat(balance thermostat) 180 degree, im not sure whats in there right now. i calculated 180-192ish from the factory gauge. but i will do what you suggested.
__________________
93 5 speed 306/GT40p Heads,GT40 Tubular Intake,Stock Cam/Electric fan/3g 130amp/MAC underdrives/Blue Thunder Short Throw/MAC offroad Xpipe/Flows super 44/Eibach prokit/MMS lower control arms & Bumpsteer kit/Retrofit Projectors 6000k HID/Saleen spoiler
Saleen302 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 11-09-2010   #13 (permalink)
Saleen302 is offline Apprentice

5.0L Member


Joined: Oct 2010
Posts: 161 Threads: 18
 Saleen302's Country Flag  View Saleen302's 7 photos
Regina   Saskatchewan
Saleen302 is on a distinguished road
Default

ok, so i changed the EGR solenoid like i said earlier, but now my friggen check engine light will come on again and off and on yada yada. pulled code 31 again! my car runs really good, but what else can i do to fix this code 31? should i buy a new EGR Sensor? oh and there is 1v on the green wire at the EGR solenoid from a DVM test i did. Would bad TAD and TAB solenoids cause a code 31?
__________________
93 5 speed 306/GT40p Heads,GT40 Tubular Intake,Stock Cam/Electric fan/3g 130amp/MAC underdrives/Blue Thunder Short Throw/MAC offroad Xpipe/Flows super 44/Eibach prokit/MMS lower control arms & Bumpsteer kit/Retrofit Projectors 6000k HID/Saleen spoiler
Saleen302 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 11-10-2010   #14 (permalink)
My 5.0 91 LX is offline Made Member

5.0L Member


Joined: Jan 2009
Posts: 379 Threads: 26
 My 5.0 91 LX's Country Flag  View My 5.0 91 LX's 63 photos
Mcdonough   Georgia
My 5.0 91 LX is on a distinguished road
Default

just had the same codes ,buy a new egr solenoid that will clear the 31 code
__________________
91 LX 5.0 HO , BBK SSI intake,MSD Pro Billet dist.,BBK adj.fpr, 75mm tb.73mm mas,BBK cai, Trick Flow underdrive pullies, 19lb injectors, 2 1/2" exhaust, BBK headers, x pipe, & converters, magnaflow cat back, Aod with TCI streetfighter valve body
My 5.0 91 LX is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Sponsored Links
Advertisement
 
Reply   Post New Thread

Tags
koeo



Thread Tools



Mustang Photos
Mustang Links    Top Sites    RSS    Link To Us    Add to Favorites    Archive    Terms of Use    Site Rules    Privacy    Contact    Sponsors    Advertise   
AllFordMustangs is not affiliated with or endorsed by Ford Motor Company. ©Copyright 2002-2011 All Auto Enthusiasts Network

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162