When I push in on the clutch my car dies... - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 10 (permalink) Old 11-09-2004 Thread Starter
PONY Member
5.0L Member
 
sxrpGT's Avatar
 
Joined: Oct 2004
Location: vsu
Posts: 626
 
Send a message via AIM to sxrpGT
When I push in on the clutch my car dies...

This has happened several times in the last 6 months. It doesnt happen often but I dont think it should happen at all. Today I was coming back to my apartment after school and was getting in the left turn lane. I was going about 65 and I pressed in on the clutch and the rpm fell and then it died so I let out on the clutch and it started back up so I pressed the clutch again and it stayed running. I dont know what would cause this. Sometimes it will start to die when I press the clutch, you can see the rpm fall to about 500 and then it spikes back to 1500 and then down to 1000. It only happens if I am slowing down too, never when I am shifting gears. So im lost here.

Drew

If I take cars and hot girls with money and add them to my life, I have found the key to happiness!
sxrpGT is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 11-09-2004
Apprentice
5.0L Member
 
Thunder122's Avatar
 
Joined: Jan 2004
Posts: 193
 
Send a message via Yahoo to Thunder122
Sounds like the mass air flow sensor 2 me... I also have this problem on my 91 tracer..... and its just the mass air flow sensor... just havent gotten around 2 replacing it..

87 mustang gt 5.0 5 speed,Flowmaster,Bored .30 over ,BBK Shorty Headers,Steeda short thow,New engine fully rebuild pure carb..
Thunder122 is offline  
post #3 of 10 (permalink) Old 11-09-2004
Top Dog
5.0L Member
 
GhostDog 5.0's Avatar
 
Joined: Aug 2002
Location: Edinburg
Posts: 4,837
 
Send a message via AIM to GhostDog 5.0 Send a message via Yahoo to GhostDog 5.0
I'd clean the IAC valve and go from there. When you press the clutch in it just seems like the rpms fall off as fast as they can right?

89 GT Hatch: Custom M90 Supercharged w/ Ported Trickflow Trackheat Heads, Stage 1 cam, Streetheat lower / Sheet metal upper, Tweecer RT & PLX Wideband, 75mm TB, 1.6 Roller rockers, 3.73s, MSD 6a, Canton 7qt Pan+ Windage tray, 36LB Injectors, 200 amp Alternator, 75mm Pro-Mas MAF, 190lph fuel pump,Spec Stage 1 Clutch,SouthSide LCA's, Pro 5.0 Shifter, Steeda CC Plates / Springs, FMS Aluminum Driveshaft, New T5 w/ 2.95 first gear, Underdrive pullies, Zirgo 3300Cfm Elec. Fan, AFCO alum. radiator
GhostDog 5.0 is offline  
post #4 of 10 (permalink) Old 11-09-2004 Thread Starter
PONY Member
5.0L Member
 
sxrpGT's Avatar
 
Joined: Oct 2004
Location: vsu
Posts: 626
 
Send a message via AIM to sxrpGT
Yeah they fall as if i have turned the ignition off, they fall slowly at first ( first hundred rpm) then they just drop to 0

If I take cars and hot girls with money and add them to my life, I have found the key to happiness!
sxrpGT is offline  
post #5 of 10 (permalink) Old 11-09-2004
Apprentice
5.0L Member
 
88GT5.0's Avatar
 
Joined: Jul 2004
Posts: 116
 
Send a message via AIM to 88GT5.0
I have the same damn problem.

88 Gt hatch, 96 5.0 motor, GT40 Cast Heads, Explorer upper and lower intake manifold, Lunati 51014 Cam, 3.55 gears, B&M ripper, rebuilt world class t-5, RAM HD clutch, Crane Valve Springs and retainers, FMS 1.6 ratio roller rockers, Eibach lowering springs, BBK 70mm TB and EGR spacer, C&L 73mm maf, BBK long tube headers, BBK short O/R H-pipe.....more to come.
88GT5.0 is offline  
post #6 of 10 (permalink) Old 11-09-2004 Thread Starter
PONY Member
5.0L Member
 
sxrpGT's Avatar
 
Joined: Oct 2004
Location: vsu
Posts: 626
 
Send a message via AIM to sxrpGT
Its a great problem did it to me again tonight kind of bad when you are coming up to a red light and you lose power brakes. I think i needed a change of underwear after that.

Drew

If I take cars and hot girls with money and add them to my life, I have found the key to happiness!
sxrpGT is offline  
post #7 of 10 (permalink) Old 11-09-2004
Top Dog
5.0L Member
 
GhostDog 5.0's Avatar
 
Joined: Aug 2002
Location: Edinburg
Posts: 4,837
 
Send a message via AIM to GhostDog 5.0 Send a message via Yahoo to GhostDog 5.0
Have you checked for a vacuum leak with a gauge ?

89 GT Hatch: Custom M90 Supercharged w/ Ported Trickflow Trackheat Heads, Stage 1 cam, Streetheat lower / Sheet metal upper, Tweecer RT & PLX Wideband, 75mm TB, 1.6 Roller rockers, 3.73s, MSD 6a, Canton 7qt Pan+ Windage tray, 36LB Injectors, 200 amp Alternator, 75mm Pro-Mas MAF, 190lph fuel pump,Spec Stage 1 Clutch,SouthSide LCA's, Pro 5.0 Shifter, Steeda CC Plates / Springs, FMS Aluminum Driveshaft, New T5 w/ 2.95 first gear, Underdrive pullies, Zirgo 3300Cfm Elec. Fan, AFCO alum. radiator
GhostDog 5.0 is offline  
post #8 of 10 (permalink) Old 11-10-2004 Thread Starter
PONY Member
5.0L Member
 
sxrpGT's Avatar
 
Joined: Oct 2004
Location: vsu
Posts: 626
 
Send a message via AIM to sxrpGT
Yeah we did it after I changed my intake and it was holding steadt pressure, there was no signs of any leaks. All this started before I changed my intake amd for a while it never died and then started doing it again the last 2 months. Like I said it doesnt happen often, just at the wrong times, it is only when I am coming from a high speed stop, When I am on campus it never happens, slow speeds through there, get on a highway doing 60-65 and boom thats prime time for it to happen.

Drew

If I take cars and hot girls with money and add them to my life, I have found the key to happiness!
sxrpGT is offline  
post #9 of 10 (permalink) Old 11-10-2004
Top Dog
5.0L Member
 
GhostDog 5.0's Avatar
 
Joined: Aug 2002
Location: Edinburg
Posts: 4,837
 
Send a message via AIM to GhostDog 5.0 Send a message via Yahoo to GhostDog 5.0
I would really clean the crap out of the IAC valve, check the throttle position sensor to make sure it's still within spec and pull the codes. I had this problem a long time ago and I threw a bunch of parts at it and it took care of it.

I changed the positive and negative battery cables, fuel pressure regulator, map sensor (on my 88), throttle position sensor, plugs, and the idle air control valve. I didnt know what I know now so I probably replaced a part or two that I didn't need. How do you battery cables look ?

89 GT Hatch: Custom M90 Supercharged w/ Ported Trickflow Trackheat Heads, Stage 1 cam, Streetheat lower / Sheet metal upper, Tweecer RT & PLX Wideband, 75mm TB, 1.6 Roller rockers, 3.73s, MSD 6a, Canton 7qt Pan+ Windage tray, 36LB Injectors, 200 amp Alternator, 75mm Pro-Mas MAF, 190lph fuel pump,Spec Stage 1 Clutch,SouthSide LCA's, Pro 5.0 Shifter, Steeda CC Plates / Springs, FMS Aluminum Driveshaft, New T5 w/ 2.95 first gear, Underdrive pullies, Zirgo 3300Cfm Elec. Fan, AFCO alum. radiator
GhostDog 5.0 is offline  
post #10 of 10 (permalink) Old 11-10-2004 Thread Starter
PONY Member
5.0L Member
 
sxrpGT's Avatar
 
Joined: Oct 2004
Location: vsu
Posts: 626
 
Send a message via AIM to sxrpGT
They look ... dirty.... the terminals are clean and have a good connection. They wires just ave 15 years of dirt on them but I have rubbed them down and seen no wear down into the wire. I could replace them, probably wouldnt hurt but. I could try the IAC as well.
Drew

If I take cars and hot girls with money and add them to my life, I have found the key to happiness!
sxrpGT is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in









Random Question

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183