Go Back   Ford Mustang Forums > Mustang > 5.0 Mustang > 94-95 Tech

Welcome to our Mustang forums where Mustangers come together to hang out, discuss and enjoy their favorite Mustang hobby with fellow Mustang enthusiasts. We invite everyone to read, post, and enjoy our Mustang forum as well as the many other sections of our site.

You are currently viewing our forums as a guest. By joining our community you gain access to post topics, communicate with members, upload your photos and access many other special features. Registration is fast, simple and free so why wait, join our Mustang community today! If you have any problems with registration or your account login, please contact support.

1994-1995 5.0 Mustang SN95 Tech Forum

5.0L Talk | 5.0L Tech | 94-95 Tech | 1979-1993   1994   1995   Upload Pictures | Timeslips | Power Adders | Mustang Tech 


Closed Thread   Post New Thread
Unread 12-01-2008   #1 (permalink)
piaband is offline Apprentice

4.6L Member


Joined: May 2005
Posts: 143 Threads: 22
 piaband's Country Flag
East Coast   New Jersey
piaband is on a distinguished road
Default 1994 Mustang Cobra, O2 sensor problems

1994 Mustang Cobra
97,000 Miles
runs good



I replaced my O2 sensors over the weekend because I had really low fuel economy and I heard that this had helped a few others. Well, now my check engine light is coming on. It comes and goes about 2-5 min intervals. I am sure its the O2 sensors. Do I need to reset the computer? Do they need break-in time? My car seems to be running normal, but I havent had them in long enough to see if the fuel economy had changed?



Should I take them back to Autozone ASAP?



Just to clarify, the check engine light neevr came on before changing the O2 sensors.
piaband is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Sponsored Links
Advertisement
 
Unread 12-01-2008   #2 (permalink)
RCRacer94gt is offline PONY Member

5.0L Member


Joined: Oct 2007
Posts: 783 Threads: 86
 RCRacer94gt's Country Flag  View RCRacer94gt's 9 photos  View RCRacer94gt's HomePage
Omaha   Nebraska
RCRacer94gt is on a distinguished road
Default

Get back under the car and clean your connectors.

Same thing happened to me. no light before O2's and i hooked up the 30 acron computer scanner for 95 and older fords and it told my which one wasnt reading good.

I got under the car and cleaned the connector on the O2 and the connector that goes to the O2.

Only other thing is that you have the wrong O2's. just go online and check the number on the box with the one online and that should tell you if you got the right once.

ALSO,
Clean your MAF and change your fuel filter and once your low on gas get a complete fuel system cleaner from GUM and fill up with gas.
The only other thing would be use seafoam on your car an hour before your next oil change and make sure your Spark plugs are good and gapped properly. Make sure your distributer cap and rotor are still in good condition if not go to advance auto and get a MSD cap and rotor set. Make sure all plugs are good if not get 9mm ford racing wires and maybe a MSD blaster coil.
All this contributes to the proper burning in fuel and making sure your fuel to air ration is on point for better fuel combustion and fuel economy.
__________________
1994 GT AODE, Performance Automatics Street/Strip Valve Body , 3.55, BBK(H PIPE, Equal Length Shorty Headers, UnderDrive Pulleys -minus Alternator Pulley, Spring Insulator & CAI), FlowMaster Super 44's Dumped, MSD(Distributor, TFI Blaster Coil & 8.5 Super Conductors), Ford Racing B Springs, KYB AJX Adjustable Shocks, AJE(Tubular K-member, A-Arms & 5.0 Solid Motor Mounts), Stiffler Transmission Crossmember, SVE Rear Upper & Lower Control Arms, Explorer Intake, A/C Delete, Smog Delete
RCRacer94gt is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Unread 12-01-2008   #3 (permalink)
piaband is offline Apprentice

4.6L Member


Joined: May 2005
Posts: 143 Threads: 22
 piaband's Country Flag
East Coast   New Jersey
piaband is on a distinguished road
Default

Thats funny, because I;ve done literally every single thing you've listed in your "ALSO" section. Even down to the seafoam. And I did clean the connectors with electronics cleaner. I may just take them back. They better give me my money back even though they were installed.
piaband is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Unread 12-01-2008   #4 (permalink)
RCRacer94gt is offline PONY Member

5.0L Member


Joined: Oct 2007
Posts: 783 Threads: 86
 RCRacer94gt's Country Flag  View RCRacer94gt's 9 photos  View RCRacer94gt's HomePage
Omaha   Nebraska
RCRacer94gt is on a distinguished road
Default

I'm a Advance Auto Parts guy cause i get everything discounted but i would think that you would get your money back.

The only other thing i did was hold onto the tab and try to stick the connectors together and disconnect it over and over again and shove the connectors hard into each other till they clicked or i just couldn't push them back together.
__________________
1994 GT AODE, Performance Automatics Street/Strip Valve Body , 3.55, BBK(H PIPE, Equal Length Shorty Headers, UnderDrive Pulleys -minus Alternator Pulley, Spring Insulator & CAI), FlowMaster Super 44's Dumped, MSD(Distributor, TFI Blaster Coil & 8.5 Super Conductors), Ford Racing B Springs, KYB AJX Adjustable Shocks, AJE(Tubular K-member, A-Arms & 5.0 Solid Motor Mounts), Stiffler Transmission Crossmember, SVE Rear Upper & Lower Control Arms, Explorer Intake, A/C Delete, Smog Delete
RCRacer94gt is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Unread 12-02-2008   #5 (permalink)
piaband is offline Apprentice

4.6L Member


Joined: May 2005
Posts: 143 Threads: 22
 piaband's Country Flag
East Coast   New Jersey
piaband is on a distinguished road
Default

You know what, I have had a lot of problems with Autozone giving me regular Mustang parts instead of Cobra parts , but I asked the people on here and was told there is no difference so I figured Autozone couldnt screw this one up. I think I am done going there.


On the other hand, Advance Auto has always got it correct.
piaband is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Sponsored Links
Advertisement
 
Closed Thread   Post New Thread



Thread Tools



Mustang Photos
Mustang Links    Top Sites    RSS    Link To Us    Add to Favorites    Archive    Terms of Use    Site Rules    Privacy    Contact    Sponsors    Advertise   
AllFordMustangs is not affiliated with or endorsed by Ford Motor Company. ©Copyright 2002-2011 All Auto Enthusiasts Network

Search Engine Friendly URLs by vBSEO 3.5.2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172