Go Back   Ford Mustang Forums > Mustang > 5.0 Mustang > 94-95 Tech

Welcome to our Mustang forums where Mustangers come together to hang out, discuss and enjoy their favorite Mustang hobby with fellow Mustang enthusiasts. We invite everyone to read, post, and enjoy our Mustang forum as well as the many other sections of our site.

You are currently viewing our forums as a guest. By joining our community you gain access to post topics, communicate with members, upload your photos and access many other special features. Registration is fast, simple and free so why wait, join our Mustang community today! If you have any problems with registration or your account login, please contact support.

1994-1995 5.0 Mustang SN95 Tech Forum

5.0L Talk | 5.0L Tech | 94-95 Tech | 1979-1993   1994   1995   Upload Pictures | Timeslips | Power Adders | Mustang Tech 


Reply   Post New Thread
Unread 02-14-2011   #1 (permalink)
davidsyclone2 is offline Rookie

5.0L Member


Joined: Feb 2011
Posts: 34 Threads: 13
 davidsyclone2's Country Flag
Vancouver   Washington
davidsyclone2 is on a distinguished road
Default 1995 Mustang GT 5.0 - Hesitation in the 30-40 mph Range.

ok i recently bought a stock 95 5.0 w/134xxx had a diagnostic done came back with a weak distributor,egr valve,position sensor,tps,i had them do the distributor i did the rest,still have the same problem.i cleaned the maf and it looks OK(wires in tack)same thing.it also for a 5.0 lacks a lot of power and pings.i also replaced the ignition coil same thing.when its cold no stumble.any and all help ill take,thanks.



this is my first ford,and i have a problem when driving around 30 to 45 mph my 5.0 hesitates give it a little throttle its OK.iv replaced the tps,egr valve,position sensor,all plugs,wires cap rotor and a new distributor,fuel filter,still the same s#!t.could it be the egr vacuum solenoid if so how do i get to it.

Last edited by Snackmaster; 02-16-2011 at 03:14 PM. Reason: merged thread info
davidsyclone2 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Sponsored Links
Advertisement
 
Unread 02-14-2011   #2 (permalink)
DROCK9 is offline Apprentice


Joined: May 2009
Posts: 81 Threads: 26
 DROCK9's Country Flag
SFV   California
DROCK9 is on a distinguished road
Default

did you replace the iac?
__________________
95 gt 5.0....... eddlebrock upper and lower intake, eddlebrock throttle body and elbow, bbk headers, bbk h-pipe, flowmasters, cam....
DROCK9 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 02-14-2011   #3 (permalink)
davidsyclone2 is offline Rookie

5.0L Member


Joined: Feb 2011
Posts: 34 Threads: 13
 davidsyclone2's Country Flag
Vancouver   Washington
davidsyclone2 is on a distinguished road
Default

yes,im running out options and $$$
davidsyclone2 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 02-14-2011   #4 (permalink)
alleymad95GT is offline MACH I Member

5.0L Member
S197 Member


Joined: Mar 2010
Posts: 3,095 Threads: 10
 alleymad95GT's Country Flag  View alleymad95GT's 10 photos  View alleymad95GT's HomePage
Okemos   Michigan
alleymad95GT is on a distinguished road
Default

Quit throwing parts at it.

Looks like you got the tune-up parts taken care of. Have you tried cleaning the MAF?

Have you pulled the codes?

DIY KOEO/KOER/Cylinder Balance Self-Test Procedure

Amazon.com: Equus 3145 Ford Digital Code Reader: Automotive

Pull the codes and let us know what you find...
__________________
Matt

2006 GT - Vortech polished w/ intercooler, Eibach suspension, Hurst short-throw, some other goodies - tuned by Paul's High Performance. It moves...

and it collects dust admirably while parked for repairs in the garage...

SOLD - 1995 Black Mustang GT, AODE. Loved it, but I had to let it go...

mjmalegalsolutions.com
alleymad95GT is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 02-14-2011   #5 (permalink)
davidsyclone2 is offline Rookie

5.0L Member


Joined: Feb 2011
Posts: 34 Threads: 13
 davidsyclone2's Country Flag
Vancouver   Washington
davidsyclone2 is on a distinguished road
Default

yes i cleaned the maf,i was reading an article and it sounds like egr vacuum solenoid.the things i replaced was after a diagnostic test,but didnt take care of the problem.no check engine light comes on:?:

ill pull some codes and get back to ya,thanks man

Last edited by Snackmaster; 02-16-2011 at 03:07 PM. Reason: merged back to back posts
davidsyclone2 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 02-14-2011   #6 (permalink)
alleymad95GT is offline MACH I Member

5.0L Member
S197 Member


Joined: Mar 2010
Posts: 3,095 Threads: 10
 alleymad95GT's Country Flag  View alleymad95GT's 10 photos  View alleymad95GT's HomePage
Okemos   Michigan
alleymad95GT is on a distinguished road
Default

To be honest, the speed at which this is occurring makes me doubt you will get a code, but i have been wrong before...

Anyhow, pull the codes and we will go from there. I don't want to just start guessing and costing you money...
__________________
Matt

2006 GT - Vortech polished w/ intercooler, Eibach suspension, Hurst short-throw, some other goodies - tuned by Paul's High Performance. It moves...

and it collects dust admirably while parked for repairs in the garage...

SOLD - 1995 Black Mustang GT, AODE. Loved it, but I had to let it go...

mjmalegalsolutions.com
alleymad95GT is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 02-14-2011   #7 (permalink)
cam94fire89 is offline Apprentice

5.0L Member


Joined: Feb 2010
Posts: 76 Threads: 21
 cam94fire89's Country Flag  View cam94fire89's 2 photos
Granbury   Texas
cam94fire89 is on a distinguished road
Default

Try unplugging the maf and see if ur car stays running or not mine was running kinda like that and with the help of afm it got solved. I'm actually running my car right now with my maf unplugged I have a 95 with just gears and exhaust. So try that and see.
cam94fire89 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 02-15-2011   #8 (permalink)
davidsyclone2 is offline Rookie

5.0L Member


Joined: Feb 2011
Posts: 34 Threads: 13
 davidsyclone2's Country Flag
Vancouver   Washington
davidsyclone2 is on a distinguished road
Angry

:?::?:i just got back from my auto parts store and my gt didn't pull any codes.any ideas

the maf is clean and good working order

Last edited by Snackmaster; 02-16-2011 at 03:08 PM. Reason: merged back to back posts
davidsyclone2 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 02-15-2011   #9 (permalink)
alleymad95GT is offline MACH I Member

5.0L Member
S197 Member


Joined: Mar 2010
Posts: 3,095 Threads: 10
 alleymad95GT's Country Flag  View alleymad95GT's 10 photos  View alleymad95GT's HomePage
Okemos   Michigan
alleymad95GT is on a distinguished road
Default

Quote:
Originally Posted by davidsyclone2 View Post
:?::?:i just got back from my auto parts store and my gt didn't pull any codes.any ideas
Yeah. The auto parts store tried to use the OBD-II port under the dash and of course it didn't show any codes since the car is OBD-I and that port under the dash is not hooked up to anything???

Which port did they use? Under the dash or behind the passenger side strut tower?
__________________
Matt

2006 GT - Vortech polished w/ intercooler, Eibach suspension, Hurst short-throw, some other goodies - tuned by Paul's High Performance. It moves...

and it collects dust admirably while parked for repairs in the garage...

SOLD - 1995 Black Mustang GT, AODE. Loved it, but I had to let it go...

mjmalegalsolutions.com
alleymad95GT is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 02-15-2011   #10 (permalink)
davidsyclone2 is offline Rookie

5.0L Member


Joined: Feb 2011
Posts: 34 Threads: 13
 davidsyclone2's Country Flag
Vancouver   Washington
davidsyclone2 is on a distinguished road
Default

we checked but under the hood gave one the all good code i didn't write it down because it was all clear code

im sorry i did not replace the iac.

Last edited by Snackmaster; 02-16-2011 at 03:09 PM. Reason: merged back to back posts
davidsyclone2 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 02-16-2011   #11 (permalink)
alleymad95GT is offline MACH I Member

5.0L Member
S197 Member


Joined: Mar 2010
Posts: 3,095 Threads: 10
 alleymad95GT's Country Flag  View alleymad95GT's 10 photos  View alleymad95GT's HomePage
Okemos   Michigan
alleymad95GT is on a distinguished road
Default

OK - now, I am going to probe for a little bit more information on the symptoms you are experiencing...

You said it "hesitates" when you are driving between 30 and 45 mph...

But then you say when you give it throttle it is ok...

Normally, I characterize "hesitation" as the car not being ok when you give it throttle...so I am a bit confused to be honest...

Is it a miss? Or does it suddenly feel like it just has no power? Does the power kind of "surge" when it corrects itself?

What do the RPMs do? Do they go up but the car doesn't move forward any differently? Do they drop and then shoot up? Do they stay the same for a second and then jump up?
__________________
Matt

2006 GT - Vortech polished w/ intercooler, Eibach suspension, Hurst short-throw, some other goodies - tuned by Paul's High Performance. It moves...

and it collects dust admirably while parked for repairs in the garage...

SOLD - 1995 Black Mustang GT, AODE. Loved it, but I had to let it go...

mjmalegalsolutions.com
alleymad95GT is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 02-16-2011   #12 (permalink)
davidsyclone2 is offline Rookie

5.0L Member


Joined: Feb 2011
Posts: 34 Threads: 13
 davidsyclone2's Country Flag
Vancouver   Washington
davidsyclone2 is on a distinguished road
Default

surge might be the right word.between 30 and 40 it surges or jerks give it a little throttle or a little less its ok.and it just doesnt have the power that i know a 5.0 should have.you asked about my iac i didnt change that

rps don't jump all over,pretty stable

the rpm doesnt shoot all over the place

ok i just disconnected the power to the maf still runs,i did the same with the iac runs rough so i think both are good.i also disconnected the green vacuum tube to the egr @ operating temp no vacuum,so is this telling me its the egr vacuum solenoid?
i did get a check engine light for the maf&iac.thanks,dave

Last edited by Snackmaster; 02-16-2011 at 03:11 PM. Reason: merged back to back posts
davidsyclone2 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 02-16-2011   #13 (permalink)
johnGT is offline GT Member


Joined: May 2010
Posts: 1,843 Threads: 103
 johnGT's Country Flag  View johnGT's 1 photo
Dawsonville   Georgia
johnGT is on a distinguished road
Default

Is the car an automatic? It sounds to me that its just your overdrive gear slipping...
Depending on your gears, thats about the speed it will shift into the OD gear. I have 2.73s and mine switches to OD at around 40-45mph under normal driving conditions.
__________________
1995 mustang gt vert - 1 of 36 5.0, AODE, 2.73 gears, Pacesetter O/R x-pipe, Flowtech Terminator mufflers. Appx. 410,000~ miles. (honestly not sure..)
johnGT is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 02-16-2011   #14 (permalink)
davidsyclone2 is offline Rookie

5.0L Member


Joined: Feb 2011
Posts: 34 Threads: 13
 davidsyclone2's Country Flag
Vancouver   Washington
davidsyclone2 is on a distinguished road
Default

yep its an auto,but that wouldnt count for lack of power would it?

Last edited by davidsyclone2; 02-16-2011 at 05:56 PM. Reason: forgot
davidsyclone2 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 02-16-2011   #15 (permalink)
davidsyclone2 is offline Rookie

5.0L Member


Joined: Feb 2011
Posts: 34 Threads: 13
 davidsyclone2's Country Flag
Vancouver   Washington
davidsyclone2 is on a distinguished road
Default

so i think i found the problem.i adjusted the iac took it for a spin no hesitation between 30-40 mph.but im not sure if the setting on the iac is correct,any suggestions? or is this a sign of the iac going bad

Last edited by davidsyclone2; 02-16-2011 at 09:52 PM. Reason: no reason
davidsyclone2 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Sponsored Links
Advertisement
 
Reply   Post New Thread



Thread Tools



Mustang Photos
Mustang Links    Top Sites    RSS    Link To Us    Add to Favorites    Archive    Terms of Use    Site Rules    Privacy    Contact    Sponsors    Advertise   
AllFordMustangs is not affiliated with or endorsed by Ford Motor Company. ©Copyright 2002-2011 All Auto Enthusiasts Network

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162