Go Back   Ford Mustang Forums > Mustang > 5.0 Mustang > 94-95 Tech

Welcome to our Mustang forums where Mustangers come together to hang out, discuss and enjoy their favorite Mustang hobby with fellow Mustang enthusiasts. We invite everyone to read, post, and enjoy our Mustang forum as well as the many other sections of our site.

You are currently viewing our forums as a guest. By joining our community you gain access to post topics, communicate with members, upload your photos and access many other special features. Registration is fast, simple and free so why wait, join our Mustang community today! If you have any problems with registration or your account login, please contact support.

1994-1995 5.0 Mustang SN95 Tech Forum

5.0L Talk | 5.0L Tech | 94-95 Tech | 1979-1993   1994   1995   Upload Pictures | Timeslips | Power Adders | Mustang Tech 


Reply   Post New Thread
Unread 04-29-2012   #1 (permalink)
dunny077 is offline Apprentice

5.0L Member


Joined: Feb 2009
Posts: 66 Threads: 15
 dunny077's Country Flag
Mansfield   Massachusetts
dunny077 is on a distinguished road
Default 1995 Mustang GT Check Engine Light?

So I've been looking around the forums and noticed that a chip will usually throw the code 511, which is what I am getting back when I do a scan. However, people are saying that they get this code but it isn't tripping their CEL, and my CEL comes on. It comes on when I'm driving and will turn off here and there (I've noticed it often turns off when I come to a complete stop). There were no other codes that came up, but I feel like I should also mention that AutoZone and Advance Auto were unable to even pull codes because there was some sort of error. Anyone know what my problem might be? Thanks for the help!
__________________
-Dunny
1995 GT - B&M Short Throw, CAI, Pypes O/R X Pipe, Magnaflow 6in SS Mufflers, SCT Eliminator Chip, 3.73 gears, Ford Racing Aluminum Driveshaft, 20%front/5%rear window tint, 6000K HIDs
dunny077 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Sponsored Links
Advertisement
 
Unread 04-29-2012   #2 (permalink)
YLDPONY is offline SHELBY GT 350 Member

5.0L Member


Joined: Nov 2009
Posts: 8,798 Threads: 46
 YLDPONY's Country Flag  View YLDPONY's 29 photos
Thornville   Michigan
YLDPONY is on a distinguished road
Default

Quote:
Originally Posted by dunny077 View Post
but I feel like I should also mention that AutoZone and Advance Auto were unable to even pull codes because there was some sort of error.
Common knowledge. I assume they were plugging into the diagnostic port under the steering column?
__________________
'94 Laser red 'vert. Still a 5-oh... for now
YLDPONY is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 05-05-2012   #3 (permalink)
dunny077 is offline Apprentice

5.0L Member


Joined: Feb 2009
Posts: 66 Threads: 15
 dunny077's Country Flag
Mansfield   Massachusetts
dunny077 is on a distinguished road
Default

Yes they were plugging into the diagnostic port and got nothing from it besides the error messages. It took AAMCO a couple tries to get the code finally. I heard people get this code but it doesn't trip the CEL, how come mine keeps coming on and off? Any help would greatly be appreciated!
__________________
-Dunny
1995 GT - B&M Short Throw, CAI, Pypes O/R X Pipe, Magnaflow 6in SS Mufflers, SCT Eliminator Chip, 3.73 gears, Ford Racing Aluminum Driveshaft, 20%front/5%rear window tint, 6000K HIDs
dunny077 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 05-05-2012   #4 (permalink)
toyman is offline GT Member


Joined: Sep 2007
Posts: 2,297 Threads: 0
 toyman's Country Flag
Vernon   British Columbia
toyman is on a distinguished road
Default

Quote:
Originally Posted by dunny077 View Post
Yes they were plugging into the diagnostic port and got nothing from it besides the error messages. It took AAMCO a couple tries to get the code finally. I heard people get this code but it doesn't trip the CEL, how come mine keeps coming on and off? Any help would greatly be appreciated!
Something is not clear. The only DTC port that works on the 5.0 GT is the one in the engine bay passenger side between the strut tower and the firewall. The under the dash port is for the same years V-6 which has an OBDII compliant computer. The wiring harness is common to both cars. For a CEL to turn on and off means that whatever sensor is tripping the CEL is sending a signal voltage that is moving in and out of the expected parameter. Somehow, I don't get the feeling that you are accessing the DTC port in the engine bay.

FWIW most CEL's are triggered by sensors that have an affect on emissions so as to alert the driver to get the problem fixed. There are many trouble codes logged by the ECU that never activate the CEL. An OBDI code reader is a must have tool for diagnosing all computer related issues on these cars. They can be bought from Summit for about $22.
__________________
Richard
KB 2.1L, FRPP M5400-A Suspension System, FRPP Aluminum D/S, Shift Kit, Built TC, FRPP 3.73 Gears, Balanced Roller Cammed Engine, Edelbrock Performer Heads, Comp 270AH cam, AEM EMS, 3.5 Bar MAP, Zeitronix ZT-2 WB, FRPP 70mm TB, hardened AODE, modified UPR CAI, Be Cool Aluminum Rad
toyman is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 05-06-2012   #5 (permalink)
dunny077 is offline Apprentice

5.0L Member


Joined: Feb 2009
Posts: 66 Threads: 15
 dunny077's Country Flag
Mansfield   Massachusetts
dunny077 is on a distinguished road
Default

Then what's the port underneath the steering column? I've never heard of using the diagnostic tool anywhere under the hood.
__________________
-Dunny
1995 GT - B&M Short Throw, CAI, Pypes O/R X Pipe, Magnaflow 6in SS Mufflers, SCT Eliminator Chip, 3.73 gears, Ford Racing Aluminum Driveshaft, 20%front/5%rear window tint, 6000K HIDs
dunny077 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 05-06-2012   #6 (permalink)
alleymad95GT is offline MACH I Member

5.0L Member
S197 Member


Joined: Mar 2010
Posts: 3,103 Threads: 10
 alleymad95GT's Country Flag  View alleymad95GT's 10 photos  View alleymad95GT's HomePage
Okemos   Michigan
alleymad95GT is on a distinguished road
Default

Quote:
Originally Posted by dunny077 View Post
Then what's the port underneath the steering column? I've never heard of using the diagnostic tool anywhere under the hood.
In a word, that port is USELESS.

The '94-'95 cars were a between computer model if you will. The V6 cars switched to OBD-II compliant computer control. But, Ford retained the 5.0 and also retained the OBD-I compliant EEC-IV engine management system. So, the same make and model of car can be either OBD-I or OBD-II, depending solely on whether it is a V6 or a V8.

Now, Ford didn't want to spend the money manufacturing and assembling two completely different engine wiring harnesses, so the harnesses are wired for EITHER OBD-I or OBD-II systems. Thus, your OBD-I controlled car has a diagnostic port under the dash that is not hooked to anything. It just hangs there. If the car was a V6, it would be functional.

The correct port to use to pull codes from your OBD-I computer is under the hood in the engine compartment, on the passenger side, between the firewall and the passenger-side strut tower.

You will be pulling 3-digit OBD-I codes.
__________________
Matt

2006 GT - Vortech polished w/ intercooler, Eibach suspension, Hurst short-throw, some other goodies - tuned by Paul's High Performance. It moves...

and it collects dust admirably while parked for repairs in the garage...

SOLD - 1995 Black Mustang GT, AODE. Loved it, but I had to let it go...

mjmalegalsolutions.com
alleymad95GT is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Sponsored Links
Advertisement
 
Reply   Post New Thread



Thread Tools



Mustang Photos
Mustang Links    Top Sites    RSS    Link To Us    Add to Favorites    Archive    Terms of Use    Site Rules    Privacy    Contact    Sponsors    Advertise   
AllFordMustangs is not affiliated with or endorsed by Ford Motor Company. ©Copyright 2002-2011 All Auto Enthusiasts Network

Search Engine Friendly URLs by vBSEO 3.5.2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171