issues installing hei distributor on a 1971 mustang - Ford Mustang Forum
LinkBack Thread Tools
post #1 of 1 (permalink) Old 07-05-2010 Thread Starter
blah123's Avatar
Joined: Jul 2010
Location: puyallup
Posts: 1
issues installing hei distributor on a 1971 mustang

HELP!!!! does anyone know how to install a hei distributor on a 1971 mustang with a 302... having issues!!!
blah123 is offline  
Sponsored Links
Closed Thread

Quick Reply

Register Now

In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

For the best viewing experience please update your browser to Google Chrome