Go Back   Ford Mustang Forums > Mustang > Classic Mustang > Classic Tech

Welcome to our Mustang forums where Mustangers come together to hang out, discuss and enjoy their favorite Mustang hobby with fellow Mustang enthusiasts. We invite everyone to read, post, and enjoy our Mustang forum as well as the many other sections of our site.

You are currently viewing our forums as a guest. By joining our community you gain access to post topics, communicate with members, upload your photos and access many other special features. Registration is fast, simple and free so why wait, join our Mustang community today! If you have any problems with registration or your account login, please contact support.

Classic Mustangs Tech Forum

Technical discussions specific to 1964-1967, 1968-1970, and 1971-1973 Classic Mustang. Discuss all tech related to in-line six cylinder and V8 powered Vintage Mustangs here.

Classic Forums | Classic Talk | Classic Tech | Classic Pictures | Introductions | Mustang Tech | Mustang Lounge 


Closed Thread   Post New Thread
Unread 08-29-2008   #1 (permalink)
guitfiddler2089 is offline Rookie


Joined: Jan 2008
Posts: 32 Threads: 11
 guitfiddler2089's Country Flag  View guitfiddler2089's 3 photos
springfield   Missouri
guitfiddler2089 is on a distinguished road
Default Re-installing the chrome windshield moulding on 1967 mustang Help!!!

I removed the chrome molding around the windshield on my 1967 mustang, but now I don't know how to get it back on. i know it was held on by metal clips, but how do you get them back on? Any input would be very appreciated. Thanks.
guitfiddler2089 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Sponsored Links
Advertisement
 
Unread 08-29-2008   #2 (permalink)
Musty67 is offline Rookie

Classic Member


Joined: Feb 2008
Posts: 27 Threads: 11
 Musty67's Country Flag  View Musty67's 5 photos
Montreal   Quebec
Musty67 is on a distinguished road
Default

Quote:
Originally Posted by guitfiddler2089 View Post
I removed the chrome molding around the windshield on my 1967 mustang, but now I don't know how to get it back on. i know it was held on by metal clips, but how do you get them back on? Any input would be very appreciated. Thanks.
I've changed my windshield recently and naturaly I had to remove the moldings. First start by putting in new clips, it will help alot. Next start with the side moldinds by clipping the windshield side first and work the moldings around the windshield pillars and screw them in place. The lower molding should just clip in place with no problems. Good luck
Musty67 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Sponsored Links
Advertisement
 
Closed Thread   Post New Thread



Thread Tools



Mustang Photos
Mustang Links    Top Sites    RSS    Link To Us    Add to Favorites    Archive    Terms of Use    Site Rules    Privacy    Contact    Sponsors    Advertise   
AllFordMustangs is not affiliated with or endorsed by Ford Motor Company. ©Copyright 2002-2011 All Auto Enthusiasts Network

Search Engine Friendly URLs by vBSEO 3.5.2

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172