Go Back   Ford Mustang Forums > Mustang > Classic Mustang > Classic Tech

Welcome to our Mustang forums where Mustangers come together to hang out, discuss and enjoy their favorite Mustang hobby with fellow Mustang enthusiasts. We invite everyone to read, post, and enjoy our Mustang forum as well as the many other sections of our site.

You are currently viewing our forums as a guest. By joining our community you gain access to post topics, communicate with members, upload your photos and access many other special features. Registration is fast, simple and free so why wait, join our Mustang community today! If you have any problems with registration or your account login, please contact support.

Classic Mustangs Tech Forum

Technical discussions specific to 1964-1967, 1968-1970, and 1971-1973 Classic Mustang. Discuss all tech related to in-line six cylinder and V8 powered Vintage Mustangs here.

Classic Forums | Classic Talk | Classic Tech | Classic Pictures | Introductions | Mustang Tech | Mustang Lounge 


Reply   Post New Thread
Unread 10-07-2012   #1 (permalink)
klassen1 is offline Rookie


Joined: Oct 2012
Posts: 6 Threads: 3
 klassen1's Country Flag
surrey   British Columbia
klassen1 is on a distinguished road
Exclamation 2002 ford crown victoria 4.6l v8 engine stumbles when under load

i have a 2002 crown victoria police intercepter with a 4.6L V8 and it has been stumbling under load. when it idles it is fine does not misfire or shake but when i try to drive i lose power, it stumbles and shakes very bad i have checked almost everything.

ive checked plugs, coils, fuel filter, fuel injectors, drivers side catalytic converter and o2 sensors, air filter, intakes,

the check engine light is not coming on and when it does and i hook reader up to car it powers up but will not take the codes from car
klassen1 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Sponsored Links
Advertisement
 
Unread 10-08-2012   #2 (permalink)
gearheadhick429 is offline PONY Member


Joined: Jun 2012
Posts: 693 Threads: 48
 gearheadhick429's Country Flag  View gearheadhick429's 5 photos
ankeny   Iowa
gearheadhick429 is on a distinguished road
Default

there is a fairchance that you have a vacuum leak or something of the sort. could be alot of things including compression. these two would not throw codes. could even be as simple as a weak battery. this is classic section so redirect yourself to the more current era forums they will know better. when it comes to fuel injection it could be anything. if its high miles id check out all your throttle related sensors iac maf tps and so on. these can cause havok. carb ftw. good luck hope you get it figured out. milage on engine would be a helpful point also.
gearheadhick429 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Sponsored Links
Advertisement
 
Reply   Post New Thread

Tags
2002, 4.6 crown vic, ford, stumbles, v8 engine



Thread Tools



Mustang Photos
Mustang Links    Top Sites    RSS    Link To Us    Add to Favorites    Archive    Terms of Use    Site Rules    Privacy    Contact    Sponsors    Advertise   
AllFordMustangs is not affiliated with or endorsed by Ford Motor Company. ©Copyright 2002-2011 All Auto Enthusiasts Network

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162