Go Back   Ford Mustang Forums > Vendors > LatemodelRestoration.com

Welcome to our Mustang forums where Mustangers come together to hang out, discuss and enjoy their favorite Mustang hobby with fellow Mustang enthusiasts. We invite everyone to read, post, and enjoy our Mustang forum as well as the many other sections of our site.

You are currently viewing our forums as a guest. By joining our community you gain access to post topics, communicate with members, upload your photos and access many other special features. Registration is fast, simple and free so why wait, join our Mustang community today! If you have any problems with registration or your account login, please contact support.

 

LatemodelRestoration.com Forum

The ultimate latemodel Ford Mustang parts source with everything you need to modify and restore your late model Mustang.

LatemodelRestoration.com
Contact LatemodelRestoration.com | Visit LatemodelRestoration.com
 

Reply   Post New Thread
Unread 06-19-2012   #1 (permalink)
refurbed 88 5.0 is offline Rookie


Joined: May 2012
Posts: 15 Threads: 7
 refurbed 88 5.0's Country Flag
lake in the hills   Illinois
refurbed 88 5.0 is on a distinguished road
Default 93 gt rough idle

got a 93 gt with rough idle. and it fall on its face in gear but not neutral .have changed plugs wires ,msd cap and rotor, and fuel filter. any ideas would be great cause this is gettin agravating. THNX
refurbed 88 5.0 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Sponsored Links
Advertisement
 
Unread 06-19-2012   #2 (permalink)
Jarrod@Latemodel is offline Site Sponsor

S197 Member


Joined: Nov 2007
Posts: 677 Threads: 241
 Jarrod@Latemodel's Country Flag  View Jarrod@Latemodel's 12 photos  View Jarrod@Latemodel's HomePage
Waco   Texas
Jarrod@Latemodel is on a distinguished road
Default

Check all hoses for a vacuum leak.
__________________
Jarrod.Shelburne@latemodelrestoration.com
254.296.6531
LatemodelRestoration.com

Jarrod@Latemodel is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 06-19-2012   #3 (permalink)
refurbed 88 5.0 is offline Rookie


Joined: May 2012
Posts: 15 Threads: 7
 refurbed 88 5.0's Country Flag
lake in the hills   Illinois
refurbed 88 5.0 is on a distinguished road
Default

Repaired all va leaks but I'll check again. Any other suggestions would be great.
refurbed 88 5.0 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 06-19-2012   #4 (permalink)
Jarrod@Latemodel is offline Site Sponsor

S197 Member


Joined: Nov 2007
Posts: 677 Threads: 241
 Jarrod@Latemodel's Country Flag  View Jarrod@Latemodel's 12 photos  View Jarrod@Latemodel's HomePage
Waco   Texas
Jarrod@Latemodel is on a distinguished road
Default

Idle air control valve maybe? Did you start changing parts because you were doing a tune up, or did it just start running bad one day?
__________________
Jarrod.Shelburne@latemodelrestoration.com
254.296.6531
LatemodelRestoration.com

Jarrod@Latemodel is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 06-19-2012   #5 (permalink)
refurbed 88 5.0 is offline Rookie


Joined: May 2012
Posts: 15 Threads: 7
 refurbed 88 5.0's Country Flag
lake in the hills   Illinois
refurbed 88 5.0 is on a distinguished road
Default

Both, took top half of engine down and replaced gaskets, then it idled rough , also needed tune up. And it makes a pop noise when u start it up like timing is off , but it's not.
refurbed 88 5.0 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Unread 06-19-2012   #6 (permalink)
Jarrod@Latemodel is offline Site Sponsor

S197 Member


Joined: Nov 2007
Posts: 677 Threads: 241
 Jarrod@Latemodel's Country Flag  View Jarrod@Latemodel's 12 photos  View Jarrod@Latemodel's HomePage
Waco   Texas
Jarrod@Latemodel is on a distinguished road
Default

Did you change the IAC? It might need to be changed out. I don't know that it will fix your problem, but it could. It sounds like everything else was changed. You might want to make sure it is timed correctly. Something is off for sure if its popping.
__________________
Jarrod.Shelburne@latemodelrestoration.com
254.296.6531
LatemodelRestoration.com

Jarrod@Latemodel is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Sponsored Links
Advertisement
 
Reply   Post New Thread



Thread Tools



Mustang Photos
Mustang Links    Top Sites    RSS    Link To Us    Add to Favorites    Archive    Terms of Use    Site Rules    Privacy    Contact    Sponsors    Advertise   
AllFordMustangs is not affiliated with or endorsed by Ford Motor Company. ©Copyright 2002-2011 All Auto Enthusiasts Network

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162