1998 Mustang Cobra fuel pump problems - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 06-04-2008 Thread Starter
Rookie
 
cobra kidd's Avatar
 
Joined: Jun 2008
Location: Portland
Posts: 4
 
1998 Mustang Cobra fuel pump problems

My 1998 cobra has been down for about 8 months.I finaly completed my mods, and tried to start the car and I have no fuel pressure. the pump is not kicking on. I didnt touch the fuel system at all. I put a tubular k-member on with coil over kit and some other suspension mods. Ive checked all of the fuses and relays. anybody have any Ideas? thanks.

Last edited by cobra kidd; 06-04-2008 at 10:43 PM. Reason: I placed it in the wrong area.
cobra kidd is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 06-04-2008
GLOBAL MODERATOR
Mustang II Member
Classic Member
V6 Member
4.6L Member
5.0L Member
 
heavy metal's Avatar
 
Joined: Oct 2007
Location: Bradyville
Posts: 29,006
                 
Garage
Send a message via Yahoo to heavy metal
Welcome to the site....have you checked the inertia switch?


Cherish those around you,for at the blink
of an eye,they can be gone.

AFM GLOBAL MODERATOR
heavy metal is online now  
post #3 of 4 (permalink) Old 06-04-2008
MODERATOR
Classic Member
S197 Member
 
stlwagon's Avatar
 
Joined: Oct 2005
Location: Southern
Posts: 74,631
                 
Send a message via Yahoo to stlwagon
Welcome... Let's look for more answers in here.

1965 Mustang Coupe
stlwagon is offline  
post #4 of 4 (permalink) Old 06-05-2008 Thread Starter
Rookie
 
cobra kidd's Avatar
 
Joined: Jun 2008
Location: Portland
Posts: 4
 
yes, I did check the inertia switch, crank shaft positioning sensor. I have the ford shop manual for the car, and I will check that out more tomarro. Ive heard of alot of cobra owners that have had this problem, I just cant seem to remember what the solution is.Thanks for the feedback.
cobra kidd is offline  
Sponsored Links
Advertisement
 
Closed Thread

Tags
cobra , fuel pump

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182