1999 Mustang Cobra, Is It The Fuel Pump? - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 09-11-2006 Thread Starter
Apprentice
4.6L Member
 
warcat's Avatar
 
Joined: Oct 2005
Location: Corpus Christi
Posts: 83
 
1999 Mustang Cobra, Is It The Fuel Pump?

I've got a problem with my 1999 Cobra, and I need some help diagnosing the problem. For quite a while (about 6 months), it had trouble starting up on the first try. It usually took 2 to 3 tries before it fired up- I didn't think too much of it and figured I'd get it taken care of soon enough. Well, time flew by, and I didn't get to it. Now, it will not start. IT cranks up like normal, but won't fire. I checked the inertia switch, and it was not tripped. I also check for fuel pressure on the fuel rail, and there was no pressure.

At this point, I'm thinking it must be the fuel pump or the fuel pump relay. Can anyone give me some tips on what to do?

1999 Cobra SVT
4.10 gears, K & N Cold Air Intake, Ford Motorsports Pulleys, Steeda springs,
X-pipe exhaust w/ Magnaflows, Tri-ax short throw shifter, Chromed '98 Cobra wheels,
Tires: Nitto NT Extreme 555ZR- 265/35/ZR18 in front, 285/35/ZR18 in back.
warcat is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 09-11-2006
Rookie
 
96CobraMan01's Avatar
 
Joined: Sep 2006
Location: Middleburg
Posts: 3
 
the fuel pump relay should be somewhere in your trunk, i have dealt with a fuel pump on my 1989 5.0, i had to drop the gastank and put a new one in, this is how i could tell, turn ur key to acc, no music anything, listen for the fuel pump to charge, it will sound like a small humming noise, if you dont hear antyhing then its your fuel pump
96CobraMan01 is offline  
post #3 of 6 (permalink) Old 09-12-2006
Rookie
 
Kelxin's Avatar
 
Joined: Jul 2006
Location: Denver
Posts: 9
 
Maybe fuel filter?

Quote:
Originally Posted by warcat
I've got a problem with my 1999 Cobra, and I need some help diagnosing the problem. For quite a while (about 6 months), it had trouble starting up on the first try. It usually took 2 to 3 tries before it fired up- I didn't think too much of it and figured I'd get it taken care of soon enough. Well, time flew by, and I didn't get to it. Now, it will not start. IT cranks up like normal, but won't fire. I checked the inertia switch, and it was not tripped. I also check for fuel pressure on the fuel rail, and there was no pressure.

At this point, I'm thinking it must be the fuel pump or the fuel pump relay. Can anyone give me some tips on what to do?
Had almost an identical problem with my 1996 Cobra, but I noticed when I turned the key I could hear the fuel pump trying. Instead of going through the cost and hastle of replacing the fuel pump, it maybe a good idea to replace your fuel filter first. Ever since I did that it starts with barely a touch to the key, but before it would intermittenly not start at all unless I played with it for a while. Looked like something was getting sucked up blocking the flow of gas on initial start, but if I left it for a minute and tried again it started just fine, and ran after that perfectly.
Kelxin is offline  
post #4 of 6 (permalink) Old 09-12-2006 Thread Starter
Apprentice
4.6L Member
 
warcat's Avatar
 
Joined: Oct 2005
Location: Corpus Christi
Posts: 83
 
Quote:
Originally Posted by 96CobraMan01
the fuel pump relay should be somewhere in your trunk, i have dealt with a fuel pump on my 1989 5.0, i had to drop the gastank and put a new one in, this is how i could tell, turn ur key to acc, no music anything, listen for the fuel pump to charge, it will sound like a small humming noise, if you dont hear antyhing then its your fuel pump
Well, I turn the key to acc, and I don't exactly not hear anything. I do hear something. Let me try to describe it. It sounds like a couple of clicks, followed by a 1 second pause, then a small poot. The poot sound is kinda like when you close your lips together then exhale opening your mouth. I guess the same way someone would try to pronounce the sound of the letter p.
Anyway someone can pinpoint the problem off that description ?

1999 Cobra SVT
4.10 gears, K & N Cold Air Intake, Ford Motorsports Pulleys, Steeda springs,
X-pipe exhaust w/ Magnaflows, Tri-ax short throw shifter, Chromed '98 Cobra wheels,
Tires: Nitto NT Extreme 555ZR- 265/35/ZR18 in front, 285/35/ZR18 in back.
warcat is offline  
post #5 of 6 (permalink) Old 09-18-2006
Made Member
5.0L Member
 
87stang 5.0's Avatar
 
Joined: Apr 2006
Location: Bellevue
Posts: 1,392
 
Send a message via AIM to 87stang 5.0
you have to turn the key to the on possition for the pump to prime

New addition: 1986 GT t-tops 5.0L 5speed, intake, exhaust,9mm plug wires

1987 Mustang LX 5.0 5-speed,white with smoke grey interior,MAF conversion,Perfection clutch(valeo)2.5inch Ravin exhaust, subframe connectors, ported lower intake & heads=SOLD
87stang 5.0 is offline  
post #6 of 6 (permalink) Old 08-18-2007
Rookie
5.0L Member
 
ponyboy88's Avatar
 
Joined: Aug 2007
Location: Brookhaven
Posts: 2
 
fuel pump question

i have a 1989 MUSTANG LX, it came stock with the 5.0 and a t5 and remains mostly stock, my fuel pump seems to no longer shut off when i shut the key off, but rather continues to run until i disconnect the battery, has any one had this problem, and does anyone know nwhere the fuel relay is so that i can see if that is what causing the problem, any suggestions or help is more then appreciated
ponyboy88 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in









Random Question

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183