overdrive light comes on and off - Ford Mustang Forums
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 10-14-2010 Thread Starter
Rookie
V6 Member
 
DISONE_STANG's Avatar
 
Joined: Mar 2010
Location: Central
Posts: 19
 
overdrive light comes on and off

while driving on the freeway i notice my overdrive light coming on and off. and plus my abs & traction light comes on too. does anybody know the reason why my overdrive light comes on and off. and as for my abs & traction light its always been coming on and off. but still cant find the issue to it too. if anybody knows i can use the help thanks.


DISONE_STANG
DISONE_STANG is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 10-15-2010
Senior Member
V6 Member
 
davidcseifert's Avatar
 
Joined: Dec 2009
Location: White Hall
Posts: 3,778
 
if it is flashing, its a warning for tranny problems, if it just comes on stays on then goes off idk, one thing you can do is check fluid level (must be in park while running to check it accurately) and i had that problem with the light flashing after some unnecessary stress lol changed fluid and filter never had a problem since after 15000+ miles as for the others check the owners man. it has a list of what the lights mean for each action they do, solid flashing etc. good luck!!

BV heads, P&P lower, windstar upper, comp 218/226, 4.2 bottom end, 3k stall, flow 40's, O/R x-pipe, Pacesetter lt's, Xcal2, 65mm tb, CAI, 8.8 w/ 3.73's, MM LCA's
coming soon: blower cam and intercooled M112
dealer for Ortiz Performance; tunes, cams, etc. PM me!
davidcseifert is offline  
post #3 of 6 (permalink) Old 10-15-2010 Thread Starter
Rookie
V6 Member
 
DISONE_STANG's Avatar
 
Joined: Mar 2010
Location: Central
Posts: 19
 
yesterday night after arriving at my destination i park my car and opened the hood and let it cool down. after 5 to 10 mins of letting it cooled down i started the car back up again and there was nomore flashing lights or anything. i even drove it to a friends house and i didnt see anything. there was no overdrive light coming on or off. and even the abs light went off by itself. maybe i should lift up my car and try my best to change my fluids. thats the only thing i could think of at the moment. if anybody else has any ideas im open to ideas thanks.

DISONE_STANG
DISONE_STANG is offline  
post #4 of 6 (permalink) Old 10-15-2010
Senior Member
V6 Member
 
davidcseifert's Avatar
 
Joined: Dec 2009
Location: White Hall
Posts: 3,778
 
changing fluid in tranny is pretty easy, just make sure you have something big enough to catch all the fluid that falls as it may come out both sides lol, just pop off tray and let the fluid go and once it stops filter is right there on bottem so its really easy to do just pop on new filter slap the pan back on and put in new fluid, and check it before you drive should be right around 5qts. get an extra one just in case

BV heads, P&P lower, windstar upper, comp 218/226, 4.2 bottom end, 3k stall, flow 40's, O/R x-pipe, Pacesetter lt's, Xcal2, 65mm tb, CAI, 8.8 w/ 3.73's, MM LCA's
coming soon: blower cam and intercooled M112
dealer for Ortiz Performance; tunes, cams, etc. PM me!
davidcseifert is offline  
post #5 of 6 (permalink) Old 10-15-2010 Thread Starter
Rookie
V6 Member
 
DISONE_STANG's Avatar
 
Joined: Mar 2010
Location: Central
Posts: 19
 
theres actually a white piece of plastic, where does that go? does that go right there where the magnetic shaving catcher is? its a plastic plugger i think.
DISONE_STANG is offline  
post #6 of 6 (permalink) Old 10-15-2010
Senior Member
V6 Member
 
davidcseifert's Avatar
 
Joined: Dec 2009
Location: White Hall
Posts: 3,778
 
oh, i don't know about that, i never saw one on mine sorry

BV heads, P&P lower, windstar upper, comp 218/226, 4.2 bottom end, 3k stall, flow 40's, O/R x-pipe, Pacesetter lt's, Xcal2, 65mm tb, CAI, 8.8 w/ 3.73's, MM LCA's
coming soon: blower cam and intercooled M112
dealer for Ortiz Performance; tunes, cams, etc. PM me!
davidcseifert is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Mustang Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182