1995 3.8 mustang - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 11 (permalink) Old 10-12-2013 Thread Starter
Rookie
 
cody1991's Avatar
 
Joined: Oct 2013
Location: digby
Posts: 23
 
1995 3.8 mustang

well guys im starting to get a collection of stangs lol I got a 1995 green stang I got a 1996 and another 1995 3.8 aode I just bought last night for 800 bucks lol the car is in realy good shape but has been sitting for 2 and a half years I replaced fuel pump filter ,lines etc I got lots of fuel but no fire at any of the plugs iv checked all the fuses under the hood and under the dash they are all good I tried a coil pack off one of my other 1995 mustang and still nothing. any kind of help will be apreaciated thanks
cody1991 is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 10-13-2013
Apprentice
V6 Member
 
Americansilver's Avatar
 
Joined: Jan 2013
Location: Manhattan, KS
Posts: 164
 
is the battery good
Americansilver is offline  
post #3 of 11 (permalink) Old 10-13-2013 Thread Starter
Rookie
 
cody1991's Avatar
 
Joined: Oct 2013
Location: digby
Posts: 23
 
yup the battery is brand new I just bought it it cranks over great but will not start at all thanks for the reply
cody1991 is offline  
post #4 of 11 (permalink) Old 10-13-2013
Apprentice
V6 Member
 
Americansilver's Avatar
 
Joined: Jan 2013
Location: Manhattan, KS
Posts: 164
 
If its cranking the starter is engaging the fly wheel so it shouldn't be the starter. You got fresh oil, fresh gas, and a clean air filter in the car. If it is getting gas, air, and a spark it should start, unless there is a much bigger problem with the engine.
Americansilver is offline  
post #5 of 11 (permalink) Old 10-13-2013 Thread Starter
Rookie
 
cody1991's Avatar
 
Joined: Oct 2013
Location: digby
Posts: 23
 
yea everything is fine new gas ,filter air filter all that good stuff but I am getting no fire at any of the plugs when rolling the car over
cody1991 is offline  
post #6 of 11 (permalink) Old 10-13-2013
SHELBY GT 350 Member
 
wmburns's Avatar
 
Joined: Sep 2010
Location: Houston
Posts: 5,318
       
Turn the key on but do NOT crank. Does the theft light go off after a 3 second "prove out"? Does the theft light blink during cranking?

Confirm there is +12 volts with the key on at the ignition radio interference capacitor (or coil pack R/LG wire). If no power confirm the ignition fuse in the I/P panel. If the fuse is good, confirm there is +12 volts in the supply side of the fuse holder. Post the results.

2003 GT Convertible (sold & missed)
2000 GT coupe (Craigslist project. Fixed. Now my DD). Windsor to Romeo swap.
wmburns is offline  
post #7 of 11 (permalink) Old 10-14-2013 Thread Starter
Rookie
 
cody1991's Avatar
 
Joined: Oct 2013
Location: digby
Posts: 23
 
when I turn the key on I have no theft light on I did not no these had a theft system my other 1995 has no light might just be burned out ,that may be the problem I have 12 volts every where else ,is the theft light sopposed to come on when the key is on ?
cody1991 is offline  
post #8 of 11 (permalink) Old 10-14-2013
SHELBY GT 350 Member
 
wmburns's Avatar
 
Joined: Sep 2010
Location: Houston
Posts: 5,318
       
There's a "lamp test" at initial key on. Almost all cars have this feature in order to test the dash lights.

Crank with no start check list.

http://www.allfordmustangs.com/forum...e.html#2984838

2003 GT Convertible (sold & missed)
2000 GT coupe (Craigslist project. Fixed. Now my DD). Windsor to Romeo swap.
wmburns is offline  
post #9 of 11 (permalink) Old 10-14-2013 Thread Starter
Rookie
 
cody1991's Avatar
 
Joined: Oct 2013
Location: digby
Posts: 23
 
k when I turn my key on I hear my fuel pump the only lights that are on in the dash are the seatbelt light and a check engine light no theft light the theft light don't come on at all do u think It is my anti theft if so how do I fix it ?
cody1991 is offline  
Apprentice
V6 Member
 
Americansilver's Avatar
 
Joined: Jan 2013
Location: Manhattan, KS
Posts: 164
 
You have 12v to the coil pack?
Americansilver is offline  
post #11 of 11 (permalink) Old 10-14-2013 Thread Starter
Rookie
 
cody1991's Avatar
 
Joined: Oct 2013
Location: digby
Posts: 23
 
yes I have 12 volt to the coil pack im just wondering if the anti theft can do this if so can I fix it lol
cody1991 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183