Code P0340 and Code P0344 - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 11-03-2019 Thread Starter
Rookie
 
Miguel2005S197's Avatar
 
Joined: Nov 2019
Posts: 1
 
Code P0340 and Code P0344

I have both of these codes on the car I've replaced both camshaft position sensors with the motorcraft ones and I've also replaced the connector for the bank 1 (driver's side) yet the engine light is still on and both codes are on......I need help with any ideas or just an Answer!! Thank you and I appreciate it in advance.

Miguel2005S197 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 11-03-2019
PONY Member
 
Travis98146's Avatar
 
Joined: Jun 2016
Location: Seattle
Posts: 964
 
Garage
May sound like a dumb question, but did you clear the codes after you installed the new parts? If you didn't, they would still show on your CEL. If you don't have a scan tool that will do that, I believe you can disconnect the battery for a minute then restart your car.

Travis98146 is offline  
post #3 of 4 (permalink) Old 11-03-2019
MACH I Member
5.0L Member
 
Bullitt95's Avatar
 
Joined: Feb 2007
Location: Cyprus
Posts: 3,409
 
What he said but if the codes reappear and the engine runs rough, the problem could be the VCT solenoids.


2006 GT Deluxe - 5MT - 12.50 @ 109.61
314rwhp 330rwtq with basic bolt-ons
Bullitt95 is offline  
 
post #4 of 4 (permalink) Old 4 Weeks Ago
PONY Member
 
huberoy123's Avatar
 
Joined: Aug 2008
Location: Kent County
Posts: 954
 
Garage
I also had that issue. Replaced the sensors and the codes would appear intermittently. Finally, replaced the alternator after reading some posts on this site. Problem solved.


2006 GT, Strut Tower Brace, Gas Hood Struts, FR Intake Plenum cover, Metal Fuse Box cover, Moroso brake reservoir cover, Rear shock tower brace, Front Bumper Lip Spoiler, JVC DVD Head unit w/ back-up camera, satellite Radio and USB input, 2 - 12" sub-woofers, 4 - 6"x8" speakers, 2 - 6.5" speakers to replace the door subs, 3 amplifiers, LED lights under the hood and in the trunk, chrome e-handle on parking brake handle, chrome cup holder trim, and trunk lid cover with running pony emblem.

huberoy123 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1