Clutch Pedal Problem? - Page 2 - Ford Mustang Forum
Closed Thread
 
LinkBack Thread Tools
post #16 of 17 (permalink) Old 10-09-2008 Thread Starter
Rookie
 
maxx90's Avatar
 
Joined: Mar 2004
Location: Londonderry
Posts: 31
 
Great Thanks, I just did it it and it appears to work. Im just concerned on why this happened all of sudden. I hope once i change the to spec 2+ this problem doesnt come back.
Jim

maxx90 is offline  
Sponsored Links
Advertisement
 
4.6L Member
S197 Member
 
hardhead07gt's Avatar
 
Joined: Oct 2008
Posts: 77
 
No problem... Good luck.

hardhead07gt is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
I think my clutch exploded… RazorX 2005-2010 Mustang GT Tech 18 06-21-2012 01:40 AM
Potential Clutch Problem upichie 4.6L Tech 17 07-09-2008 06:14 PM
clutch pedal hard to push down..??? fastest95stang 5.0L Tech 6 04-20-2008 01:10 PM
Help Please Clutch problem Angamine 5.0L Tech 3 09-12-2006 01:55 AM
Problem with Clutch Release Rod 69Mach1351w Classic Tech 3 06-30-2003 10:36 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1