Sucking sound after IMRC delete install? - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 10 (permalink) Old 11-24-2009 Thread Starter
Apprentice
 
cvarley's Avatar
 
Joined: Nov 2008
Location: Ames
Posts: 79
 
Sucking sound after IMRC delete install?

I finally got around to installing my Steeda economy plates. Everything went fine and my car is up and running, but when i punch the throttle I hear a very fast, quick sucking sound. There is no sounds when i ease into the throttle, only when it is punched. It kind sounds like the air that is released when changing air tools, only the air is being sucked in and it is a deeper sound. I'm not throwing any codes and the car appears to be running fine. Anyone ever run into something like this?


07 Vista Blue "debadged" GT/CS, JLT, Steeda IMRC deletes, Brenspeed 93 tune, Boomtubes, Hurst short throw, Roush hood scoop, Xenon 1/4 window scoops
cvarley is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 11-24-2009
PONY Member
4.6L Member
S197 Member
 
RedMosesSC's Avatar
 
Joined: Mar 2008
Location: New York City
Posts: 858
 
Send a message via AIM to RedMosesSC
Thats the way its supposed to sound! By installing a cold air and delete paltes you have removed all the restriction on the air induction path. so when you punch the throttle a massive amount of air gets funnled into a cone shaped entry point, hence the sound.

That sucking sound is your money hard at work!!


2006 Saleen S281 SC #1247 || Screaming Yellow || Scenic Roof || Watts Link || 3.6 Pulley || Extreme CAI || 39# Inj || Autolite HT .030 || JDM tune || Steeda F&R Sway Bars w/ Billet Mounts, adj UCA & LCA's || Magnaflow catted X Pipe || MGW ||

RedMosesSC is offline  
post #3 of 10 (permalink) Old 11-24-2009
GT Member
 
cman's Avatar
 
Joined: Feb 2007
Location: Chesteremere
Posts: 1,162
 
I get this same noise after I installed a CAI. This noise is just induction noise that can't be heard with a stock air box as the box is closed up and not open like most CAIs.

2005 black GT premium (5spd) / GT500 front LCA/upper strut mounts / Koni Adjustable (yellow)shocks with Roush Springs / FRPP 4:10 rear gear / BMR rear UCA/LCA+relocation brackets / MGW Shifter / Bassani axle backs / Cervinis heat extractor hood and Ducktail spoiler / Carroll Shelby CS69 20x9/20x10 wheels / MSD Blaster 2 coils / Roush TVS2300 Supercharger+Brenspeed 560R upgrade / Exedy Mach 500 Stage 3 Clutch / Exedy lightweight flywheel / SR Performance braided stainless clutch Line / Afco Dual Fan Heat Exchanger upgrade / JLT Catch Can / Axle Exchange one piece aluminum DS / Silly grin on my face every time I turn the key.
cman is offline  
 
post #4 of 10 (permalink) Old 11-24-2009 Thread Starter
Apprentice
 
cvarley's Avatar
 
Joined: Nov 2008
Location: Ames
Posts: 79
 
I know you should hear the induction, but I don't think this it. It is only a sharp release of air when I punch it, I don't hear it when the constant throttle is given. I've had my CAI on for a quite a while and only heard this today after I installed my delete plates.

07 Vista Blue "debadged" GT/CS, JLT, Steeda IMRC deletes, Brenspeed 93 tune, Boomtubes, Hurst short throw, Roush hood scoop, Xenon 1/4 window scoops
cvarley is offline  
post #5 of 10 (permalink) Old 11-24-2009 Thread Starter
Apprentice
 
cvarley's Avatar
 
Joined: Nov 2008
Location: Ames
Posts: 79
 
I went back through and tightened everything up again, now it seems to be gone. Easy come easy go I guess....

07 Vista Blue "debadged" GT/CS, JLT, Steeda IMRC deletes, Brenspeed 93 tune, Boomtubes, Hurst short throw, Roush hood scoop, Xenon 1/4 window scoops
cvarley is offline  
post #6 of 10 (permalink) Old 11-24-2009
PONY Member
S197 Member
 
jonballi's Avatar
 
Joined: Jul 2007
Location: Dallas/Fort Worth
Posts: 710
 
Wow...I'm impressed with this group. I was expecting a funny comment when I read the title

Mods.
M-6550-3V Cams.
Whipple HO
JBA Headers
472rhwp 435rwtq
jonballi is offline  
post #7 of 10 (permalink) Old 11-24-2009
Registered User
S197 Member
 
grabborange's Avatar
 
Joined: Jan 2007
Location: Calgary
Posts: 833
 
Quote:
Originally Posted by cvarley View Post
I went back through and tightened everything up again, now it seems to be gone. Easy come easy go I guess....
Maybe an airleak with the plenum not being tightened down enough?

Do you notice any power gains with the delete plates or loss in the low end?
grabborange is offline  
post #8 of 10 (permalink) Old 11-24-2009 Thread Starter
Apprentice
 
cvarley's Avatar
 
Joined: Nov 2008
Location: Ames
Posts: 79
 
Quote:
Originally Posted by grabborange View Post
Maybe an airleak with the plenum not being tightened down enough?

Do you notice any power gains with the delete plates or loss in the low end?
That might of been it, or I might just have been hearing things. It has been raining all day so I haven't had a chance to take my car out and see how it actually drives but it seems like it is running great. I'm guessing any power gains from will not be noticeable. I also put some Boomtubes on today(without jacking the car up, it was interesting) so that is what I'm most excited about to get out and see how they sound on the road.

07 Vista Blue "debadged" GT/CS, JLT, Steeda IMRC deletes, Brenspeed 93 tune, Boomtubes, Hurst short throw, Roush hood scoop, Xenon 1/4 window scoops
cvarley is offline  
post #9 of 10 (permalink) Old 11-25-2009
GT Member
 
jaja6009's Avatar
 
Joined: Nov 2007
Location: Atlantic City
Posts: 1,650
 
Sucking sound after IMRC delete install?

Its the mod bug at your wallet.

2005 Ford Mustang GT Torch Red Manual
Saleen Super Shaker 3.4 pulley/Brenspeed Tune
Kooks Longtubes Catted H/FRPP Stingers
Full BMR And Steeda Suspension
FRPP Throttlebody
Dynotech Driveshaft
SOLD!! I have no Mustang at this time!
jaja6009 is offline  
MODERATOR
Classic Member
S197 Member
 
stlwagon's Avatar
 
Joined: Oct 2005
Location: Southern
Posts: 72,881
                 
Send a message via Yahoo to stlwagon
What did you torqe the intake manifold bolts to?

1965 Mustang Coupe
stlwagon is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1