2006 Mustang GT Engine problem - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 02-28-2010 Thread Starter
PONY Member
S197 Member
 
snake 42's Avatar
 
Joined: Nov 2006
Location: Bonham
Posts: 398
 
Cool 2006 Mustang GT Engine problem

During the winter storage my stang's battery went dead so I replaced it. Now when I start the engine it idles rough and will not accelerate at all. I decided to reload my tune (C&L racer tune) to see if perhaps the tune had been corrupted by the loss of battery power. That made no difference whatever, the engine will still start and idle roughly but I can press the pedal to the floor and nothing happens.
Is it possible that the TPS has gone bad while without battery power or should I look elsewhere?

Ideas anyone.


Snake 42
2006 Mustang GT Premium, convertible, automatic, tungsten grey/blk top, 18" chrome Bullit wheels, C&L cai, BBK tuned shorty headers, UPR off road X-pipe, OEM mufflers, 3.73 FRPP gears and Diablosport Predator C&L Racer 93 octane tune.
snake 42 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 02-28-2010
PONY Member
4.6L Member
S197 Member
 
Leon B's Avatar
 
Joined: Nov 2009
Location: Ridgecrest
Posts: 454
 
First, do a read to see if there are any codes stored in the computer.

Leon B is offline  
post #3 of 5 (permalink) Old 02-28-2010
Shelby Gt 350 member
S197 Member
 
sqidd's Avatar
 
Joined: Dec 2006
Location: South Eastern
Posts: 9,239
           
Quote:
Originally Posted by snake 42 View Post
During the winter storage my stang's battery went dead so I replaced it. Now when I start the engine it idles rough and will not accelerate at all. I decided to reload my tune (C&L racer tune) to see if perhaps the tune had been corrupted by the loss of battery power. That made no difference whatever, the engine will still start and idle roughly but I can press the pedal to the floor and nothing happens.
Is it possible that the TPS has gone bad while without battery power or should I look elsewhere?

Ideas anyone.
If your battery doesn’t have at LEAST 13v showing when the car is not running it is likely that the battery is smoked and it is tripping your ECU out. When you start the car on a weak battery and it gets pulled down far enough a lot of manufacturers ECU’s will go ballistic and start throwing every code under the sun, going into limp home mode, etc. It doesn’t matter if the alternator is making the correct power once it is running (which it may not be, test that also).

Good luck

Waiting on 2019 GT500

2012 GT Vert Brembo - Stock-ish

2012 F-150 FX4 EcoBoost 4x4 406rwhp/522rwtq. The most powerful EB F-150 on the planet?

2007 GT-TSR/Stops/Turns/Custom Everything/3.4L Whipple Crusher/1000hp SOLD
sqidd is offline  
 
post #4 of 5 (permalink) Old 03-08-2010 Thread Starter
PONY Member
S197 Member
 
snake 42's Avatar
 
Joined: Nov 2006
Location: Bonham
Posts: 398
 
2006GT Engine Problem

Good News!!!

The engine problem turned out to be a simple fix once I found the source.
The throttle actuator preload spring had somehow jumped out of it's mounting hole and unclocked itself. I don't have the foggiest notion how it happened but just FYI if your stang ever starts and will not take input from the throttle, that's where I would look first.

Snake 42
2006 Mustang GT Premium, convertible, automatic, tungsten grey/blk top, 18" chrome Bullit wheels, C&L cai, BBK tuned shorty headers, UPR off road X-pipe, OEM mufflers, 3.73 FRPP gears and Diablosport Predator C&L Racer 93 octane tune.
snake 42 is offline  
post #5 of 5 (permalink) Old 03-08-2010
Apprentice
 
tltcracing's Avatar
 
Joined: Feb 2009
Location: Central
Posts: 176
 
interesting, good find. easy is always nice.

2005 Mustang GT
Paxton Novie 1200SL, Comp NSR Blower Grind 2, MMR Shortblock, C&L 95mm Mass/Air sensor, 39lb injectors, Motoblue ignition coils, Motoblue throttle plate spacer, Borla XR-1 Long Tube Headers and no cat x-pipe, Hooker Aero Chamber muffler, Custom LaMotta Performance tune, G-force tires, B&M shifter, Kennybell b-a-p, AEM analog A/F gauge, Interceptor scan gauge, McLeod RST clutch, aluminum flywheel
intercooler/smaller pully to come...
and yes it is my DD
tltcracing is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1