2005 Mustyang GT - "Check Charging System" - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 04-08-2010 Thread Starter
Rookie
5.0L Member
S197 Member
 
Gr8One1998's Avatar
 
Joined: Feb 2009
Location: Dallas
Posts: 15
 
2005 Mustyang GT - "Check Charging System"

So last night on my way home from work, the battery light came on my dash and my info center said "CHECK CHARGING SYSTEM". It stayed on for maybe 30 seconds, then the info center went back to normal, and the battery light went off. After a few minutes, the same thing happened again, and went back to normal just as quickly. This morning everything was fine for about 7 minutes when I started driving, then the same on/off issue with the "CHECK CHARGING SYSTEM" message and battery light started again.

I have a feeling this is an alternator problem, but it is weird to me that the light and message come and go so frequently. Has this happened to anyone before?


2008 Ford Mustang GT/CS - Black with Black/Dove Gray interior - Bone stock...for now
Gr8One1998 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 04-08-2010
MODERATOR
Classic Member
S197 Member
 
stlwagon's Avatar
 
Joined: Oct 2005
Location: Southern
Posts: 72,881
                 
Send a message via Yahoo to stlwagon
You're alternator is failing. You're on borrowed time.


1965 Mustang Coupe
stlwagon is offline  
post #3 of 4 (permalink) Old 04-12-2010
Rookie
4.6L Member
S197 Member
 
1stmustang@56's Avatar
 
Joined: Mar 2010
Location: swmichigan
Posts: 27
 
Mine is doing the same thing. Seems to happen more if I use the heater in the mornings but has also done it with nothing on. I thought maybe at 1st it was low rpms with the heater on but this morning it happened while I was doing 60 ???

Steve

2007 GT premium coupe black/medium parchment
options: 3.55 gears 18" premium wheels with pony center cap interior upgrade package. Mods: flowmaster american thunder axle back, billet grille (upper/lower), chrome taillight trim, JLT cai, bama custom tune.
 
post #4 of 4 (permalink) Old 04-13-2010
MACH I Member
4.6L Member
S197 Member
 
redruder's Avatar
 
Joined: Jul 2008
Location: Oahu
Posts: 2,557
 
mine does it from time to time in the morning if it's damp. I'm going to order another alt soon.

Forged bottom end, Ported heads, Saleen super charger, 2.8 blower pulley/15psi, Dual stage water to air intercooler, AFCO heat exchanger, battery relocated, Twin GT500 fuel pumps, T-56 trans, Aluminum flywheel, Aluminum driveshaft, 3.73 rear gears, Eaton TruTrac Diff, TA Performance rear end girdle, Racecraft suspension system, UCA, LCA, panhard bar, 15" slotted front rotors w/ 6 piston calipers, Carbon Fiber front splitter/rear diffuser, and bunch of other stuff
RWHP/RWTQ is adequate
redruder is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1