All three BAMA tunes - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 05-10-2010 Thread Starter
Apprentice
S197 Member
 
goofas7070's Avatar
 
Joined: Mar 2010
Location: Houston
Posts: 205
 
All three BAMA tunes

I just tried all three 93 octane BAMA tunes in my 2009 GT. I think I will stick with the "Street" tune. It gives the best fun factor in my opinion. My set up includes JLT CAI, FRPP shorty headers and the stock H pipe with Flowmasters. The low to midrange torque is just a blast and I can't shift fast enough to keep up with that crazy "race" tune!

goofas7070 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 05-10-2010
BOSS Member
 
Thereaper's Avatar
 
Joined: Jul 2007
Location: Mobile
Posts: 4,571
 
Garage
I run the 93 Race tune and have been very happy with it.


Shadow Black 2018 GT 10R80-355
Thereaper is offline  
post #3 of 6 (permalink) Old 05-10-2010
GT Member
 
gmantheman's Avatar
 
Joined: Jun 2008
Location: Escondido
Posts: 1,636
 
I will switch tunes from time to time. I like the updated race tune better than the previous race tune and better than the tq tune. It has the low end tq of the tq tune but also the drive-ability of the tq tune. I have only used the performance tune a few times. Currently I am running Brooksspeed tune which is a well balanced tune.

RIP 2006 Mustang GT
New Ride 04 Pontiac GTO
gmantheman is offline  
 
post #4 of 6 (permalink) Old 05-11-2010
Rookie
4.6L Member
S197 Member
 
PonySticks's Avatar
 
Joined: May 2010
Location: Spangdahlem AFB
Posts: 7
 
hey did any of you guys after your tune and cai install have the check engine light come on.... and if so .... more than likley theres nothing wrong just go ahead and clear it..... the tune is amazing though... hell of alot more mid range

PoNyStIcKs

07 GT Premium
Eleanor Grill
FRPP Lowering Springs
JBA Axleback
Steeda UDP
JLT 88mm CAI
PonySticks is offline  
post #5 of 6 (permalink) Old 05-11-2010
GT Member
 
gmantheman's Avatar
 
Joined: Jun 2008
Location: Escondido
Posts: 1,636
 
My CEL will sometimes come on when I install a tune. Clearing it usually takes care of the problem. The codes are usually the "cycle not ready" and Lean Bank 1 or Bank 2 or both. According to two different dynos, my A/F is around 12.4 to 12.9

RIP 2006 Mustang GT
New Ride 04 Pontiac GTO
gmantheman is offline  
post #6 of 6 (permalink) Old 05-15-2010
Rookie
4.6L Member
S197 Member
 
PonySticks's Avatar
 
Joined: May 2010
Location: Spangdahlem AFB
Posts: 7
 
I fixed it... i forgot to go into the x3 tuner and adjust it to my CAI and the 93 ict since i dont have the custom tune yet.... runs awesome definatly looking forward to getting my bamachips tune this week somtime
PonySticks is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1