Trouble codes and SCT tuner questions - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 8 (permalink) Old 10-10-2010 Thread Starter
Apprentice
S197 Member
 
nathansdad04's Avatar
 
Joined: Aug 2006
Location: Upstate
Posts: 161
 
Trouble codes and SCT tuner questions

My 06 Mustang GT popped 2 codes (P0345 and P0349)- car hiccups while I'm driving
; and also the power steering pump is whining terribly.

I'm bringing it in to Ford dealer Tuesday and I need some help.

I have to return it to factory tune and lost my SCT tuner instructions. I haven't used the tuner since I installed my BamaTunes tune 2 years ago. Does the SCT just walk you thru the steps to reflash to factory?

Is the dealer likely to update the car's software, so my SCT ends up not working anymore? Can I tell them not to update my car or am I likely to raise red flags if I ask them not to?

Is the power steering pump and P0345/349 code problems covered under my 5 years/60K warranty?

I've done some searching here for answers, but I've been away from the boards for awhile and am so out of touch now I'm kinda lost.


2006 Black GTA Premium Vert

Mods:
JLT CAI/Bama 93 race Tune/ Taillight trim/Trunk Letters/painted calipers/CDC Classic Chin Spoiler/Ford Exhaust Tips/Pony emblems/Sequential Taillights
nathansdad04 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 10-11-2010
PONY Member
 
Stangstta's Avatar
 
Joined: Jul 2010
Location: Boston MetroWest
Posts: 424
 
The codes could quite possibly be caused by your alternator diodes failing. There is a TSB on this. See:

https://www.allfordmustangs.com/forum...sb06_02_09.pdf

This TSB calls for a scope to monitor the alternator ripple pattern. You can see the different ripple patterns on the last page of the TSB.

Returning to the stock stradegy is not difficult. The tuner will walk you through it. However, installing the stock stradegy will also reset the PCM and clear any codes. If you take the car in shortly after doing that, and your dealer tech is sharp, they can tell that the PCM has been recently reset, as not all the OBDII Readiness Monitors will be "Ready". There is also a PID, "DRIVECNT" which shows how many miles the vehicle has been driven since the PCM has been reset last. Hopefully the code will pop again once the stock stradegy is reloaded...

You will have to explain why you don't want the PCM re-flashed, which I expect will raise a red flag. You can use your tuner to identify the stock stradegy code before you bring it in. Since you have Bamatunes, you can always get a new free tune if they do re-flash the PCM.

Those codes and power steering pump should be covered under your powertrain warranty.

-Stangstta

Stangstta is offline  
post #3 of 8 (permalink) Old 10-11-2010 Thread Starter
Apprentice
S197 Member
 
nathansdad04's Avatar
 
Joined: Aug 2006
Location: Upstate
Posts: 161
 
Ok...I just took off the CAI and reflashed to stock. I started the car and got a "wrench" trouble light on the dash console....and the car runs rough and won't stay idling.
WTF??! I've got to drive 15 miles to the dealer first thing and I have no idea if the car will make it or not.

2006 Black GTA Premium Vert

Mods:
JLT CAI/Bama 93 race Tune/ Taillight trim/Trunk Letters/painted calipers/CDC Classic Chin Spoiler/Ford Exhaust Tips/Pony emblems/Sequential Taillights
nathansdad04 is offline  
 
post #4 of 8 (permalink) Old 10-11-2010
PONY Member
 
Stangstta's Avatar
 
Joined: Jul 2010
Location: Boston MetroWest
Posts: 424
 
What are the code(s) in the PCM now?
Stangstta is offline  
post #5 of 8 (permalink) Old 10-11-2010 Thread Starter
Apprentice
S197 Member
 
nathansdad04's Avatar
 
Joined: Aug 2006
Location: Upstate
Posts: 161
 
No codes. When I start it...I keep blipping the throttle or hold it at 2k RPM I can keep it running

2006 Black GTA Premium Vert

Mods:
JLT CAI/Bama 93 race Tune/ Taillight trim/Trunk Letters/painted calipers/CDC Classic Chin Spoiler/Ford Exhaust Tips/Pony emblems/Sequential Taillights
nathansdad04 is offline  
post #6 of 8 (permalink) Old 10-11-2010 Thread Starter
Apprentice
S197 Member
 
nathansdad04's Avatar
 
Joined: Aug 2006
Location: Upstate
Posts: 161
 
UPDATE:

After furiously Googling the subject....I went back and rechecked the MAF sensor. BINGO! It wasn't plugged in properly.

Car starts and idles just fine. Now I'll just have to take the long way to the dealership to try and trip the the trouble codes before I get there.


Thanks, Stangstta for trying to help out.

2006 Black GTA Premium Vert

Mods:
JLT CAI/Bama 93 race Tune/ Taillight trim/Trunk Letters/painted calipers/CDC Classic Chin Spoiler/Ford Exhaust Tips/Pony emblems/Sequential Taillights
nathansdad04 is offline  
post #7 of 8 (permalink) Old 10-11-2010
PONY Member
 
Stangstta's Avatar
 
Joined: Jul 2010
Location: Boston MetroWest
Posts: 424
 
If the wrench light is on there should be codes. Try disconnecting the negative terminal of the battery for 15 minutes to reset the PCM. Reconnect after 15 minutes and advise.
Stangstta is offline  
post #8 of 8 (permalink) Old 10-11-2010
PONY Member
 
Stangstta's Avatar
 
Joined: Jul 2010
Location: Boston MetroWest
Posts: 424
 
You're quite welcome. Glad you figured it out.

Please follow-up on this thread with what the dealer finds for those codes.
Stangstta is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1