2005 Mustang GT Power Loss - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 8 (permalink) Old 05-17-2012 Thread Starter
Rookie
 
dhellstang's Avatar
 
Joined: May 2012
Location: Lincoln
Posts: 7
 
2005 Mustang GT Power Loss

This has happened twice now. I was driving on the HWY at 75MPH just maintaining speed. All of the sudden it feels like I've lost quite a bit of power. ALL gears get sluggish! It feels like the car is ignoring the pressure I put on the accelerator. Then the wrench icon will light up (under the speedo).
The every time this has happened, it seemed to fix itself after it was shut off and left alone for a few hours. Car drives normal as long as I'm not going far have gone on a lot of 1.5hr drives with no issues. The first time this occurred I was on a 3hr trip and it had issues about hour 2. The second time this happened I was on an 8hr trip and it had issues about hour 5.
The first time I suspected bad gas, but after the second occurrence several months later I'm not sure what to think.
I had the codes read and the only thing that shows up is a misfire.


dhellstang is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 05-17-2012
GT Member
5.0L Member
 
ShortySmalls's Avatar
 
Joined: Oct 2011
Location: Goose Creek, SC
Posts: 1,375
 
Garage
When was the last time the fuel filter plugs and wires where changed

Sent from my Desire HD using Tapatalk 2


2016 Mustang GT 5.0 Magnetic Metallic Performance Package
Interior - Recaro Bucket Seats, Weathertech Digital Fit Floor Mats, Diode Dynamics LED Visor Mirror Lights, LED Glove Box Light, LED Trunk Light, and LED Map Light
Exterior -Dealer Installed Shelby GT350 Racing Stripes, SunTek Carbon 15% Tint, Diode Dynamics LED Switchback Blinkers, LED Reverse Light
Performance - MBRP Race Series 3" Catback
ShortySmalls is offline  
post #3 of 8 (permalink) Old 05-17-2012 Thread Starter
Rookie
 
dhellstang's Avatar
 
Joined: May 2012
Location: Lincoln
Posts: 7
 
fuel filter was changed about 25,000mi ago but I will just replace it again to be sure thats not what it is.

plugs and wires havent been change in the 25,000mi that I have owned the car I will look into them as well.

Thanks for the post.
dhellstang is offline  
 
post #4 of 8 (permalink) Old 05-17-2012
PONY Member
S197 Member
 
GTBob985's Avatar
 
Joined: May 2012
Location: Mandeville
Posts: 534
 
I know that some guyes swear that they change thier fuel filter once a year after every winter, especially if they store the care.

also there is a known issue with air bubbles in the 05 fuel pump that manifests itslef after highway driving for a while.

2008 Metallic Alloy GT Convertible Premium
Show : black top| 18" bullitt polished wheels| CDC light bar and black billet replacement grilles | black/amber corner lights | GT500 rear spoiler| AH chin spoiler
Go:
FRPP CAI with StangHi tunes | Kooks LT's | FR500 axle back | Steeda Sport springs | Koni STR.t struts/shocks | J&M camber plates | UMI adj. panhard bar | LCA relocation brackets | GT500 LCA's | Hurst Billet shifter | 3.73 gear | FRPP axle girdle | Baer Rotors and Pads
GTBob985 is offline  
post #5 of 8 (permalink) Old 05-17-2012 Thread Starter
Rookie
 
dhellstang's Avatar
 
Joined: May 2012
Location: Lincoln
Posts: 7
 
Air bubbles in the fuel pump sounds like it could be a definite possibility to me since everything is fine until I take a long drive.
dhellstang is offline  
post #6 of 8 (permalink) Old 05-18-2012 Thread Starter
Rookie
 
dhellstang's Avatar
 
Joined: May 2012
Location: Lincoln
Posts: 7
 
Any reason this couldn't be the TPS? Just hoping I don't have to replace the fuel pump.
Also I saw that it's recomended to replace the whole fuel tank not just the pump any ideas why this would be? Venting maybe?
dhellstang is offline  
post #7 of 8 (permalink) Old 05-18-2012
PONY Member
 
psycho bob's Avatar
 
Joined: Apr 2012
Location: Peyton
Posts: 429
 
people there are no plug wires on these cars. seems like i keep seeing people asking if the wires have been changed. please tell me where the distributor is on your 3v.

no idea why you would change the entire tank. there have been some people that have issues when filling the tank, but i've not had the issue more than once or twice.

Heads, Cams, Edelbrock Eforce, 4.10 & true-trac, TR6060 trans, DSS driveshaft, Full BMR suspension, tokico d-specs, eibach pro kit springs
psycho bob is offline  
post #8 of 8 (permalink) Old 06-14-2012
Rookie
 
Yourself's Avatar
 
Joined: Jun 2012
Location: Delta
Posts: 4
 
Do your spark plugs and check your coil packs.

Black 2005 Mustang GT BBK CAI, Bullitts, Spoiler Delete, Roush 9 bar grille, FRPP Handling Pack.
Dark Blue 2003 Crown Victoria Police Interceptor
Dark Blue 2001 F150 SuperCrew
Yourself is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1