Need some advice please - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 08-07-2012 Thread Starter
Apprentice
 
cfr865's Avatar
 
Joined: Nov 2006
Location: midwest
Posts: 118
 
Need some advice please

About two weeks ago I was driving on the highway doing about 70 mph suddenly the car lost power. I was able to get it to my tuner, they are having a hard time finding the problem, the cats are good, the throttle body is good, 02 sensors are good, the tune files are all crazy and running very rich fowling the plugs. I have paxton 2200 s/c GT-500 fuel pump, DSS stroked 302. Any suggestions would be appreciated.

cfr865 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 08-07-2012
PONY Member
5.0L Member
 
redrocket93's Avatar
 
Joined: Mar 2008
Location: Park Forest
Posts: 372
 
what boost were you running and does it still boost up also what year. did you foul all plugs might need a new fuel pressure regulator need alittle more info like injector size ect.

redrocket93 is offline  
post #3 of 4 (permalink) Old 08-07-2012 Thread Starter
Apprentice
 
cfr865's Avatar
 
Joined: Nov 2006
Location: midwest
Posts: 118
 
Quote:
Originally Posted by redrocket93 View Post
what boost were you running and does it still boost up also what year. did you foul all plugs might need a new fuel pressure regulator need alittle more info like injector size ect.
I have 60lb. injectors 10% overdrive crank pulley, about 12 psi. I don't know if its still building boost I'll ask the tuner tomorrow.
cfr865 is offline  
 
post #4 of 4 (permalink) Old 08-10-2012 Thread Starter
Apprentice
 
cfr865's Avatar
 
Joined: Nov 2006
Location: midwest
Posts: 118
 
Found the problem, it was a torn rubber fitting that connects the plumbing on the s/c. It was hard to find because it was a small slit but enough to cause a major problem. Does anyone who has a Paxton had this problem before ?
cfr865 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1