2005 Mustang Clutch Chatter Issue - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 8 (permalink) Old 02-10-2007 Thread Starter
 
pfiandra's Avatar
 
Joined: Jul 2005
Posts: 317
 
2005 Mustang Clutch Chatter Issue

Every once in a while when I engage the clutch on my 05 GT I get a sort of chatter. It only seems to do it when I slowly engage it like in traffic. I haven't noticed it slipping or anything like that. Have any of you guys noticed this?

pfiandra is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 02-10-2007
MACH I Member
5.0L Member
S197 Member
 
Kyle F's Avatar
 
Joined: Aug 2005
Location: Knoxville
Posts: 3,067
 
Send a message via AIM to Kyle F Send a message via Yahoo to Kyle F
I had that problem with my 05. The good news is it eventually went away. I never took it to the dealer because it wasn't often enough to be able to count on it happening and I could never figure out how to make it happen.

Mine lasted about a month... I still have no clue what it was.


2006 Mustang GT in Torch Red
C&L Intake, Evolution Performance Tune, Borla Axle Backs, Hurst Shifter, 4.10's, JBA Long Tubes, Prothane Engine Mounts, Steeda UDPs, FRPP Charge Motion Delete Plates

84 Bronco, 302 C6 on 32 10.50's
Kyle F is offline  
post #3 of 8 (permalink) Old 02-10-2007
SHELBY GT 350 Member
4.6L Member
 
tripleblack's Avatar
 
Joined: Feb 2005
Location: Atlanta
Posts: 5,633
 
Chatter

Are you sure it isn't the clutch packs in your posi rear end? I hear they can act up (there's a TSB on this - they add 4oz of friction modifier).

tripleblack

"You can never be free until you let yourself go."
tripleblack is offline  
 
post #4 of 8 (permalink) Old 02-10-2007
MODERATOR
Classic Member
S197 Member
 
stlwagon's Avatar
 
Joined: Oct 2005
Location: Southern
Posts: 72,881
                 
Send a message via Yahoo to stlwagon
Could be a little abnormality in either the pressure plate or clutch plate.

1965 Mustang Coupe
stlwagon is offline  
post #5 of 8 (permalink) Old 02-10-2007 Thread Starter
 
pfiandra's Avatar
 
Joined: Jul 2005
Posts: 317
 
Quote:
Originally Posted by tripleblack View Post
Are you sure it isn't the clutch packs in your posi rear end? I hear they can act up (there's a TSB on this - they add 4oz of friction modifier).
I'm not sure. It's hard to tell. It only seems to do it when the car is good and warmed up and it it's very intermittent. If I want to make smoke, engage the clutch and tromp it it works fine.
pfiandra is offline  
post #6 of 8 (permalink) Old 02-10-2007
MODERATOR
Classic Member
S197 Member
 
stlwagon's Avatar
 
Joined: Oct 2005
Location: Southern
Posts: 72,881
                 
Send a message via Yahoo to stlwagon
Quote:
Originally Posted by pfiandra View Post
I'm not sure. It's hard to tell. It only seems to do it when the car is good and warmed up and it it's very intermittent. If I want to make smoke, engage the clutch and tromp it it works fine.
Clutch pack noise is easy to distinguish. Rear end makes a sound like a rock tumbler in tight low speed turns.

1965 Mustang Coupe
stlwagon is offline  
post #7 of 8 (permalink) Old 02-10-2007
SHELBY GT 500 Member
 
pcfrisch's Avatar
 
Joined: Feb 2005
Location: Southeastern
Posts: 13,191
 
Quote:
Originally Posted by stlwagon View Post
Clutch pack noise is easy to distinguish. Rear end makes a sound like a rock tumbler in tight low speed turns.
That is what I am experiencing.




AFM Site Administrator
2006 Tungsten Grey Mustang GT Manual.
Alpine H/U with Infinity speakers.
Powerhouse CAI and Tune.
Previous Mustangs:
1978 2.8 L, 1979 5.0, 1982 5.0 "HO", 1986 5.0 GT

Don't wait for tomorrow to look back and wish for today
pcfrisch is offline  
post #8 of 8 (permalink) Old 02-10-2007
PONY Member
S197 Member
 
booger's Avatar
 
Joined: Mar 2006
Location: Broomfield
Posts: 463
 
Quote:
Originally Posted by pcfrisch View Post
That is what I am experiencing.
Better get it in and get it fixed.

My wifes V6 Mustang had an intermittent chattering clutch for the first 3k miles or so. It was a bear to start out without it chattering like crazy. It has finally quit and seems to work fine now. My GT hasn't done it though.

06 GT Legend Lime, Konig Beyonds, Hurst, JBA, Steeda stuff, MAC CAI, Sniper tuned, LT's, catted H pipe, VIS Racing CF heat extractor hood, Tokico D-Specs, Silver Horse Racing, LLR #0174

08 GT Performance White, Konig Beyonds, Legend Lime accents.
booger is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
What is clutch chatter & why does it happen Born To Run 2005-2010 Mustang GT Tech 0 08-06-2006 11:14 PM
UK 2005 GT Update! Thanks to all of you, my Mustang is shaping up General G 2005-2010 Mustang Talk 3 06-13-2006 05:04 AM
2005 Mustang Clutch Problems! CrzyHorse 2005-2010 V6 Mustang Tech 1 06-10-2006 06:46 PM
05 mustang commercial wll premiere in movie theaters on Oct. 29 dave 02 gt 2005-2010 Mustang Talk 23 10-18-2004 01:29 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1