2007 Mustang GT...Brake Pressure killing throttle? - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 12 (permalink) Old 09-10-2007 Thread Starter
S197 Member
 
88_stanga's Avatar
 
Joined: Dec 2003
Posts: 516
 
2007 Mustang GT...Brake Pressure killing throttle?

Ok so the past few times ive been to the track. i pull up to the water box spin the tires, pull up a bit and do my burnout. pull up to the lights, launch and then NOTHING. the car is horrible slow through first gear. grab second and it feels normal. now i just read over on SVT performance, a gentleman with a GT500 was saying that if the computer senses too much brake pressure that it will cut throttle.

Quoted: it's a combo of t/c and the stupid drive by wire...it will close the TB if it senses too much brake applied. I now have a line lock so no more worries stalling during a burnout.

think this is my problem?

88_stanga is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 09-10-2007
SHELBY GT-40 ULTIMATE Member
4.6L Member
5.0L Member
 
EagleAutosports's Avatar
 
Joined: Feb 2007
Location: Graham
Posts: 46,020
               
I would say so about the computer cutting down the throttle. I'm sure the S197 crowd will chime in too but that's more than likely the gremlin.









AFM Site Administrator
Member: Mustang Club of America #82740, White Mustang Registry #362, NMRA, Fun Ford Weekend, Mustangs of Burlington

MOOG Certified Technician
For mods and sound clips, see profile and gallery.

EagleAutosports is offline  
post #3 of 12 (permalink) Old 09-10-2007
S197 Member
 
don_w's Avatar
 
Joined: Dec 2006
Posts: 1,796
 
I've made 900 runs in my car and never had a situation where brake pressure affected the launch.

Of course, launching with TCS on is a big no-no. It will kill you out of the whole for sure.
don_w is offline  
 
post #4 of 12 (permalink) Old 09-11-2007
Apprentice
S197 Member
 
Liftedbronco's Avatar
 
Joined: Aug 2007
Location: Suffern
Posts: 56
 
I have the same problem 07gt

2007 White GT coupe. 5-sp. Ford racing whipple 500-hp kit. Ford racing rear end girdle. Centerforce DFX clutch and lightweight billet flywheel. Apexcone HID's in fogs and headlights. Steeda torque box braces. Ford racing front control arm brace. Optima yellow top. GTA mufflers.
Liftedbronco is offline  
post #5 of 12 (permalink) Old 09-11-2007 Thread Starter
S197 Member
 
88_stanga's Avatar
 
Joined: Dec 2003
Posts: 516
 
Quote:
Originally Posted by Liftedbronco View Post
I have the same problem 07gt
this problem never happened to me on my 06. ive had this problem twice. both times were during my first pass down the track. TCS was OFF.
88_stanga is offline  
post #6 of 12 (permalink) Old 09-11-2007
PONY Member
S197 Member
 
thump_rrr's Avatar
 
Joined: Mar 2005
Location: Montreal
Posts: 897
 
Send a message via MSN to thump_rrr
Quote:
Originally Posted by 88_stanga View Post
Ok so the past few times ive been to the track. i pull up to the water box spin the tires, pull up a bit and do my burnout. pull up to the lights, launch and then NOTHING. the car is horrible slow through first gear. grab second and it feels normal. now i just read over on SVT performance, a gentleman with a GT500 was saying that if the computer senses too much brake pressure that it will cut throttle.

Quoted: it's a combo of t/c and the stupid drive by wire...it will close the TB if it senses too much brake applied. I now have a line lock so no more worries stalling during a burnout.

think this is my problem?
Do you have a tune in the car or is it stock?

05 White GT Premium 5 Sp. IUP, Active Alarm
BMR, C&L, Centerforce, Fidanza, FRPP, GI Joe, JBA, JDM Engineering, LPW, Saleen, SCT, Steeda, SOS

S/C 1.613 60'. 4.748 330', 7.332 @ 93.75mph 1/8th, 9.566 1000', 11.427 @ 119.92 1/4mile
thump_rrr is offline  
post #7 of 12 (permalink) Old 09-12-2007
Apprentice
S197 Member
 
Liftedbronco's Avatar
 
Joined: Aug 2007
Location: Suffern
Posts: 56
 
mines completley stock. have appt to go get supercharged shortly so ill let you know if that tune i get fixes it.

2007 White GT coupe. 5-sp. Ford racing whipple 500-hp kit. Ford racing rear end girdle. Centerforce DFX clutch and lightweight billet flywheel. Apexcone HID's in fogs and headlights. Steeda torque box braces. Ford racing front control arm brace. Optima yellow top. GTA mufflers.
Liftedbronco is offline  
post #8 of 12 (permalink) Old 09-12-2007 Thread Starter
S197 Member
 
88_stanga's Avatar
 
Joined: Dec 2003
Posts: 516
 
mines stock. no reflash. awaiting on Diablosport to not suck. hoping that fixes it. but even on my 06 when it was stock it never did that
88_stanga is offline  
post #9 of 12 (permalink) Old 09-13-2007
BOSS Member
Classic Member
S197 Member
 
zmanm3's Avatar
 
Joined: Dec 2006
Location: St. Robert
Posts: 3,839
 
Send a message via Yahoo to zmanm3
I'd get the line locks anyway. PMP sells a nice set for about $70.

05 - Zeon body kit, Saleen S/C, 3.6" pully, 90mm MAF, L/T Heders, Catted X-Pipe, Saleen Race Craft suspension, Axel brace, Pan hard bar. More to come this spring from my friends at PMP and Larry H.
65 - Street force coil over front suspension, Wilwood disk breaks at all 4 wheels, More construction in progress! More to come this spring from Simons Auto & Restoration!
zmanm3 is offline  
MACH I Member
S197 Member
 
JetBlack's Avatar
 
Joined: Nov 2005
Location: Grand Junction
Posts: 3,106
 
Try this.

In the driveway, press down on the brake pedal, fairly hard.

Let off the brake and just sit there.

Watch the RPMs and see if they drop or the car just dies. If this happens, you have a bad brake booster. It's just a vacuum leak and the booster, although it is a very large chunk of part, is cheap and very easy to replace.

2006 Black, GT, spoiler delete, five speed, leather, custom welded straight pipes with resonators, sequential turn signals, Hurst Pro Performance shifter. FRPP 4.10s with Motive bearing kit, Spydershaft one piece aluminum driveshaft, w/ Spicer 1330 U-joints, Steeda UCA and LCAs, chrome moly panhard rod. bye bye wheel hop, hello traction! SCT XCalII, BBK CAI, ZEX 100 shot.
I've written a book or two. Google David Buschhorn to laugh at my scribblings.
JetBlack is offline  
PONY Member
S197 Member
 
snowboarder7710's Avatar
 
Joined: May 2007
Location: Rancho Cucamonga
Posts: 331
 
on my 07 i can hold the brake and do a burnout and it revs up fine for me.
snowboarder7710 is offline  
SHELBY GT 350 Member
S197 Member
 
RetroGT2006's Avatar
 
Joined: Feb 2007
Location: Central
Posts: 6,048
 
Send a message via AIM to RetroGT2006
my 06 GT had no problems stock, and now with the intake/ tune.. it still does it good..

Daily Driver: 2006 Honda CBR600rr
Weekend Warrior: 2006 Mustang GT
RetroGT2006 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Need info on stock injectors for a 2007 Mustang GT RS89Gt 2005-2010 Mustang GT Tech 7 05-26-2009 12:39 PM
2002 Mustang GT Convertible... questions about suspension fresnoGT 4.6L Tech 6 09-03-2007 02:51 AM
2007 Mustang GT exhaust... Question about mid-pipes srt2stang725 2005-2010 Mustang Talk 16 09-02-2007 09:35 PM
2007 Mustang GT PCM removal Liftedbronco 2005-2010 Mustang GT Tech 9 08-17-2007 04:33 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1