License plate bulb wont turn on !!!! - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 13 (permalink) Old 01-10-2010 Thread Starter
Apprentice
V6 Member
S197 Member
 
MustangV6x's Avatar
 
Joined: Nov 2007
Location: Joliet
Posts: 244
 
License plate bulb wont turn on !!!!

my mustang license plate light wont turn on when i turn my headlights or parking lights But when i unlocked or lock my car the license plate light will turn on ( along with my park lights and taillights ) for a sec so what can be the problem what fuses should i check ?

MustangV6x is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 01-10-2010
MACH I Member
4.6L Member
S197 Member
 
Ryan09's Avatar
 
Joined: Mar 2009
Location: Cape Girardeau
Posts: 2,828
 
Hmm not sure, look in the manual.


07 White GT Premium/ Eibach Pro Kit/ 2010 GT500 staggered wheels/NITTO 555R Tires/ GT Headrests/ Straight Pipes with 4inch stainless tips/ 5% tint/ Apline sound system.
*RIP*(Dad, Grandpa, Jared, and many others)
*I've learned from my mistakes, and I'm becoming a better person because of them*
Ryan09 is offline  
post #3 of 13 (permalink) Old 01-10-2010
MACH I Member
S197 Member
 
Dave's Avatar
 
Joined: Mar 2007
Location: Amherst
Posts: 2,655
 
Should we play twenty questions? Is it a Mustang? What year? Just a little bit of info like just might help! Do the turn and brake lights work all the time?
Dave

2015 Stage 3 Roush
'66' Ranchero w/almost done 302 T-5 swap
2000 4x4 Ranger
2003 4x2 Ranger
'69' Fairlane Cobra, 428 4-speed waiting for work
Dave is offline  
 
post #4 of 13 (permalink) Old 01-10-2010
SHELBY GT 500 Member
 
amustangrocks's Avatar
 
Joined: Jul 2008
Location: Traverse City
Posts: 11,864
         
have you messed with the wiring, like adding sequentials or anything else?

05 V6 auto,
amustangrocks is offline  
post #5 of 13 (permalink) Old 01-10-2010
BOSS Member
V6 Member
5.0L Member
S197 Member
 
SilverBullet07's Avatar
 
Joined: Oct 2008
Location: Canton
Posts: 4,217
 
fuse maybe? maybe just a short somewhere? hmmm....its a mystery!

1985 Regatta Blue vert 5.0- 87 5.0 shortblock, T5 transmission, Steeda Tri-ax Shifter, A/C delete, UDP's, edelbrock rpm performer intake, holley 600 4bbl carb, dual flowmaster 44's with o/r H pipe, MSD ignition, 1.72 roller rockers, Tokico HP shocks/struts, FRPP B springs, FRPP 4.10's

2003 F150 Lariat 4x4-DD
2007 V6 Nitrous injected-SOLD
2002 GT 5 speed- SOLD
SilverBullet07 is offline  
post #6 of 13 (permalink) Old 01-10-2010 Thread Starter
Apprentice
V6 Member
S197 Member
 
MustangV6x's Avatar
 
Joined: Nov 2007
Location: Joliet
Posts: 244
 
its a 2005 mustang v6

Quote:
Originally Posted by MustangV6x View Post
my mustang license plate light wont turn on when i turn my headlights or parking lights But when i unlocked or lock my car the license plate light will turn on ( along with my park lights and taillights ) for a sec so what can be the problem what fuses should i check ?
MustangV6x is offline  
post #7 of 13 (permalink) Old 01-10-2010 Thread Starter
Apprentice
V6 Member
S197 Member
 
MustangV6x's Avatar
 
Joined: Nov 2007
Location: Joliet
Posts: 244
 
Quote:
Originally Posted by amustangrocks View Post
have you messed with the wiring, like adding sequentials or anything else?

ya the sequentials and halo fog lights
MustangV6x is offline  
post #8 of 13 (permalink) Old 01-10-2010 Thread Starter
Apprentice
V6 Member
S197 Member
 
MustangV6x's Avatar
 
Joined: Nov 2007
Location: Joliet
Posts: 244
 
ya my brake and turn signals work
Quote:
Originally Posted by Dave View Post
Should we play twenty questions? Is it a Mustang? What year? Just a little bit of info like just might help! Do the turn and brake lights work all the time?
Dave
MustangV6x is offline  
post #9 of 13 (permalink) Old 01-10-2010
MACH I Member
S197 Member
 
Dave's Avatar
 
Joined: Mar 2007
Location: Amherst
Posts: 2,655
 
Do the side marker lights work? Those go thru the same connector as the liscense light. Have no idea why the lights are acting like they are switched. Sorry for being kind of smart earlier but someone at another site asked "My car is running rough, what's wrong with it"? No info given at all.
Dave

2015 Stage 3 Roush
'66' Ranchero w/almost done 302 T-5 swap
2000 4x4 Ranger
2003 4x2 Ranger
'69' Fairlane Cobra, 428 4-speed waiting for work
Dave is offline  
post #10 of 13 (permalink) Old 01-10-2010 Thread Starter
Apprentice
V6 Member
S197 Member
 
MustangV6x's Avatar
 
Joined: Nov 2007
Location: Joliet
Posts: 244
 
yeah im guessing might be a bad bulb because its led bulb but im about to go to autozone to get a new bulb and see
Quote:
Originally Posted by Dave View Post
Do the side marker lights work? Those go thru the same connector as the liscense light. Have no idea why the lights are acting like they are switched. Sorry for being kind of smart earlier but someone at another site asked "My car is running rough, what's wrong with it"? No info given at all.
Dave
MustangV6x is offline  
Apprentice
V6 Member
S197 Member
 
GilmourD's Avatar
 
Joined: Nov 2009
Location: Rutherford
Posts: 116
 
Having been a PC tech for about 20 years, now, the first thing I do is unplug and then replug everything. I actually do this a few times. Sometimes something weird may build up on a connector somehow and the unplug/replug operation cleans that off.

2006 Mustang V6 Convertible: Stock so far
1994 Mustang GT: 306 (Speedpro H273CP pistons, stock rods & crank, GT-40P heads, 5.0HO cam, Crane/FRPP 1.7 roller rockers), MAC GT-40P headers, Magnaflow catted H-pipe, Magnaflow cat-back, KYB shocks & struts, aluminum driveshaft, stock T5 Sold, but still in the family
GilmourD is offline  
post #12 of 13 (permalink) Old 01-10-2010 Thread Starter
Apprentice
V6 Member
S197 Member
 
MustangV6x's Avatar
 
Joined: Nov 2007
Location: Joliet
Posts: 244
 
Quote:
Originally Posted by GilmourD View Post
Having been a PC tech for about 20 years, now, the first thing I do is unplug and then replug everything. I actually do this a few times. Sometimes something weird may build up on a connector somehow and the unplug/replug operation cleans that off.
well somehow it got fix now lol
MustangV6x is offline  
Apprentice
 
nitro1989's Avatar
 
Joined: Sep 2010
Location: Hialeah
Posts: 174
 
Lights

Alright ! i have a 2011 mustang V6 and i recently Crashed the right side of it... car was standing still for 2 months Computer was removed and battery... now the car is put back together with the cobra conversion and new Projector Headlights before putting in the headlights i Noticed when i Put the Switch for the lights on the Middle (Parking lights) they would not turn on and recently i noticed that the Tail lights DONT turn on either only when i brake they turn on.... im not sure what may cause this.... maybe Fuses any one have feed back please thank you?

Mobile Mod Performance
Mustang Performance
v6mustangperformance.com
Leading 3.7L Database Website
nitro1989 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in













Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1