Engine cover rubbing - Page 2 - Ford Mustang Forum
Reply
 
LinkBack Thread Tools
S197 Member
 
HazMatLadder26's Avatar
 
Joined: Feb 2005
Posts: 538
 
I hope I just didnt spend 300 bucks on a Midwest Auto air brushed plenum cover only for it to have friggin rub marks on it in a couple of weeks!!
What about my strut tower brace?? Will the tower brace clear the plenum cover??

HazMatLadder26 is offline  
Sponsored Links
Advertisement
 
post #17 of 24 (permalink) Old 08-31-2006 Thread Starter
PONY Member
S197 Member
 
bigplayrayr's Avatar
 
Joined: Mar 2005
Location: Whitestown
Posts: 478
 
Quote:
Originally Posted by HazMatLadder26
I hope I just didnt spend 300 bucks on a Midwest Auto air brushed plenum cover only for it to have friggin rub marks on it in a couple of weeks!!
What about my strut tower brace?? Will the tower brace clear the plenum cover??

I have the Ford cover. I do not know what the differences are, but form just seeing pics, it looks like they mount differently.

I have read where you may have trouble with the strut clearing the cover, probably depends on the brand.


Ordered 4/26/05. Picked up June 11, 2005. 05 Mustang GT Premium Coupe, 5spd, Performance White, with red accent leather (ICAP), Shaker 500, IUP, active alarm, side airbag, spoiler delete. MODS: Baltimore Street Mods 10' red stripes and red rocker stripe. window tint. K & N aircharger. Pony Package fender emblems. Added 18" Polished Alum. Bullitts Hurst comp shifter
bigplayrayr is offline  
Apprentice
S197 Member
 
99vert's Avatar
 
Joined: Apr 2005
Location: Southeastern
Posts: 90
 
I have the Midwest cover and also have some black marks where it rubs. Unfortunatley I didn't find it until the damage was done. The insulation doesn't seem loose, so I would also be interested if anyone has a suggestion.

Redfire GT Deluxe, IUP, Charcoal leather, 5 Speed, Polished wheels, Sequential Taillights (custom designed), Redline Tuning Hood Struts, Shorty Antenna, Midwest Plenum Cover, Autovation Billet Pedal Covers, Ford Racing Chrome Exhaust Tips, Panasonic Head w/ color display, XM Direct, Scosche subwoofer w/ Rockford mono amp
99vert is offline  
 
S197 Member
 
HazMatLadder26's Avatar
 
Joined: Feb 2005
Posts: 538
 
Quote:
Originally Posted by 99vert
I have the Midwest cover and also have some black marks where it rubs. Unfortunatley I didn't find it until the damage was done. The insulation doesn't seem loose, so I would also be interested if anyone has a suggestion.
If you install a strut tower brace, the brace will keep the insulation from rubbing on the plenum cover. I would go with a single bar strut tower brace so the brace does not interfere too much with the visual you get from the plenum cover. I have a double bar tower brace and it kinda takes away from the graphics. Steeda makes a nice single bar for around 99 bucks. IMO. Good luck!
Attached Thumbnails
Click image for larger version

Name:	P8310044.JPG
Views:	85
Size:	383.8 KB
ID:	19238  
HazMatLadder26 is offline  
Apprentice
S197 Member
 
NorthernStang's Avatar
 
Joined: Jan 2005
Location: Kingsville
Posts: 100
 
Mine was rubbing too. I figured out that the insulation was sagging or flapping in the wind, so what I did was removed the insulation and then drilled two holes in the ribs of the braces that support the hood and then I installed a couple of those plastic push pins that I purchased at a local auto parts supply store. I'll take pictures tommorrow and post them for you guys.

2005 Redfire GT Premium, IUP & ICAP, 5-speed, anti-theft, and Shaker 500
Add-ons; Ignition Start Button, Blackout Panel,18" Casino rims by American Racing, Eibach Pro-kit, Roush Hood Scoop, Rear Quarter Louvers, Rear Spoiler, Front Fascia, Rockers, Billet Strut Tower Caps, Oil Cap, Rad Cap, Pedals, Painted Mirrors, 20% Tint, Flowmasters,
Roushcharger received and installed, just waiting for Spring...
NorthernStang is offline  
Apprentice
S197 Member
 
NorthernStang's Avatar
 
Joined: Jan 2005
Location: Kingsville
Posts: 100
 
Here's the pic.
Attached Thumbnails
Click image for larger version

Name:	Extra Pins.JPG
Views:	82
Size:	93.7 KB
ID:	19392  

2005 Redfire GT Premium, IUP & ICAP, 5-speed, anti-theft, and Shaker 500
Add-ons; Ignition Start Button, Blackout Panel,18" Casino rims by American Racing, Eibach Pro-kit, Roush Hood Scoop, Rear Quarter Louvers, Rear Spoiler, Front Fascia, Rockers, Billet Strut Tower Caps, Oil Cap, Rad Cap, Pedals, Painted Mirrors, 20% Tint, Flowmasters,
Roushcharger received and installed, just waiting for Spring...
NorthernStang is offline  
post #22 of 24 (permalink) Old 09-08-2006 Thread Starter
PONY Member
S197 Member
 
bigplayrayr's Avatar
 
Joined: Mar 2005
Location: Whitestown
Posts: 478
 
Good idea. Did you have to replace all the plastic fasteners under the hood. How hard to remove insulation?

Ordered 4/26/05. Picked up June 11, 2005. 05 Mustang GT Premium Coupe, 5spd, Performance White, with red accent leather (ICAP), Shaker 500, IUP, active alarm, side airbag, spoiler delete. MODS: Baltimore Street Mods 10' red stripes and red rocker stripe. window tint. K & N aircharger. Pony Package fender emblems. Added 18" Polished Alum. Bullitts Hurst comp shifter
bigplayrayr is offline  
Apprentice
S197 Member
 
NorthernStang's Avatar
 
Joined: Jan 2005
Location: Kingsville
Posts: 100
 
I reused the original plastic clips and I just popped them out with a flat headed screwdriver.

2005 Redfire GT Premium, IUP & ICAP, 5-speed, anti-theft, and Shaker 500
Add-ons; Ignition Start Button, Blackout Panel,18" Casino rims by American Racing, Eibach Pro-kit, Roush Hood Scoop, Rear Quarter Louvers, Rear Spoiler, Front Fascia, Rockers, Billet Strut Tower Caps, Oil Cap, Rad Cap, Pedals, Painted Mirrors, 20% Tint, Flowmasters,
Roushcharger received and installed, just waiting for Spring...
NorthernStang is offline  
S197 Member
 
Ants2005stang's Avatar
 
Joined: Jul 2005
Posts: 100
 
my plenum cover isn't touching. mine is the spark plug wire organizer started cutting it to it. I was kinda pissed until my S/C belt broke and tore the snot out of the hood liner.
Ants2005stang is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
will 5W-30 Synthetic oil hurt the engine if the engine states that it needs 5W-20only Eleanor_Mustang V6 Tech 7 11-01-2006 09:07 AM
Engine Oil Leak! please help desperate savegoodautonfg 5.0L Tech 7 08-26-2006 06:35 PM
How to build the engine... help plz... soccerpimp 5.0L Tech 4 06-28-2006 03:45 PM
Engine is running rough dolomite205 5.0L Tech 7 06-20-2006 08:49 PM
99 StangGT v/s Grand Marquis Engine Nemesis 4.6L Tech 2 05-04-2006 12:22 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1