I need soem help fast! - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 09-16-2006 Thread Starter
 
remy78's Avatar
 
Joined: Apr 2006
Posts: 35
 
I need soem help fast!

Ok i have a 2006 Mustang pony pkg, i took it in on thursday for the 5K maintance check, i get in it last night start it up and the horn won't stop going off...i shut it off start it again and it stopped, now today i go to leave and start it again and the horn again won't stop going off, i tried taking the fuse for the horn out and putting it back in...nothing, i tried taking the negative connection off of the battery but could not get the coller off of the battery?
Does anybody know what i can do so i won't have to drive to work in a hour with my horn going off the whole time? thanks!

remy78 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 09-16-2006
BOSS Member
4.6L Member
 
GTRaptor's Avatar
 
Joined: Apr 2002
Location: Mexico
Posts: 4,459
 
remove the RELAY, might be the easiest and that could be the problem-


Rob Hernandez, AFM co-Founder.
GTRaptor is offline  
post #3 of 5 (permalink) Old 09-16-2006
 
Sgt Beavis's Avatar
 
Joined: Aug 2006
Posts: 7
 
I'm betting that it is grounding out somewhere. Possibly a worn wire.

The other possibility is the switch in your steering wheel hub.
Sgt Beavis is offline  
 
post #4 of 5 (permalink) Old 09-16-2006 Thread Starter
 
remy78's Avatar
 
Joined: Apr 2006
Posts: 35
 
your'e talking about the relay that's in the Fuse box in the engine bay correct? i tried taking it out putting it back in, but not running it w/o it in...that won't do any harm to the engine/electrical? thanks guys!! (gotta go to work in 15mins don't wanna piss people off lol)
remy78 is offline  
post #5 of 5 (permalink) Old 09-16-2006 Thread Starter
 
remy78's Avatar
 
Joined: Apr 2006
Posts: 35
 
roger...removed the relay...hopefully no problems with driving it w/o the relay will come. thanks
remy78 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Muscle Mustangs & Fast Fords S197 Mustang Shootout TurboSteve 2005-2010 Mustang Talk 0 09-13-2006 07:35 PM
fast idle at cold start jjgt06 4.6L Tech 4 05-09-2006 08:45 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1