Horn Stopped Working - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 04-25-2019 Thread Starter
Rookie
 
tfrei550's Avatar
 
Joined: Apr 2019
Posts: 1
 
Horn Stopped Working

Hey all, first time post here.

I have a 2006 V6 Mustang where the horn has stopped working.

Last Sunday I went to start my car and the horn got stuck on almost immediately. I turned the car off and hit the horn and it turned off. I tried again with the same result. I turned the car off and went under the hood and pulled the relay.

When I finally got the chance to look at it, a day later, I plugged the relay back in and had no horn at all. I tried switching out a working fan relay of the same type and still no working horn. I checked the horn fuse with a test light and it's not blown. I also took the steering wheel apart and looked at the plates behind it and there seems to be nothing wrong there. Last, I went under the car and looked at the horns themselves and all connections look good.

I've read that it could be a problem with the clock spring but that usually comes with cruise control problems and airbag lights coming on. Anyone have any ideas on where to look next?

Thanks.

tfrei550 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-26-2019
GT Member
5.0L Member
S197 Member
 
my89foxbody's Avatar
 
Joined: Mar 2011
Location: Dracut
Posts: 1,312
 
Garage
Quote:
Originally Posted by tfrei550 View Post
Hey all, first time post here.

I have a 2006 V6 Mustang where the horn has stopped working.

Last Sunday I went to start my car and the horn got stuck on almost immediately. I turned the car off and hit the horn and it turned off. I tried again with the same result. I turned the car off and went under the hood and pulled the relay.

When I finally got the chance to look at it, a day later, I plugged the relay back in and had no horn at all. I tried switching out a working fan relay of the same type and still no working horn. I checked the horn fuse with a test light and it's not blown. I also took the steering wheel apart and looked at the plates behind it and there seems to be nothing wrong there. Last, I went under the car and looked at the horns themselves and all connections look good.

I've read that it could be a problem with the clock spring but that usually comes with cruise control problems and airbag lights coming on. Anyone have any ideas on where to look next?

Thanks.


I would use a jumper wire from battery + to the horn to see if they work, if they work then the issue is upstream from there. My initial thoughts were in the steering wheel



2014 GT Premium, Track Pack, Barton shifter, Borla S-type exhaust, Resonator delete, 3.73 gears, Airaid C.A.I., 93 Race Tune, JLT Oil Separator
my89foxbody is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in













Similar Threads
Thread Thread Starter Forum Replies Last Post
Speedometer stopped working Kc98gt 4.6L Tech 0 04-03-2016 06:18 PM
1968 Mustang horn wont sound quik Classic Tech 17 10-30-2010 01:41 PM
1968 Coupe Hood Turn Signal's Stopped Working sandagesr Classic Tech 3 09-10-2010 03:18 PM
power windows and convertible top stopped working storm83 2005-2010 Mustang GT Tech 5 05-15-2010 12:48 AM
HELP! Turn signals stopped working on my 1967 Mustang Edlanta Classic Tech 2 08-14-2009 10:54 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1