Smart Junction box - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 12-04-2019 Thread Starter
Rookie
 
earldavis1's Avatar
 
Joined: Sep 2019
Location: Los Lunas
Posts: 9
 
Send a message via AIM to earldavis1 Send a message via Skype™ to earldavis1
Smart Junction box

I experienced the fantastic water leak into the smart junction box. Everything when ging wow. One thing or another would stop working. I removed the junction box opened it up and cleaned and dried everything. I put it back in and everything seemed to work. After a couple of weeks, different things would quit working and then maybe start to work again. If I would disconnect and reconnect the wires from the SJB everything would work again. I thought it must be a connection. Then I was traveling through Utah at night in a snowstorm and every light on the car went out. I tried the disconnect re-connect and the lights would flash and go back out. Nothing was wet.
I ordered a new (not an Ebay used unit) and put it in. I reprogramed the key fobs and everything seemed to work.
Now to get to my point, In the morning or when the car has set and it is cold. I start the car and the fuel gauge or the speedometer either don't read or read wrong. I can go a little way and shut the engine off and restart it and everything works.
Do I need to have the dealer flash something and why does this only happen when it is cold

earldavis1 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 12-05-2019
Moderator
V6 Member
4.6L Member
5.0L Member
S197 Member
 
MustangLife's Avatar
 
Joined: Jan 2015
Location: North Carolina
Posts: 2,552
             
Garage
Hate you are having this issue, but it is very common unfortunately. I don't have a lot of experience as I haven't had the issue myself being I garage keep them and clean them out yearly to prevent it, but I know many members have. Have you done any searching on the forum as I know lots of threads and info on it. Either way hopefully a member that has had this problem will chime in soon.

Also looks like you relatively are new here. Welcome to AFM!


Current Garage
(11.)2012 GT500 silver with red stripe, SVT performance package, and Recaro seats.
2018 Honda Civic Type R
Past Mustangs in order and color of text.
(1.)2000, (2.)2004, (3.)2006GT/Auto traded for (4.)2006GT/Manual, (5.)1996, (6.)2011GT, (7.)2003GT, (8.)2006GT, (9)2013 Boss 302, and (10.) 2002GT
(I have owned a few non Mustang cars over the years as well, but always try to have a Mustang with it or come quickly back to a Mustang!)
MustangLife is offline  
post #3 of 3 (permalink) Old 12-06-2019
Apprentice
 
hobojack's Avatar
 
Joined: Oct 2013
Location: whiting
Posts: 56
 
What did you do to stop the water intrusion? If you did nothing it will be back. The sjb will start the car, it's the option content that has to be programmed.
hobojack is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1