Shaker 500 doesn't work - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 8 (permalink) Old 02-22-2010 Thread Starter
Rookie
 
ACROZIER's Avatar
 
Joined: Sep 2009
Location: Crozier
Posts: 21
 
Shaker 500 doesn't work

I have a 2007 Mustang Pony Package with the Shaker 500 stereo system.

For some odd reason, when I got in this morning to drive to work, the shaker 500 would not turn on. Blank screen, no clock no nothing. I freaked, since it has 6 CDs in it. I pushed buttons and managed to get the CD player to eject all CDs.

However, I never got power to the radio. Turned the ignition off then back on....still nothing.

Doesn't seem like it would be a fuse issue since the CD player portion has power, but the darned radio just won't turn on and nothing appears on the screen (no clock, no nothing) so it seems like something isn't getting power.

Help!!

ACROZIER is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 02-22-2010
Rookie
 
Leyteroc's Avatar
 
Joined: Dec 2009
Location: Miami
Posts: 48
 
Not sure what the problem is but i have a shaker 500 from a 2006 gt so if you need one i am willing to sell


- 2006 Mustang GT -
Leyteroc is offline  
post #3 of 8 (permalink) Old 02-22-2010
Rookie
 
speed_ga's Avatar
 
Joined: Oct 2009
Location: Hamptong
Posts: 27
 
did you check the fuse?
speed_ga is offline  
 
post #4 of 8 (permalink) Old 02-22-2010
Apprentice
V6 Member
S197 Member
 
Phillip 360's Avatar
 
Joined: Jul 2009
Location: Dallas
Posts: 202
 
I don't have a shaker 500 but after about 200 miles in my brand new 09 mustang, I had to get the radio completely replaced. It is apparently a common problem for those to malfunction.

09 Mustang V6 C/A Red with black racing stripes. Automatic. Under the Hood: JLT Cold-Air Intake, SCT 93 Octane Race Tune from Bamachips. Pypes True-Dual Exhaust w/ X-pipe and GT Takeoffs. Exhaust Cutouts. Interior: 10" Subwoofer 1,200 Watts, 1,200 Watt Insignia Amp. Chrome Auto Shifter Handles.
Best 0-60: 5.7 seconds with no traction from first gear.
Phillip 360 is offline  
post #5 of 8 (permalink) Old 02-22-2010
Rookie
 
lilcobraboy09's Avatar
 
Joined: Jan 2010
Location: Rio Rancho
Posts: 50
 
yea my shaker 500 has been nothing but problems. i would recommend just getting a whole new stereo :kooky:
lilcobraboy09 is offline  
post #6 of 8 (permalink) Old 02-23-2010
alwaysonjohn
Guest
 
alwaysonjohn's Avatar
 
Posts: n/a
i was changing my front speakers when mine refused to turn on. For myself, it was inspiration that led to the purchase of a jvc dvd player with bluetooth and ipod controls.
post #7 of 8 (permalink) Old 02-23-2010
Rookie
 
speed_ga's Avatar
 
Joined: Oct 2009
Location: Hamptong
Posts: 27
 
mines been great with no problems so far.
speed_ga is offline  
post #8 of 8 (permalink) Old 02-23-2010
Rookie
V6 Member
S197 Member
 
R08Vert's Avatar
 
Joined: Feb 2010
Location: Fort Wayne
Posts: 16
 
Quote:
Originally Posted by speed_ga View Post
mines been great with no problems so far.
famous last words mine skips for instance, and the same issue with mine in my 06 Ford Focus
R08Vert is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in













Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1