MPG DROP! Need advice! - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 14 (permalink) Old 10-13-2010 Thread Starter
Rookie
S197 Member
 
cooldue007's Avatar
 
Joined: Aug 2010
Location: Schaumburg
Posts: 8
 
MPG DROP! Need advice!

Hello everyone..

MY 2006 Stang used to give a healthy 22mpg all the time. It has dropped to 15mpg this week within a span of 2-3 days. Any reasons ? What should I get it checked for ?

cooldue007 is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 10-13-2010
GT Member
5.0L Member
 
MustangGTpower's Avatar
 
Joined: Jul 2010
Location: Danbury
Posts: 1,016
 
What type of gas are you putting into it? If you're putting 93 in or using octane boost/fuel injector cleaner too often you probably just killed the 02 sensors. Try diagnosing it and find out if the 02 sensors are bad, or if there are any other codes that may come up.


95' GT
331 cubes of fun
MustangGTpower is offline  
post #3 of 14 (permalink) Old 10-13-2010
PONY Member
5.0L Member
 
BT885.0's Avatar
 
Joined: Nov 2009
Location: South Central
Posts: 310
 
+1 on checking for codes on o2 sensors


"Cobalt SS Spoiler, 5 inch exhaust tip, neon green paint, underglow fx, side graphics, lambo doors"

lol
BT885.0 is offline  
 
post #4 of 14 (permalink) Old 10-14-2010
Apprentice
V6 Member
S197 Member
 
pjstripes's Avatar
 
Joined: Nov 2007
Location: Torrance
Posts: 208
 
If it's not the O2 sensors, and if you're over 30k, change the fuel filter and spark plugs.

My car stuttered during acceleration really bad and my mileage tanked like you describe.

Did the above (with oil change) and she's been running perfect since. Don't underestimate what a fuel filter change can do. It took all but 20 min to do my 1st time. Super simple; remove plastic cover; 2 clips; pull out the old one; clip in the new one in correct direction and the filter change is done.

But if you see codes for O2 sensors, then bingo. There's the culprit. Regardless, the fuel filter oughta be on your list cause if you let it get clogged up like I did, you will run into similar problems again.

2007 Silver V6 Auto 3345#
K&N CAI; Bama 91Race; ASP UDP; Flowmaster AT; FRPP TLock/410s; ScreaminDemonCoil; JBA PowerCables; Deka ETX14Battery; Mishimoto PerfRad; Steeda RadSupport; BMR KMem/AArms; JBA Shorties; Moroso Tanks; UPR LCAs
185# Wt Reduction 3160#
120# FRONT=EngineBraces 5#; Rad/Support 15#; Firewall/Fend/Hood Mat 5#; Intake 10#; UDP 5#; Battery/brace 25#; KMem/Arms 35#; Headers 15#; Tanks 5#
65# REAR=SpareTire 30#; TireJack/TBar/Trunk Lining/Floor/Molding 10#; Axle Wts 10#; LCAs 15#
pjstripes is offline  
post #5 of 14 (permalink) Old 10-14-2010
SHELBY GT 500 Member
 
amustangrocks's Avatar
 
Joined: Jul 2008
Location: Traverse City
Posts: 11,864
         
Quote:
Originally Posted by BT885.0 View Post
+1 on checking for codes on o2 sensors


"Cobalt SS Spoiler, 5 inch exhaust tip, neon green paint, underglow fx, side graphics, lambo doors"

lol
ha, when i was reading this thread i had the avatars blocked off the screen and i saw that sig, i had the same thought " what the %@#&"

05 V6 auto,
amustangrocks is offline  
post #6 of 14 (permalink) Old 10-14-2010
PONY Member
V6 Member
S197 Member
 
okcreferee's Avatar
 
Joined: May 2007
Location: OKC
Posts: 263
 
Also, what octane gas have you been using? Do you have a CAI and Tune? Be sure to run only 100% gas. Not the 10% ethanol crap. That will drop your MPG'S real bad and will ruin your fuel filter. Hope this helps.

2005 4.0
Sonic Blue Premium Coupe
Auto/Spoiler Delete
Ford Racing CAI
GT Takeoff Muffler
Silver Stripes
Ford Racing License Plate
okcreferee is offline  
post #7 of 14 (permalink) Old 10-14-2010
SHELBY GT 500 Member
 
amustangrocks's Avatar
 
Joined: Jul 2008
Location: Traverse City
Posts: 11,864
         
Quote:
Originally Posted by okcreferee View Post
Also, what octane gas have you been using? Do you have a CAI and Tune? Be sure to run only 100% gas. Not the 10% ethanol crap. That will drop your MPG'S real bad and will ruin your fuel filter. Hope this helps.
wow, welcome back, its been a while, nice to see you posting ya and beside the ethanol, its around the time they start putting some additives in the fuel for winter. i lost a couple mpg starting this week, but ive been letting the car warm up in the mornings before i leave for work. that kills the ave mpg, but i`m still at 21.5. might just be your fuel filter or something else.

05 V6 auto,
amustangrocks is offline  
post #8 of 14 (permalink) Old 10-14-2010
PONY Member
V6 Member
S197 Member
 
okcreferee's Avatar
 
Joined: May 2007
Location: OKC
Posts: 263
 
Yes Amustangrocks, I'm back. Sent you a PM. And yes Amustangrocks is correct about the "winter" gas additives also. Forgot about that.

2005 4.0
Sonic Blue Premium Coupe
Auto/Spoiler Delete
Ford Racing CAI
GT Takeoff Muffler
Silver Stripes
Ford Racing License Plate
okcreferee is offline  
post #9 of 14 (permalink) Old 10-18-2010
GT Member
5.0L Member
 
MustangGTpower's Avatar
 
Joined: Jul 2010
Location: Danbury
Posts: 1,016
 
Quote:
Originally Posted by amustangrocks View Post
ha, when i was reading this thread i had the avatars blocked off the screen and i saw that sig, i had the same thought " what the %@#&"
Yeah I havent updated my picture yet... whats wrong with that

95' GT
331 cubes of fun
MustangGTpower is offline  
PONY Member
 
Ducatti20's Avatar
 
Joined: May 2010
Location: Phoenix
Posts: 403
 
Quote:
Originally Posted by cooldue007 View Post
Hello everyone..

MY 2006 Stang used to give a healthy 22mpg all the time. It has dropped to 15mpg this week within a span of 2-3 days. Any reasons ? What should I get it checked for ?
I sometimes see several miles to gallon drop in fule mileage and almost always it is the fuel I put in and the weight of my right foot.

1967 C Code Coupe

Retired
86 Lx 2.3
89 Gt Vert
95 Gt
10 V6
96 GT Vert
Ducatti20 is offline  
post #11 of 14 (permalink) Old 11-01-2010 Thread Starter
Rookie
S197 Member
 
cooldue007's Avatar
 
Joined: Aug 2010
Location: Schaumburg
Posts: 8
 
:D

Thank you for the replies !!

It was very useful.. I will get the O2 checked and also the fuel filter replaced.

I am using the 87 octane fuel!

I will update once it is set right ! thanks a ton again stang owners
cooldue007 is offline  
PONY Member
V6 Member
S197 Member
 
Corban227's Avatar
 
Joined: Apr 2009
Location: Fullerton
Posts: 495
 
+5000000000000 to fuel filter btw

gave me a 160 extra miles per tank when i switched mine out

2006 V6 Mustang
Ext. Vis: Mineral Grey w/ Yellow Stripes, Tinted windows, Shorty Antenna, Brake light chrome outline, Custom installed Fog Lights.
Int. Custom Vis: Yellow/Black Carbon fiber kit, 7 color LED ambient lights, Shaker 500 with PIE module connected to a Belkin Ipod Charger cradle.
Pref Mods: Bamachips 91 race+torque tune, C&L CAI, Custom dual exhaust w/ MAC stainless steel mufflers, Front and rear GT sway bar, Shelby strut tower brace, GT take-off shocks and struts.
Corban227 is offline  
PONY Member
 
GrrrraaberU3's Avatar
 
Joined: Dec 2009
Location: Woods
Posts: 448
 
93 octane is bad for the sensors?

2008 Mustang V6 Grabber Orange
Performance: JLT CAI and Bama Tune, Dynomax Dual exhaust, Shorty Headers, Screamin' Demon coil and Livewires, Oil Catch Can,Shaker Hood Scoop
Looks: Quater Window Louvers, Shorty Antenna, GT Front Grille and Bumper, Tint,Painted Mirror Covers, Chrome door pins, Pony floor mats, LED Footwells, 4.0 Emblems, Stealth Mud Flaps, Sequentials, Chrome Cupholder Bezel, Grabber orange trim, 12"racing stripes with pinstripes, GT rocker panels, GT takeoff 18" aluminum wheels
GrrrraaberU3 is offline  
PONY Member
 
Ducatti20's Avatar
 
Joined: May 2010
Location: Phoenix
Posts: 403
 
Quote:
Originally Posted by Corban227 View Post
+5000000000000 to fuel filter btw

gave me a 160 extra miles per tank when i switched mine out
Holy crap!!! That's a dirty fuel filter!!!

Quote:
Originally Posted by V6 Mafia View Post
93 octane is bad for the sensors?
Not that I've EVER heard.... the engine is designed for 87, but 93 shouldn't hurt it one bit...

1967 C Code Coupe

Retired
86 Lx 2.3
89 Gt Vert
95 Gt
10 V6
96 GT Vert
Ducatti20 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1