Engine stability problems - Ford Mustang Forum
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 07-17-2014 Thread Starter
Rookie
 
Frydokmustang's Avatar
 
Joined: Jul 2014
Location: Miami
Posts: 22
 
Engine stability problems

hi all I'm new to the forum. Some will say that with all the problems I have is better mustang junk. lol well the first thing is that the car turned over and oil everywhere. any recommendation to check. the car starts but shakes a lot

Frydokmustang is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 07-17-2014
PONY Member
V6 Member
S197 Member
 
Duane2009's Avatar
 
Joined: Mar 2011
Location: Hays
Posts: 654
 
Visually check all the mounts. One of mine broke a few years ago and shook the car like crazy.

Oil everywhere? When was the last oil change? Did you check for the filter gasket when you changed the filter? Those are the quickest checks I can think of. Otherwise, could be pretty serious.


2006 Mustang V6 Pony Package Vista Blue with a 5-speed (Michele)
Go: BBK 70mm throttle body, BBK CAI, single custom exhaust (maxflow muffler) with polished 4" tip, SCT Tuner w/ 91 RT, SR TB Spacer, Custom made cold air bucket, Spec Stage II Clutch and SF66A Flywheel
Show: White rocker stripes, Kaenen Mach 1 Style hood, painted underhood parts/covers, Muffler tip, white stripes after heat reduction ports.
Own but not insalled- Polished Shorty Headers
Future-looking for 2007-08 F150
Duane2009 is offline  
post #3 of 5 (permalink) Old 07-17-2014 Thread Starter
Rookie
 
Frydokmustang's Avatar
 
Joined: Jul 2014
Location: Miami
Posts: 22
 
All mounts are fine. I put the new oil filter. That was what I meant the oil came out throttle body
Frydokmustang is offline  
 
post #4 of 5 (permalink) Old 07-17-2014
Rookie
 
anfojo's Avatar
 
Joined: Dec 2009
Location: Shelton
Posts: 9
 
Do you mean to say, the car rolled over??? There my be oil in the cylinders...
anfojo is offline  
post #5 of 5 (permalink) Old 07-17-2014 Thread Starter
Rookie
 
Frydokmustang's Avatar
 
Joined: Jul 2014
Location: Miami
Posts: 22
 
Yes I do. I need to do to save the engine
Frydokmustang is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1