2011-2014 5.0 V8 - does yours have a "tick" after fully warmed up? - Page 56 - Ford Mustang Forum
View Poll Results: Does your 2011-2014 Mustang 5.0 have a tick after fully warmed up?
Yes 316 43.77%
No 406 56.23%
Voters: 722. You may not vote on this poll

Like Tree6Likes
Reply
 
LinkBack Thread Tools
Rookie
 
Verty13's Avatar
 
Joined: Jul 2019
Posts: 8
 
74K on newly purchased '13 GT convertible. No tick. 6/6/12 build date, original 5.0 powerplant, 1 previous owner.

10grabber horse likes this.
Verty13 is offline  
Sponsored Links
Advertisement
 
Sponsored Links
Advertisement
 
Reply

Tags
coyote , help engine , ticking , ticking lifter

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Mustang Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a VALID email address for yourself, otherwise you will not receive the necessary confirmation email needed to confirm, validate and activate your new AFM member account.

Failure to provide a VALID email address, will result in the cancellation of your new AFM member account registration.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Search Engine Friendly URLs by vBSEO 3.6.1